-   Linux - Networking (
-   -   ath9k + ar9280 oddness (

bobb.harley 01-31-2010 05:55 PM

ath9k + ar9280 oddness
History of the Problem:
I was at Milwaukee Airport earlier this week, authenticated with their AP but was unable to get an IP address. I killed wpa_supplicant and went to run it again, this time, there was no authentication. Running 'iwlist wlan0 scan' returned with no results. This has been the case everywhere since then. The card was working like a champ up until that fateful day @ MKE.
I upgraded my kernel to today in an attempt to get my roommate's rt3572 USB wifi card running to no avail, but this is a separate issue. The onboard Atheros 9280 card worked under the default Slack64 13 kernel. I also tested the card under Ubuntu 9.10 and Backtrack 4 live distros, neither of those worked. I took a peek at the physical wireless card and the antennae are securely fastened. The laptop is a Dell Studio 1440/14z.
Current Status:
  • uname -rmp
    Code: x86_64 Intel(R) Core(TM)2 Duo CPU    T6500  @ 2.10GHz
  • lshw -C network

    *-network DISABLED
          description: Wireless interface
          product: AR928X Wireless Network Adapter (PCI-Express)
          vendor: Atheros Communications Inc.
          physical id: 0
          bus info: pci@0000:11:00.0
          logical name: wlan0
          version: 01
          serial: 00:22:5f:be:ee:ff
          width: 64 bits
          clock: 33MHz
          capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
          configuration: broadcast=yes driver=ath9k latency=0 multicast=yes wireless=IEEE 802.11abgn
          resources: irq:21 memory:f0300000-f030ffff

  • lsmod|grep ath

    ath9k                277645  0
    ath                    8336  1 ath9k
    mac80211              159642  1 ath9k
    cfg80211              119362  3 ath9k,ath,mac80211
    led_class              2545  1 ath9k

  • dmesg|grep -e ath -e wlan

    md: multipath personality registered for level -4
    ath9k 0000:11:00.0: PCI INT A -> Link[Z00N] -> GSI 21 (level, low) -> IRQ 21
    ath9k 0000:11:00.0: setting latency timer to 64
    ath: EEPROM regdomain: 0x60
    ath: EEPROM indicates we should expect a direct regpair map
    ath: Country alpha2 being used: 00
    ath: Regpair used: 0x60
    phy1: Selected rate control algorithm 'ath9k_rate_control'
    Registered led device: ath9k-phy1::radio
    Registered led device: ath9k-phy1::assoc
    Registered led device: ath9k-phy1::tx
    Registered led device: ath9k-phy1::rx
    ADDRCONF(NETDEV_UP): wlan0: link is not ready

  • ifconfig -a

    eth0      Link encap:Ethernet  HWaddr 00:24:e8:ff:ff:ff
              inet addr:  Bcast:  Mask:
              inet6 addr: fe80::224:e8ff:feff:ffff/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:24571 errors:0 dropped:0 overruns:0 frame:0
              TX packets:16602 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:29732786 (28.3 MiB)  TX bytes:1892432 (1.8 MiB)
              Interrupt:29 Base address:0xe000

    lo        Link encap:Local Loopback
              inet addr:  Mask:
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:34 errors:0 dropped:0 overruns:0 frame:0
              TX packets:34 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:1820 (1.7 KiB)  TX bytes:1820 (1.7 KiB)

    wlan0    Link encap:Ethernet  HWaddr 00:22:5f:ff:ff:ff
              BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

    *** Note the lack of wmaster0. ***
  • ifconfig wlan0 up

    SIOCSIFFLAGS: Unknown error 132
At this point I'm pretty much stuck on:
1) Why isn't wmaster0 showing up?
2) In the previous kernel, ath_pci was loaded and things seemed to be working, could this be part of the problem?
- It sounds like the new version of the kernel shouldn't require the madwifi driver....?
3) Classes start tomorrow and me wifi isn't working...yaargh! :-)

- Harley

Chuck56 02-02-2010 10:13 AM

As of 2.6.32 wmaster0 is no longer created:

Instead of using the Mad-WiFi drivers why don't you try the more up to date compat-wireless drivers.

Here's an Ubuntu support thread on the topic.

bobb.harley 02-09-2010 06:54 AM

So I still haven't gotten the onboard card working. Instead, I picked up a Linksys WUSB54G USB stick. Getting that setup was easy with the rt2870 driver.

All times are GMT -5. The time now is 12:41 PM.