-   Linux - Networking (
-   -   Apache will not start. (

MercuryRaz0r 11-02-2004 12:18 AM

Apache will not start.
Hello, all. I would like some help regarding my web server. When i click for apache to start (Start Apache), it gives me this error message back:

Failed to start apache :

Starting httpd2: [ OK ]

And thats it. Nothing seems to happen. I've tried reinstalling apache, but that hasnt worked.

Any ideas?

ps. im using Mandrake Linux 10.1, KDE. Webmin, too.

m4dj4ck 11-02-2004 01:32 AM

try to be more verbose. which version of apache2 did you install? did you install it from .rpm format or source package? We cant help you much if you didnt provide us more information. Cheers!

MercuryRaz0r 11-02-2004 09:45 AM

It is Apache version 1.3.31, it came with Mandrake Linux 10.1. I'm a Linux noob, so I dont know how to install a source copy, i only know how to install RPM packages. It seemed to be working until I changed a setting incorrectly. What I think that setting was Networking and Addresses. The Apache server was up, and I clicked the wrong option (of the three options None, All, [blank text box]) in the Address/Port Table. I think I clicked the blank text box option, and for port it was already set for port 80. I saved. Then I clicked "apply changes" thats when i got an error message that basically said "you jackass, you didnt type anything in the text box." I selected the "All" option still using port 80, then saved. When it went back to apache's page, I noticed that it said "start Apache" instead of "Apply Changes" So I clicked Start Apache and It's given me this error message since.

I've tried shutting down httpd and reloading it, shutting it down and then trying apache, restarting the computer, reinstalling apache, and I've found that nothing seems to work. My next course of action will have to be uninstalling apache completely and reinstalling it, instead of installing a copy over the existing one.

DavidPhillips 11-02-2004 02:37 PM

look in the log files in /var/log/httpd for some error that says what's wrong.

MercuryRaz0r 11-02-2004 04:58 PM

It says a lot of things, but what appears to mainly be wrong is an error message that repeats itself a couple times each time I try to start the apache server.

[Tue Nov 02 00:55:51 2004] [alert] (2)No such file or directory: getpwuid: couldn't determine user name from uid 4294967295, you probably need to modify the User directive

What/where is the User directive? I found a "Directives" section in Apache, but couldn't find what it was talking about.

DertyolBA$HTARD 11-03-2004 07:19 AM

I think that defines which user the httpd daemon runs as/is owned by.

use less httpd.conf
and then the functionality of less (/string search forward), to find user

MercuryRaz0r 11-03-2004 11:09 AM

i have no idea what any of that means.

DertyolBA$HTARD 11-04-2004 09:10 AM

You don't know what what means?

how to use less?

All times are GMT -5. The time now is 04:11 AM.