LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 04-28-2003, 09:16 PM   #1
SSBN
Member
 
Registered: Apr 2003
Posts: 80

Rep: Reputation: 15
Apache web page posting help


Ok I am in the proses of setting up apache to host a web site I made. Here is what I have completed so far.

1: sco Linux server has bin installed and updated and webmin is set up.
2: the computer has a connection to the internet. It is behind my firewall and the web page has no access to the outside world. I want to se the web page internally on my network before I tackle posting it for the rest of the world.
3: I have set up an additional ip address to my nick. It is 192.168.10.200
4: I have added a virtual domain. With the address being 192.168.10.200
The port I left at 80
5: document root. I pointed it to /home/httpd/testweb
When I go to my web browser on another computer on my network and type in http://192.168.10.200 I get this error.
Forbidden
You don't have permission to access / on this server.

Apache/1.3.27 Server at bogus_host_without_reverse_dns Port 80

Other info
My index file is called index.html
It is in the /home/httpd/testweb dir
There are two other folders in the dir which have all the web pages pictures tables text ect.

Can someone help me out with what I am missing thanks.
 
Old 04-28-2003, 09:20 PM   #2
Crashed_Again
Senior Member
 
Registered: Dec 2002
Location: Atlantic City, NJ
Distribution: Ubuntu & Arch
Posts: 3,503

Rep: Reputation: 57
Sounds like a permissions problem to me. What distro are you using? Any special reason for using /home/httpd/testweb?

Check the permissions on those directories.
 
Old 04-28-2003, 09:28 PM   #3
SSBN
Member
 
Registered: Apr 2003
Posts: 80

Original Poster
Rep: Reputation: 15
I just added the dir because. No real reason other than organizing where the web page is. How do I add permissions to the dir.? and what should they be.

also when i type in the web page should i just type in http://192.168.10.200 or should i include my index.html file in there. http://192.168.10.200/index.html

Last edited by SSBN; 04-28-2003 at 09:34 PM.
 
Old 04-28-2003, 09:46 PM   #4
SSBN
Member
 
Registered: Apr 2003
Posts: 80

Original Poster
Rep: Reputation: 15
do i have to set up Per-Directory Options.
 
Old 04-28-2003, 10:15 PM   #5
Crashed_Again
Senior Member
 
Registered: Dec 2002
Location: Atlantic City, NJ
Distribution: Ubuntu & Arch
Posts: 3,503

Rep: Reputation: 57
Well I'd say scratch the /home/httpd/testweb thing. Go into your /etc/httpd/conf/httpd.conf file and make sure it has:

DocumentRoot "/var/www/html"

and

DirectoryIndex index.html

Move your index.html file into /var/www/html (where all your web files should be) and then restart apache:

/etc/init.d/httpd restart

You should then be able to go to http://192.168.10.200 . You don't have to type index.html at the end of it. The line 'DirectoryIndex index.html' means if that file is in the directory being access then it defaults to index.html .
 
Old 04-28-2003, 10:16 PM   #6
SSBN
Member
 
Registered: Apr 2003
Posts: 80

Original Poster
Rep: Reputation: 15
I fixed it. This is strange. When the index file was Index.html it wouldn't work. When it was index.html it did. It didn't like the index file heaving a capital i. Strange.
 
Old 04-28-2003, 10:19 PM   #7
Crashed_Again
Senior Member
 
Registered: Dec 2002
Location: Atlantic City, NJ
Distribution: Ubuntu & Arch
Posts: 3,503

Rep: Reputation: 57
Nah remember linux is case sensitive.
 
Old 04-28-2003, 10:28 PM   #8
SSBN
Member
 
Registered: Apr 2003
Posts: 80

Original Poster
Rep: Reputation: 15
My brain had stopped and I forgot. I was looking at the default web page you get with openlinux and trying to figure out why it worked and mine didn't. I put the index files side by side to se if there was a diff. Well hahahaha there was. i not I

Thanks for all you help and time guys.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache not showing web page harisund Linux - Software 3 11-25-2005 12:31 PM
Apache web page not working fordb37 Linux - Newbie 1 02-24-2005 09:27 AM
web page with apache regnier Linux - Networking 3 02-15-2005 09:49 PM
Apache 2.0.52 funny characters on web page mnauta Linux - Networking 1 12-03-2004 12:24 AM
Apache web page - refresh dvong3 Linux - General 7 06-26-2003 01:36 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 03:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration