-   Linux - Networking (
-   -   apache, process owner, and rsync/ssh question (

Kruel 03-01-2002 01:25 PM

apache, process owner, and rsync/ssh question
I am running an apache server on a linux machine.
Clients can connect to this server in their browser, and i'd like one of their possible actions to be copying files from this server to another linux server, using rsync through ssh.
The problem is that the apache user is "nobody" and is not recognised by ssh.

i've tried defining a "nobody" home and put a key in the .ssh, then authorize it on the remote server, but it doesn't work.

i've also tried writing the rsync command in a shell script owned by an authorized user on the second machine, and changed its mode with the setuserid bit (rws).
I thought this was supposed to make that whoever was running the script, the process owner would still be the script owner, but it doesn't work.

Can anyone help ? It looks like such a simple thing to do and i've spent hours and hours trying to do this...

thanks in advance

All times are GMT -5. The time now is 08:47 AM.