Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Networking
User Name
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.


  Search this Thread
Old 07-10-2004, 08:21 AM   #1
LQ Newbie
Registered: Jun 2004
Posts: 13

Rep: Reputation: 0
Apache only works on localhost


I have the following problem:

I run Redhat 9 and apache 2. When I open localhost on my linuxbox, I see the standard welcom message from apache.

But on my network, I don't see that page when I request it.

I can ping from and to my linux box.

httpd.conf is set to listen 80.

Can anybody help me! What should I test to isolate the problem.

Old 07-10-2004, 08:45 AM   #2
LQ Newbie
Registered: Feb 2004
Location: London
Distribution: Fedora Core 3
Posts: 18

Rep: Reputation: 0
From the network you have to use the ip address of your RH box, as follows - in your browser address bar

And if you want use the computer name (of the RH box) on the network, you will have to set up dns
Old 07-10-2004, 10:43 AM   #3
LQ Newbie
Registered: Jun 2004
Posts: 13

Original Poster
Rep: Reputation: 0
Sure, I know.

But it just doesn't give me the webpages.

What could it be?
Old 07-10-2004, 11:16 AM   #4
LQ Guru
Registered: Mar 2004
Distribution: Slackware
Posts: 6,230

Rep: Reputation: 714Reputation: 714Reputation: 714Reputation: 714Reputation: 714Reputation: 714Reputation: 714
tail -f /var/log/apache/errors_log
while you try to access web pages to see if it logs the problem and you may check how access comes also :
tail -f /var/log/apache/access_log
Old 07-10-2004, 12:06 PM   #5
Senior Member
Registered: Mar 2003
Location: Beautiful BC
Distribution: RedHat & clones, Slackware, SuSE, OpenBSD
Posts: 1,791

Rep: Reputation: 50
could be your iptables are not letting in http traffic.
Old 07-10-2004, 09:55 PM   #6
Registered: Jul 2004
Distribution: Gentoo
Posts: 101

Rep: Reputation: 15
Try running it on port 8080 or some other alternate port, just to see if that works.
Old 07-11-2004, 01:17 AM   #7
Registered: Oct 2003
Distribution: Just about anything... so long as it is Debain based.
Posts: 297

Rep: Reputation: 30
Firewall issue...

The issue is probably your local firewall. You'll need to open port 80 for the web traffic.

Since you're runing Redhat9 it can be done like this:

Go to your Red Fedora Menu

Choose System Settings

Under that choose Security Level

Make sure that if a firewall is enabled that the Allow Incoming has WWW (HTTP) checked

Hope that helps!

Old 07-11-2004, 11:17 AM   #8
LQ Newbie
Registered: Jun 2004
Posts: 13

Original Poster
Rep: Reputation: 0
Hi Mark,

Cool, that was it. Security was set to high on install, but also http was enableled.
I ran the firewall config tool (in text mode) and enabeled http traffic.

Old 07-12-2004, 03:29 AM   #9
LQ Newbie
Registered: Feb 2004
Location: Singapore
Posts: 5

Rep: Reputation: 0
you can only see it on your local host machine.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mail from Apache being rejected - Cannot route to sender apache@localhost.localdomain jimwillsher Linux - Networking 2 01-19-2006 01:41 AM
can't ping localhost, Internet works fine drowstar Linux - Networking 5 01-04-2005 04:09 PM
Apache works localhost but not over the internet newuser455 Red Hat 4 05-22-2004 12:04 PM
proftpd - localhost works. but can't connect from a PC on the network cevjr Linux - Networking 6 02-22-2004 05:44 PM
SSH To IP Address Fails - Localhost Works ViragoRider Linux - Newbie 7 10-03-2003 08:19 AM > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 09:55 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration