LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 10-12-2016, 07:52 PM   #1
TBotNik
Member
 
Registered: May 2016
Location: Greenville, TX
Distribution: Kubuntu 18.04
Posts: 793

Rep: Reputation: Disabled
Apache Issue - I think


All,

Been struggling to get the browser to work on my Aspire Laptop running Kubuntu 14.04 LTS. There are no errors in the logs, when I restart apache2, but localhost will not enable and any website with "index.*" as the home page will not work, just get errors, however I've managed to get Google to work and therefore been able to trick sites into giving me info.

EX:
blueletterbible.org errors so can not use it's home page. To trick it and get answers, in Google I enter:

blueletterbible.org Rom 8:32

and I will then get the Google list which I can click on to get the information being sought.

I put all applicable file on pastebin at:

http://pastebin.ca/3727003

I'm at my wits end on this and not much of an Apache hack, so really stumping and frustrating me, so any help appreciated.

Thanks!

TBNK
 
Old 10-12-2016, 09:37 PM   #2
c0wb0y
Member
 
Registered: Jan 2012
Location: Inside the oven
Distribution: Windows
Posts: 417

Rep: Reputation: 74
I would love to help and English is also not my native language but sorry I am unable to comprehend much of it.
 
Old 10-12-2016, 09:54 PM   #3
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Ubuntu MATE, Mageia, and whatever VMs I happen to be playing with
Posts: 19,216
Blog Entries: 28

Rep: Reputation: 6114Reputation: 6114Reputation: 6114Reputation: 6114Reputation: 6114Reputation: 6114Reputation: 6114Reputation: 6114Reputation: 6114Reputation: 6114Reputation: 6114
If I understand correctly, the issue is that you cannot directly access blueletterbible.org in your browser, but can access it via a web search. If that is a correct understanding, I cannot duplicate your issue, as I can access blueletterbible.org quite nicely on both FreeBSD and on Slackware --Current with Firefox.

I puzzled as to how your running apache on your local machine could have any bearing whatsoever on your accessing a public website via your browser. I will note I am running httpd on the Slackware machine.

Can you clarify specifically why you think the two are related?
 
Old 10-13-2016, 02:11 PM   #4
Habitual
LQ Veteran
 
Registered: Jan 2011
Location: Abingdon, VA
Distribution: Catalina
Posts: 9,374
Blog Entries: 37

Rep: Reputation: Disabled
What happens using https://www.blueletterbible.org/ instead of blueletterbible.org in your browser tab?

Rom 8:32 search works there, from here.

Last edited by Habitual; 10-13-2016 at 02:17 PM.
 
Old 10-13-2016, 03:05 PM   #5
TBotNik
Member
 
Registered: May 2016
Location: Greenville, TX
Distribution: Kubuntu 18.04
Posts: 793

Original Poster
Rep: Reputation: Disabled
Every Site

All,

No this problem exists for every single site that has an index.* or home.* as it's default home page. I used blueletterbible.org as an example only!

Thanks!

TBNK
 
Old 10-13-2016, 03:18 PM   #6
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 19,872
Blog Entries: 12

Rep: Reputation: 6052Reputation: 6052Reputation: 6052Reputation: 6052Reputation: 6052Reputation: 6052Reputation: 6052Reputation: 6052Reputation: 6052Reputation: 6052Reputation: 6052
Quote:
Originally Posted by TBotNik View Post
when I restart apache2, but localhost will not enable and any website with "index.*" as the home page will not work
you do not need apache to browse the web from your home machine!!!
if you really installed apache on a desktop machine, i think you should just uninstall it, update the system, reboot & hope for the best.
if the best does not happen, i suggest a reinstall.
 
Old 10-13-2016, 04:42 PM   #7
Habitual
LQ Veteran
 
Registered: Jan 2011
Location: Abingdon, VA
Distribution: Catalina
Posts: 9,374
Blog Entries: 37

Rep: Reputation: Disabled
ondoho is right.
Apache2 - remove it from your local system if you aren't hosting sites.
Also try a new browser profile and or system user
 
Old 10-17-2016, 01:24 PM   #8
TBotNik
Member
 
Registered: May 2016
Location: Greenville, TX
Distribution: Kubuntu 18.04
Posts: 793

Original Poster
Rep: Reputation: Disabled
Ondoho & Habitual,

No I do web development and in particular framework/oop extensions, which require localhost so that's a must for me. However for your information the problem still exists when I stop apache2 with cmd:
service apache2 stop
So guessing the browsing part is a different issue from the apache2 problem. However localhost could be part of the browser issue, why the localhost index.php file is not processing.

Cheers!

TBNK

Last edited by TBotNik; 10-17-2016 at 01:27 PM.
 
Old 10-17-2016, 01:31 PM   #9
TBotNik
Member
 
Registered: May 2016
Location: Greenville, TX
Distribution: Kubuntu 18.04
Posts: 793

Original Poster
Rep: Reputation: Disabled
All,

I run 20 machines and this problem is unique to only my Aspire 7739 laptop. All other machines are fine. I have checked the browser and apache2 configs on all the machines, which are all the same as the laptop, as far as I can tell, so that is why I'm stumped here, since I have this anomaly!

PS
Cannot even get to this forum, via the laptop, so working this from one of my 2 servers.

Cheers!

TBNK

Last edited by TBotNik; 10-17-2016 at 01:34 PM.
 
Old 10-17-2016, 06:03 PM   #10
c0wb0y
Member
 
Registered: Jan 2012
Location: Inside the oven
Distribution: Windows
Posts: 417

Rep: Reputation: 74
If I understand it correctly, you are developing a webapp on that particular laptop and you would like to deploy it on a local Apache which is a fairly standard setup. The problem you seem to be having is you are unable to preview the webapp with index pages such as index.php. (Also, you have secondary issue which is your inablity to browse external sites)

What did you see when you point your browser to http://127.0.0.0 ? What error messages you get? Does it render any material, php text or not? If Apache php module is not enabled, you would not be able to see the sites correctly but it won't stop the browser from rendering contents including plain text. If you see any content that seems to be your webapp, that is already a good sign. If not, you have a bit of troubleshooting ahead of you.
 
Old 10-18-2016, 04:11 AM   #11
Habitual
LQ Veteran
 
Registered: Jan 2011
Location: Abingdon, VA
Distribution: Catalina
Posts: 9,374
Blog Entries: 37

Rep: Reputation: Disabled
Sounds like you don't have a DirectoryIndex set in your site.conf
 
Old 10-18-2016, 08:00 PM   #12
TBotNik
Member
 
Registered: May 2016
Location: Greenville, TX
Distribution: Kubuntu 18.04
Posts: 793

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Habitual View Post
Sounds like you don't have a DirectoryIndex set in your site.conf
Habitual,

Well yes there is no "site.conf" file on any of my machines.

You must be talking about another Linux fork. I'm on Kubuntu 14.04 LTS.

Cheers!

TBNK
 
Old 10-19-2016, 11:06 AM   #13
TBotNik
Member
 
Registered: May 2016
Location: Greenville, TX
Distribution: Kubuntu 18.04
Posts: 793

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by c0wb0y View Post
If I understand it correctly, you are developing a webapp on that particular laptop and you would like to deploy it on a local Apache which is a fairly standard setup. The problem you seem to be having is you are unable to preview the webapp with index pages such as index.php. (Also, you have secondary issue which is your inablity to browse external sites)

What did you see when you point your browser to http://127.0.0.0 ? What error messages you get? Does it render any material, php text or not? If Apache php module is not enabled, you would not be able to see the sites correctly but it won't stop the browser from rendering contents including plain text. If you see any content that seems to be your webapp, that is already a good sign. If not, you have a bit of troubleshooting ahead of you.
c0wb0y,

I get the message:

************************************************************************

Unable to connect

Firefox can't establish a connection to the server at 127.0.0.0.

The site could be temporarily unavailable or too busy. Try again in a few moments.
If you are unable to load any pages, check your computer's network connection.
If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.

************************************************************************

That is shown just after restarting apache2!

Cheers!

TBNK
 
Old 10-19-2016, 01:20 PM   #14
Habitual
LQ Veteran
 
Registered: Jan 2011
Location: Abingdon, VA
Distribution: Catalina
Posts: 9,374
Blog Entries: 37

Rep: Reputation: Disabled
Quote:
Originally Posted by c0wb0y View Post
What did you see when you point your browser to http://127.0.0.0 ?
Correction, I think? > http://127.0.0.1
 
Old 10-19-2016, 01:21 PM   #15
Habitual
LQ Veteran
 
Registered: Jan 2011
Location: Abingdon, VA
Distribution: Catalina
Posts: 9,374
Blog Entries: 37

Rep: Reputation: Disabled
Quote:
Originally Posted by TBotNik View Post
Habitual,

Well yes there is no "site.conf" file on any of my machines.
terminal>
Code:
sudo apache2ctl -S
In that output there should be a .conf listed.
Use "grep DirectoryIndex" on it.
DirectoryIndex controls "home*" and "index*" pages.

Does it exist?

Last edited by Habitual; 10-19-2016 at 01:23 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Issue with Apache? your_shadow03 Linux - Newbie 2 04-23-2009 11:38 PM
Apache issue plk Linux - Server 2 04-14-2008 10:30 AM
apache issue kidswipe Linux - Server 8 07-09-2007 09:16 AM
Is this an apache issue? opsraja Linux - Networking 1 03-03-2005 12:03 AM
apache issue... Robin01 Linux - Newbie 3 09-21-2003 07:12 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 09:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration