LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 03-07-2003, 02:29 PM   #1
tenraek
LQ Newbie
 
Registered: Mar 2003
Posts: 23

Rep: Reputation: 15
Apache fails on boot in RH8


I'm currently trying to get Apache to load on boot in RH8. It is installed as a service, and is cheked for startup on boot.

-I tried doing this with Apache 2.0 which obviouslt came with RH8 when I installed it, but when that was failing

- I thought maybe I hadn't gotten a full install of it, so I downloaded and installed the latest release from apache.org. It does work, because I can manually start it in terminal, but it still fails on boot.

I am using this with dyndns.org, which I know is also working correctly as after I start httpd manually, I can go to nhti.homeip.net and I get the apache welcome page.

Since I am a nebie with Linux, please be very specific with commands/ paths, as some of the stuff that should be obvious to me (since I figured it out before), hasn't quite clicked fully in my brain yet.
 
Old 03-07-2003, 02:47 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,692

Rep: Reputation: 232Reputation: 232Reputation: 232
What error messages you get? Look into /var/log/messages and see if you can find Apache fail messages.

The simpliest method to start it at boot: put the command you use to start Apache from console into /etc/rc.d/rc.local (at the end of the file).
 
Old 03-07-2003, 03:00 PM   #3
tenraek
LQ Newbie
 
Registered: Mar 2003
Posts: 23

Original Poster
Rep: Reputation: 15
Thank you for the prompt reply. I'll try your suggestion of putting the cmd in that file.

As for the error I'm getting, this is taken right from /var/log/messages:
Mar 7 14:47:08 x1-6-00-e0-18-3d-60-6c httpd: httpd startup failed

In the words of George Carlin: "Well isn't this being a little vague?"
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Help getting Apache going on RH8 ozstar Red Hat 2 01-29-2004 04:27 PM
i Got 1 Harddisk with Win XP & RH8 Dual Boot,will WinXP perform slower coz i got RH8? kublador Linux - General 4 08-28-2003 12:32 AM
rpm upgrade documentation RH8 -> RH9 fails gill1109 Linux - Distributions 1 05-05-2003 02:19 AM
boot fails in rh8 rooman Linux - Newbie 0 02-20-2003 02:58 PM
RH8.0 : Need to uninstall Apache 2 and install Apache 1 ericcarlson Linux - Software 1 02-10-2003 03:13 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 11:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration