LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 09-28-2015, 03:00 PM   #1
injijagwalaafq
Member
 
Registered: Oct 2013
Posts: 36

Rep: Reputation: Disabled
Question Apache cgi-bin trouble


I am having more issues with my folding cd project. See THIS THREAD.

I followed this guide to enable GCI and installed MOD_CGI. The test script works.

The issue now sees be have to do with the Apache web server configuration and or file permissions. when clicking submit on the page I get a 500 internal server error.
Quote:
Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at webmaster@localhost to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

Apache/2.4.10 (Ubuntu) Server at jeffloper.me Port 80
The error logs show the following:
Quote:
[Mon Sep 28 19:40:14.229929 2015] [cgi:error] [pid 22338] [client 70.97.124.44:48149] AH01215: (8)Exec format error: exec of '/usr/lib/cgi-bin/fold.iso' failed, referer: http://jeffloper.me/folding/cd.html
[Mon Sep 28 19:40:14.230374 2015] [cgi:error] [pid 22338] [client 70.97.124.44:48149] End of script output before headers: fold.iso, referer: http://jeffloper.me/folding/cd.html
So what do i do about it?
 
Old 09-28-2015, 11:56 PM   #2
norobro
Member
 
Registered: Feb 2006
Distribution: Debian Sid
Posts: 792

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
Hi again.

Did you copy the "fold.iso" file from "foldingathome/initrd_dir/etc/folding/cgi-bin" to "/usr/lib/cgi-bin"? It is a shell script that your webserver should execute.

Make install_web failed on my box, but it looks like you have a hosted account so make install won't work anyway.

I got it to work on my local server by copying all of the files in "foldingathome/initrd_dir/etc/folding/cgi-bin" to /usr/lib/cgi-bin:
Code:
cp foldingathome/initrd_dir/etc/folding/cgi-bin/* /usr/lib/cgi-bin
HTH
 
Old 09-29-2015, 12:49 PM   #3
injijagwalaafq
Member
 
Registered: Oct 2013
Posts: 36

Original Poster
Rep: Reputation: Disabled
I'll do that as sood an I get everything rebuilt a slight meltdown last night. Thanks.

Sometimes I am a bigger idiot than usual.
 
Old 09-29-2015, 06:41 PM   #4
injijagwalaafq
Member
 
Registered: Oct 2013
Posts: 36

Original Poster
Rep: Reputation: Disabled
It works. Up and running. Yahoo! I've been trying to get this thing operational for (literally) year.

Many Thanks!!
 
Old 09-29-2015, 07:59 PM   #5
norobro
Member
 
Registered: Feb 2006
Distribution: Debian Sid
Posts: 792

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
You're welcome!

I haven't burned a cd and tried to run it but it looks like you need one more file in /usr/lib/cgi-bin.
Code:
cp foldingathome/boot/initrd /usr/lib/cgi-bin
I downloaded an iso from your site and the file is empty:
Code:
/mnt/isolinux# ll
total 5114
-r-xr-xr-x 1 root root    2048 Sep 29 19:36 boot.cat
-r-xr-xr-x 1 root root     179 Sep 29 19:36 fold.txt
-r-xr-xr-x 1 root root      20 Sep 29 19:36 initrd
-r-xr-xr-x 1 root root   40960 Sep 29 19:36 isolinux.bin
-r-xr-xr-x 1 root root     613 Sep 29 19:36 isolinux.cfg                             
-r-xr-xr-x 1 root root 5074624 Sep 29 19:36 kernel                                   
-r-xr-xr-x 1 root root  116520 Sep 29 19:36 ldlinux.c32
Here is a directory list from a local iso:
Code:
/mnt/isolinux# ll
total 25588
-r-xr-xr-x 1 root root     2048 Sep 29 19:41 boot.cat
-r-xr-xr-x 1 root root      179 Sep 29 19:41 fold.txt
-r-xr-xr-x 1 root root 20966752 Sep 29 19:41 initrd
-r-xr-xr-x 1 root root    40960 Sep 29 19:41 isolinux.bin
-r-xr-xr-x 1 root root      613 Sep 29 19:41 isolinux.cfg
-r-xr-xr-x 1 root root  5073360 Sep 29 19:41 kernel
-r-xr-xr-x 1 root root   116348 Sep 29 19:41 ldlinux.c32
 
Old 10-01-2015, 06:12 PM   #6
injijagwalaafq
Member
 
Registered: Oct 2013
Posts: 36

Original Poster
Rep: Reputation: Disabled
Had same issue. Working on it.
 
Old 10-01-2015, 06:39 PM   #7
injijagwalaafq
Member
 
Registered: Oct 2013
Posts: 36

Original Poster
Rep: Reputation: Disabled
This is what I see.
Click image for larger version

Name:	fold_iso.png
Views:	31
Size:	41.2 KB
ID:	19710
 
Old 10-01-2015, 06:46 PM   #8
injijagwalaafq
Member
 
Registered: Oct 2013
Posts: 36

Original Poster
Rep: Reputation: Disabled
Seems to be up and running in vbox
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help with Apache Cgi-bin? your_shadow03 Linux - Newbie 1 08-21-2009 06:22 AM
REMOTE_HOST in a CGI-bin script trouble gary knott Linux - Networking 4 11-12-2003 05:33 PM
Apache server and cgi-bin? WorldBuilder Linux - Networking 15 09-18-2003 12:13 PM
Apache cgi-bin in Mandrake 9.1 Edgemaster Linux - Newbie 1 08-14-2003 01:15 PM
apache cgi-bin roadie Linux - General 6 06-16-2001 07:15 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 11:46 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration