LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 10-23-2003, 04:46 AM   #1
jmcollin92
Member
 
Registered: Oct 2003
Distribution: Mandrake 9.1
Posts: 76

Rep: Reputation: 15
Angry Another speedtouch or USB pb with MDK9.1


Hi there,

Here is another Speedtouch USB Alcatel problem accessing ADSL on an Mandrake 9.1 Linux box.
I follow a thousand of help, and howto without success
I try with the drakconnect without more success. I'm begining to be bored of all of this and want to go back by my mother....

You are my last chance (before I do a stupid thing (windoz Aaaah no)).

I got 2 problems :
1. the commande modem_run as explain in the Speedtouch USB HOWTO, failed (see traces below),

2. I never succeed to have the ppp0 interface configured.

I wonder if I use the right USB device or driver (see below).

Some helpfull traces :
# uname -a
Linux ticerosrv1.ticero.com 2.4.21-0.13mdkenterprise #1 SMP Fri Mar 14 14:40:17 EST 2003 i686 unknown unknown GNU/Linux

# lspci
00:00.0 Host bridge: Intel Corp.: Unknown device 2570 (rev 02)
00:01.0 PCI bridge: Intel Corp.: Unknown device 2571 (rev 02)
00:1d.0 USB Controller: Intel Corp.: Unknown device 24d2 (rev 02)
00:1d.1 USB Controller: Intel Corp.: Unknown device 24d4 (rev 02)
00:1d.2 USB Controller: Intel Corp.: Unknown device 24d7 (rev 02)
00:1d.3 USB Controller: Intel Corp.: Unknown device 24de (rev 02)
00:1d.7 USB Controller: Intel Corp.: Unknown device 24dd (rev 02)
00:1e.0 PCI bridge: Intel Corp. 82801BA/CA/DB PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corp.: Unknown device 24d0 (rev 02)
00:1f.1 IDE interface: Intel Corp.: Unknown device 24db (rev 02)
00:1f.3 SMBus: Intel Corp.: Unknown device 24d3 (rev 02)
00:1f.5 Multimedia audio controller: Intel Corp.: Unknown device 24d5 (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation NV18 [GeForce4 MX 440 AGP 8x] (rev a2)
02:09.0 SCSI storage controller: Adaptec AHA-2940U/UW / AHA-39xx / AIC-7895 (rev 03)
02:09.1 SCSI storage controller: Adaptec AHA-2940U/UW / AHA-39xx / AIC-7895 (rev 03)
02:0a.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)

# lsmod | grep ehci
ehci-hcd 20168 0 (unused)
usbcore 81280 1 [ehci-hcd usb-uhci]

# lsmod | grep hcd
ehci-hcd 20168 0 (unused)
usbcore 81280 1 [ehci-hcd usb-uhci]

# modem_run -m -f /usr/share/speedtouch/alcaudsl.sys
pusb_release_interface 2: No such device
Note : sometimes it cores !

# lsmod | grep usb
usb-uhci 27372 0 (unused)
usbcore 81280 1 [ehci-hcd usb-uhci]

# pppd call adsl

# ifconfig -a
eth0 Lien encap:Ethernet HWaddr 00:08:A1:40:679
inet adr:10.0.0.10 Bcast:192.168.0.255 Masque:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1446 errors:0 dropped:0 overruns:0 frame:0
TX packets:1306 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:100
RX bytes:1199136 (1.1 Mb) TX bytes:101740 (99.3 Kb)
Interruption:22 Adresse de base:0xcc00

lo Lien encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:1220 errors:0 dropped:0 overruns:0 frame:0
TX packets:1220 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
RX bytes:92004 (89.8 Kb) TX bytes:92004 (89.8 Kb)

# cat /var/log/messages
Oct 23 00:32:48 ticerosrv1 kernel: martian source 192.168.0.255 from 192.168.0.1, on dev eth0
Oct 23 00:32:48 ticerosrv1 kernel: ll header: ff:ff:ff:ff:ff:ff:00:50:8d:fd:fc:47:08:00
Oct 23 00:32:53 ticerosrv1 pppd[6836]: pppd 2.4.1 started by root, uid 0
Oct 23 00:32:53 ticerosrv1 pppoa3[6837]: pppoa3 version 1.2-beta1 started by root (uid 0)
Oct 23 00:32:53 ticerosrv1 pppoa3[6837]: Control thread ready
Oct 23 00:32:53 ticerosrv1 pppoa3[6845]: host --> pppoa3 --> modem stream ready
Oct 23 00:32:53 ticerosrv1 pppd[6836]: Using interface ppp0
Oct 23 00:32:53 ticerosrv1 pppd[6836]: Connect: ppp0 <--> /dev/pts/3
Oct 23 00:32:53 ticerosrv1 /etc/hotplug/net.agent: assuming ppp0 is already up
Oct 23 00:32:53 ticerosrv1 pppoa3[6848]: modem --> pppoa3 --> host stream ready
Oct 23 00:32:53 ticerosrv1 pppoa3[6848]: Error reading usb urb
Oct 23 00:32:53 ticerosrv1 pppoa3[6837]: Woken by a sem_post event -> Exiting
Oct 23 00:32:53 ticerosrv1 pppoa3[6837]: Read from usb Canceled
Oct 23 00:32:53 ticerosrv1 pppoa3[6837]: Write to usb Canceled
Oct 23 00:32:53 ticerosrv1 pppoa3[6837]: Exiting
Oct 23 00:32:53 ticerosrv1 kernel: usb-uhci.c: uhci_submit_urb: pipesize for pipe c0038980 is zero
Oct 23 00:32:53 ticerosrv1 pppd[6836]: Modem hangup
Oct 23 00:32:53 ticerosrv1 pppd[6836]: Connection terminated.
Oct 23 00:32:53 ticerosrv1 devfsd[95]: error stat(2)ing: "pts/4"^INo such file or directory
...



My Linux box is a P4 2,6 Ghz with Asus P4P800 and an scsi card connected to a DAT reader.

Thank's in advance.
 
Old 10-23-2003, 06:15 AM   #2
stv_t
Member
 
Registered: Oct 2003
Location: Gatwick, UK
Distribution: Mandrake 9.1, Mandrake 9.2, Redhat 9.0
Posts: 47

Rep: Reputation: 15
Hi,

I also have a Speedtouch and Mandrake 9.1 and never had any problem whatsoever installing it. However I have noticed that your usb module is differnet to mine ie mine uses usb-ohci and not usb-uhci:
lsmod | grep usb
usb-storage 72952 0
scsi_mod 103284 6 [sg sr_mod ide-scsi sd_mod scsimon usb-storage]
usb-ohci 20584 0 (unused)
usbcore 72992 1 [printer usb-storage scanner usb-ohci]


The other thing to note is the micro code file 'alcaudsl.sys' that is downloaded to the modem before it will operate. I previously had a problem when trying to use this file directly however renaming it to mgmt.o seemed to work.
One onther problem that may occur is that when setting up the internet link via the control panel it will try to use the TCP/IP network if it is enabled. If you have a network card or an on-board network chip you should disable it while setting up the Modem. You can then re-enable it afterwards and modem will then handle the Internet traffic.

Stv T
 
Old 10-23-2003, 07:59 AM   #3
jmcollin92
Member
 
Registered: Oct 2003
Distribution: Mandrake 9.1
Posts: 76

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by stv_t

One onther problem that may occur is that when setting up the internet link via the control panel it will try to use the TCP/IP network if it is enabled. If you have a network card or an on-board network chip you should disable it while setting up the Modem. You can then re-enable it afterwards and modem will then handle the Internet traffic.

Stv T
Thank's for your help,

Indeed I've got a Network Card, but what do you meen in "disable it" ? ifconfig eth0 down or unplug the card from the box ?

Do you install adsl with DrakConnect or manually ? If manually, with what HOWTO or html link (if you remember) ?
 
Old 10-23-2003, 10:03 AM   #4
jmcollin92
Member
 
Registered: Oct 2003
Distribution: Mandrake 9.1
Posts: 76

Original Poster
Rep: Reputation: 15
Question Configuring USB2.0 to work with adsl modem

I wonder if the problem is not because I use an USB2.0 port.

In the log, we can see that :
"kernel: usb-uhci.c: uhci_submit_urb: pipesize for pipe c0038980 is zero" showing that the kernel is using usb-uhci and not ehci-hcd.

How can I configure properly Linux to use USB2.0 (ehci-hcd ?) driver for the modem ?
 
Old 10-23-2003, 11:06 AM   #5
stv_t
Member
 
Registered: Oct 2003
Location: Gatwick, UK
Distribution: Mandrake 9.1, Mandrake 9.2, Redhat 9.0
Posts: 47

Rep: Reputation: 15
Hi,
When I configured my Speedtouch I actually removed the card while I set up the modem, I tried setting it up with the network card still in the system but it was still being detected whether it was "up" or "down". I found the best and quckest way was to remove the card.

Im afraid I don't have any USB 2.0 ports so I don't know if this will affect its operation, if possible try it with USB 1.0 or 1.1.

From what I can remember I set up the modem through "Drakconnect" without having to do anything manually.

Stv T
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
usb cable modem problem under mdk9.2 mtht Linux - Hardware 2 04-24-2004 11:19 PM
speedtouch usb on mdk9.2 huzzzo Linux - Hardware 1 01-15-2004 01:29 PM
No usb in mdk9.1 rooman Linux - General 2 09-22-2003 03:32 PM
usb HDD 2"5 MDK9.0 Zhu Li Linux - Hardware 5 08-20-2003 01:53 PM
Mdk9.1 + NForce2 + USB not working mythagel Linux - Hardware 2 08-04-2003 03:56 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 02:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration