-   Linux - Networking (
-   -   annoying messages from rsh (

kevingpo 08-02-2005 06:42 PM

annoying messages from rsh
This is my passwordless SSH connection:

Connection to localhost closed.
[kc40@slave ~]$ ssh localhost date
Wed Aug 3 00:36:08 BST 2005
[kc40@slave ~]$ ssh localhost
Last login: Wed Aug 3 00:35:52 2005 from slave
[kc40@slave ~]$

It's good!
However, this is my passwordless RSH connection:

[kc40@slave ~]$ rsh localhost date
connect to address Connection refused
Trying krb4 rsh...
connect to address Connection refused
trying normal rsh (/usr/bin/rsh)
Wed Aug 3 00:36:29 BST 2005
[kc40@slave ~]$ rsh localhost
connect to address Connection refused
Trying krb4 rlogin...
connect to address Connection refused
trying normal rlogin (/usr/bin/rlogin)
Last login: Wed Aug 3 00:36:13 from slave
[kc40@slave ~]$

Does anyone know how to make rsh stop doing whatever it's doing that it's getting connection refused twice? I have edited the /etc/xinetd.d/rsh and /etc/xinetd.d/rlogin files, setting 'disable' to 'no'. Help most appreciated!

Tinkster 08-02-2005 06:56 PM

Please do not post the same thread in more than one forum. Picking the most relevant forum and posting it once there makes it easier for other members to help you and keeps the discussion all in one place.

The original post is

This one has been reported for closure.

kevingpo 08-03-2005 05:37 AM

I just like to tell everybody that at last I found out why my rsh was using
Kerbos5 resulting in annoying messages (when am trying to get a clean passwordless rsh). As I analysed from the list:

Connection refused
Trying krb4
Connection refused
Trying normal

The first being a kerberos 5, then a version 4 try before finally a normal
being successful. I thought there must be more than one version of rsh installed. So I typed 'locate rsh'. I try the first on the list. I typed '/usr/bin/rsh localhost' and that worked fine. Then typed 'which rsh'. To my surprise it says '/usr/kerberos/bin/rsh'. I then
looked at my $PATH and see that that's the first folder that's being pathed. So I removed it. Problem solved.

All times are GMT -5. The time now is 03:17 AM.