-   Linux - Networking (
-   -   Ahh! ImageMagick! This should be and easy thing! (

sporkit 04-03-2004 06:21 PM

Ahh! ImageMagick! This should be and easy thing!
ok so i setup a webserver with apache, mysql, and php. i run a script on the server that needs ImageMagick.

soooooo, i installed ImageMagick via the rpm on cd one (ImageMagick-5.5.6-5.i386.rpm).

the problem is i cant find the darn install directory! i need to know this location (probably like /usr/bin or something) so my script will auto resize images for me. im not looking to really use it from the command line or anything. i need just the path to an executeable.

AutOPSY 04-03-2004 06:25 PM

dude use locate, the rpm shoudlve also installed the manual pages.

locate imagemagik

man imagemagik

ands it probably in /usr/X11R6/bin
if its an Xwindow program.

wapcaplet 04-03-2004 06:45 PM

Actually, 'imagemagick' is the name of the package, not of any particular executable. 'man ImageMagick' (case-sensitive) tells you more about the various applications that are part of the package. These include animate, composite, display, convert, identify and others; if you run 'which convert' (or 'locate convert' or 'find / -name convert'), that should tell you what directory the rest of the binaries got installed into. Mine are in /usr/bin; yours may vary.

sporkit 04-03-2004 07:33 PM

ohhh! convert!!!! darnit thats what i should have been looking for. i really need to remember the syntaxt for that find command. i always forget. thanks so much. :)

sporkit 04-03-2004 07:51 PM

hmmm, now its getting all weird on me.


The picture 'albums/userpics/10001/DSC05501.JPG' can't be inserted in the album

Error executing ImageMagick - Return value: 1

Cmd line :
/usr/bin/convert -quality 80 -antialias -geometry 100x75 'albums/userpics/10001/DSC05501.JPG' 'albums/userpics/10001/thumb_DSC05501.JPG'

The convert program said:
/usr/bin/convert: Corrupt JPEG data: 15 extraneous bytes before marker 0xd9 (albums/userpics/10001/DSC05501.JPG).
/usr/bin/convert: Corrupt JPEG data: 15 extraneous bytes before marker 0xd9 (albums/userpics/10001/DSC05501.JPG).

File: /web_sites/sporkit/friend_pics/db_input.php - Line: 289

i tried using the GD version 1.x and 2.x instead but unfortuatly my pictures become all scrambled. soo basicly it looks like its working with the commands but i wouldnt know what else from there.

thanks for any help.

sporkit 04-05-2004 06:36 PM

ohhhhh kay. well thats pretty anonying. basicly i tried running the commands right on the server it worked. i went back to my unchanged script configureation and now that works...

All times are GMT -5. The time now is 02:18 AM.