-   Linux - Networking (
-   -   ADSL modem D-Link 2500U under openSUSE 12.2 Gnome (

lin66uxx 10-21-2012 09:35 AM

ADSL modem D-Link 2500U under openSUSE 12.2 Gnome
I have just bought D-Link 2500U modem, and need a step by step how to install it.
I am sort of newbie , I have never tried this before , so if you can please be as informative as possible.
I found in the internet that it's default web interface ip is, but when I type it in the browser search bar it fails.

So , please help me !!!!!!!!!!!!!!!!


Thor_2.0 10-22-2012 06:04 PM

Okay, it's a have (in that box) a device (the modem) and a strand of wire (mostly yellow), here's what I'd do:

- hook the lead into one of the ports of the modem, there's only one way to do that
- hook the other end in a similar socket on the PC
- hook the power lead to the modem, plug it in
- observe ... lights ... on the modem, lights is good
- on the PC, open the browser (Firefox, Opera, whatever)
- instead of an internet address ( you enter this :
- you should get the config page of the modem
- try to find a section to enter the password and login you pay your provider for, possibly on a monthly base ;)
- there should be a "save" option, do save the login data
- on the PC, open a console enter:


su -
[your root password]
route add default gw
- while in the console, enter this as a test:


- if you get a response, you're in bizz, if not, chances are your nemeservers are not set (yet)
- locate "resolve.conf" and enter this (provided by your provider) in there (root rights needed!!!!)


nameserver [ip.of.the.server]
Please post feedback so we can help you further if need be



lin66uxx 10-23-2012 02:20 AM

My provider said that it's address is, when I enter it into the browser, it asks for username and password, the only one that is accepted is user/user.
Inside there is no password username option, only all sort of information.

Thor_2.0 10-23-2012 04:13 AM

...have you tried your default gateway? Address, of course, the modem needs to be hooked up to your PC... :)

lin66uxx 10-23-2012 04:26 AM

Yes, it does not connect!

Thor_2.0 10-23-2012 05:20 AM

Okay...let me this a new install? Have you ever done any networking? In the console, enter this and observe


ping should see something similar like this:


PING ( 56(84) bytes of data.
64 bytes from icmp_req=1 ttl=64 time=0.052 ms
64 bytes from icmp_req=2 ttl=64 time=0.046 ms
64 bytes from icmp_req=3 ttl=64 time=0.045 ms
64 bytes from icmp_req=4 ttl=64 time=0.046 ms
64 bytes from icmp_req=5 ttl=64 time=0.050 ms
if not, your networking is'nt working...

Edit : perhaps not relevant, what cable are you using? Maybe the cable is a straight cable and for this you'll need a crossed one. Are you using the cable provided with the modem?

lin66uxx 10-23-2012 05:31 AM

I am just reading the user manual and it states that the IP address is, but I don't know why it does not connect??
It connected in win7 perfectly, without any need to default IP address, the provider lead me through step by step till it connected .

I am connecting also through cellular modem, and it was connecting with no problem ,till I started to try to configure the ADSL modem through YaST, now this modem does not connect either(it connects but with no internet),
do you know how can I find the tool to select country-provider-...??

I'll try the command you gave later on !

Thor_2.0 10-23-2012 05:39 AM

this is way to complex. your modem is (an one end) just a network device (hence the IP address) and can be connected to as just any other netword device. so what this boils down to is: when there's networking, you can connect to the modem, if so, you should be able to get on to the config page of the modem, provide login details and select provider in the modem. I had a D-link too, the provider was in there. Unless you bought your modem somewhere else... :)


lin66uxx 10-23-2012 05:42 AM

I received the modem from the provider...
When I enter the user/user and enter the modem it has no option Quick Setup which include the ppp user name and ppp password ???

Thor_2.0 10-23-2012 06:15 AM

I doubt is D-link even has a quick setup, I never used/needed it anyway. On the left, there should be some yellow buttons, one of them should lead to a screen where login data can be netered. Tha's all I ever had to provide...

lin66uxx 10-23-2012 06:54 AM

I just called my provider and the username and password of the IP address are admin with capital A...
but still didn't find their any place to insert my ISP username and password, should I be connected to the ADSL ? because I where not!


gave similar output.

now for some reason the cellular modem connects but there is no internet, my question was, where can I find the tool that allow me to choose provider according country for cellular modem??

I am so frustrated now , because I need to switch between windows and linux all the time !

lin66uxx 10-23-2012 08:55 AM

I now tried to enter the IP to the modem, with Admin/Admin, now I am connected to the ADSL, but i still don't find any place to enter the username ans password ..!!

Any help please!!
I also want to configure the cellular modem from scratch, but don't seem to remember where I can choose provider according to country as I did first time, that is because the modem connects but there is no internet!!

Any help please!!

Thor_2.0 10-23-2012 05:14 PM

You dont need to provide the country. Just a login and password. By the way, if you ordered the modem, chances could be that everything is preconfigured, as my modem was...


I now tried to enter the IP to the modem, with Admin/Admin,
That's not how ping works, you ping an IP adress only, nothing else, try this


and observe returning responses...

if you get something back, enter that IP address in the browser, post back what you see


lin66uxx 10-24-2012 04:57 AM

You misunderstand what I said, there are two problems, the cellular modem and the regular modem.
regarding the first, when I first configured it, I choose the country and then the provider, and then it recognized the APN and I needed to enter username and password of the APN, so my question is how can I redo this process for the cellular modem, since it connects but with no internet.

Regarding the regular modem, the username and password are Admin, when I enter them to the browser with, I found no option to insert the provider username and password.

Any help!

lin66uxx 10-25-2012 11:39 AM

Any help please??
I called my provider, they said that they don't support linux, but told me that what I need is not the ip address of the modem, instead I shall define a dialer...!
I have no Idea about how is that done!


All times are GMT -5. The time now is 06:03 AM.