Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Networking
User Name
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.


  Search this Thread
Old 01-15-2005, 01:34 PM   #1
Registered: Jan 2004
Distribution: suse/slack/gentoo/lfs (not-in-that-order)
Posts: 284

Rep: Reputation: 30
adp-telecom authentication

i'm in paris, and trying to make a wireless connection using adp-telecom. i'm getting an IP address fine, but it will not bring up the adp-telecom login screen on linux (it skips the default homepage in windows and goes directly to the hotel homepage).

i've tried several browsers, and tried to ping other computers. i checked another patron's ip settings, and tried setting my gateway to the same his windows box was assigned. tried changing authentication settings in firefox, but not having real good luck.

any ideas?
Old 01-25-2005, 08:22 AM   #2
Registered: Jan 2004
Distribution: suse/slack/gentoo/lfs (not-in-that-order)
Posts: 284

Original Poster
Rep: Reputation: 30
umm, any suggestions? i'll be passing through paris again in another week...

(to bump oneself. is it a crime??) lol
Old 02-12-2005, 05:20 PM   #3
Registered: Jan 2004
Distribution: suse/slack/gentoo/lfs (not-in-that-order)
Posts: 284

Original Poster
Rep: Reputation: 30
Problem Resolved

well, after some time, i think the problem was resolved with two possible contributing factors:

1: DHCP configuration!

as discussed elsewhere, if eth0 (ethernet nic) recieves dhcp client attention but never has an IP assigned by a DHCP server, it will stall the DHCP client, preventing other nics (eth1 = wireless in my case) from recieving an IP address. fix number one:

as su take down all eth nics, leaving all down EXCEPT the wireless (bring it back up). for my notebook that was:

ifdown eth1
ifdown eth0
ifup eth1
This got the computer to make an IP assignment from the wireless provider.

2: Certificates and Validation

using firefox, I went to "Preferences > Advanced" and set:

A. Certificates > Client Certificate Autorization to "Ask every time,"

B. Validation > OCSP to "Use OCSP to validate only certificates that specify an OCSP service URL".

then i restarted the browser and was able to redirect, recieve certificate, etc to pay for wireless. Not sure on #2 whether the certificate and OCSP settings are right or even necessary (i don't understand the authentication process here), but these settings seemed to get things working for me with the above ISP. Perhaps someone else could bring a bit more light to the subject if so inclined.

Suggestion to others: if you're traveling to unknown areas and going to be using wireless, get very familiar with setting wireless nics before departure if possible. it will make any potential problems much less painful.


Last edited by Present; 02-12-2005 at 05:28 PM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Italian Alice-Telecom users, help please mindatwork Mandriva 5 03-29-2005 07:51 AM
Non-rofit in need of telecom help psalmist Linux - Software 1 12-06-2004 08:32 AM
redht9 with linksys wmp54 wl adp pmasser1 Linux - Wireless Networking 0 01-09-2004 02:04 AM
Red hat 9 linksys wireless router pci card pbs cant recognze adp pmasser1 Linux - Hardware 0 01-05-2004 08:57 PM
s/w related to telecom farhan Linux - Software 0 04-11-2003 01:10 AM > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 01:29 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration