LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 06-20-2008, 09:22 PM   #1
santonel
LQ Newbie
 
Registered: Jun 2008
Distribution: Ubuntu Hardy Heron
Posts: 8

Rep: Reputation: 0
Adding linux box to work group


Hi, I sort of new to linux and I just installed the latest version of ubuntu on my old pc.

What i'd like to do is set it up to be a member of my windows work group so I can share files back and forth with my windows xp machine. So far i installed samba and set the workgroup name in my smb.conf. I can access my shares on my xp from ubuntu fine but my windows xp box does not even see the ubuntu machine.

I can ping the linux box from my xp box and vice versa.

I've also heard that ubuntu comes with all ports closed by default. Could this be the problem?

Any help is appreciated.
 
Old 06-20-2008, 09:47 PM   #2
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 678Reputation: 678Reputation: 678Reputation: 678Reputation: 678Reputation: 678
Check if ports 139 and 445 are open. There are other ports you may need (137 & 138) but they are more likely used for Windows 98.

I'll assume you are using the default "security = user" model and that Ubuntu configured samba to use the /etc/samba/smbpasswd file to store the samba usernames. You need the same username and password in Linux as you have in Windows. ( Although you could enter your Linux users credentials when opening a share on the Ubuntu machine from the XP machine. )
You also need to run the "smbpasswd" program as root to add a user or if the user exists to enter the password. Now Windows & Linux have the same idea who you are and who is trying to authenicate.
  • Open up ports 139/tcp and 445/tcp
  • add the user using "sudo smbpasswd -a <username>. Even if you already have that user as a Linux user.
  • Restart the smbd & nmbd services so the changes take effect.

Some other things to keep in mind:
Only share what you need to. Such as a directory you prepared in /home or /srv/samba. Don't share the root partition. In windows don''t share the C:/ drive. That is how viruses and worms love to propagate over the network.

Last edited by jschiwal; 06-20-2008 at 09:54 PM.
 
Old 06-20-2008, 10:00 PM   #3
santonel
LQ Newbie
 
Registered: Jun 2008
Distribution: Ubuntu Hardy Heron
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by jschiwal View Post
Check if ports 139 and 445 are open. There are other ports you may need (137 & 138) but they are more likely used for Windows 98.

I'll assume you are using the default "security = user" model and that Ubuntu configured samba to use the /etc/samba/smbpasswd file to store the samba usernames. You need the same username and password in Linux as you have in Windows. ( Although you could enter your Linux users credentials when opening a share on the Ubuntu machine from the XP machine. )
You also need to run the "smbpasswd" program as root to add a user or if the user exists to enter the password. Now Windows & Linux have the same idea who you are and who is trying to authenicate.
  • Open up ports 139/tcp and 445/tcp
  • add the user using "sudo smbpasswd -a <username>. Even if you already have that user as a Linux user.
  • Restart the smbd & nmbd services so the changes take effect.

Some other things to keep in mind:
Only share what you need to. Such as a directory you prepared in /home or /srv/samba. Don't share the root partition. In windows don''t share the C:/ drive. That is how viruses and worms love to propagate over the network.
Thanks for the help. It is set up as the security = user model. I've added my linux username with smbpasswd (as root). I'm new to ubuntu so I'm not sure how to open the ports you mentioned.
 
Old 06-20-2008, 10:43 PM   #4
santonel
LQ Newbie
 
Registered: Jun 2008
Distribution: Ubuntu Hardy Heron
Posts: 8

Original Poster
Rep: Reputation: 0
I restarted samba and my xp box and now the linux box shows up in my workgroup on my xp box but I still can't access it.

It says it is not accessible. The parameter is incorrect.
 
Old 06-20-2008, 11:14 PM   #5
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 678Reputation: 678Reputation: 678Reputation: 678Reputation: 678Reputation: 678
From the Windows box you can use the telnet client to check if the port is open. I don't know the syntax for the port number. Enter "telnet /?" in Windows to find out. In Linux you could enter something like "telnet 192.168.1.105 137". If you can ping the Linux host by name, then "telnet hostname 137".

The access denied is probably due to the firewall. I sure that Ubuntu has a GUI Firewall config program that may even have the ports selectable as "samba". I don't use Ubuntu, so I'm "It's RTFM time, It's RTFM time..." ( To the melody of the Howdy Doody theme song. ).
 
Old 06-21-2008, 12:27 AM   #6
santonel
LQ Newbie
 
Registered: Jun 2008
Distribution: Ubuntu Hardy Heron
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by jschiwal View Post
From the Windows box you can use the telnet client to check if the port is open. I don't know the syntax for the port number. Enter "telnet /?" in Windows to find out. In Linux you could enter something like "telnet 192.168.1.105 137". If you can ping the Linux host by name, then "telnet hostname 137".

The access denied is probably due to the firewall. I sure that Ubuntu has a GUI Firewall config program that may even have the ports selectable as "samba". I don't use Ubuntu, so I'm "It's RTFM time, It's RTFM time..." ( To the melody of the Howdy Doody theme song. ).
So i tried telnet and of course I couldnt connect so it is a port issue so I downloaded firestarter to configure the firewall. I let all the samba ports through for the ip address of my xp box and also added it to the allow list. I still cant telnet the machine on port 137. I can't even do it with the default port (23). I can ssh it through putty just fine though. I'm pretty much back to where I started. The xp box cant see the linux box again but my linux box can see my windows computers.

Now I sometimes seem to get an error refreshing the workgroup in xp saying I exceed the maximum amount of connections. Im not able to recreate it right now but it started after I got firestarter.


So i enabled the ports and allowed connections from my xp machine but it's blocking them anyway. I don't get it.
 
Old 06-21-2008, 01:09 AM   #7
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 678Reputation: 678Reputation: 678Reputation: 678Reputation: 678Reputation: 678
does telnet'ing into port 139 work. I should have used that as the example. You won't be able to do anything if it connects but you are just testing if it can connect.

If you are behind a nat router you could temporarily disable the firewall and see if you can connect. If not, then check if the services are running:
sudo service smbd status
sudo service nmbd status

Nmbd is the client service, so if you don't have any shares on the Windows box open, it may not be running. This wouldn't necessarily be a problem. Smbd should be running however.

Also look in your logs for /var/log/messages and /var/log/secure and /var/log/samba/log.smbd.
sudo tail -f /var/log/messages

There may be a separate firewall log as well. If you can try to connect from the Windows machine, while monitoring the logs, that might point you in the right example. Since putty is working you could even monitor the Ubuntu logs from the Windows machine. Hopefully something will show up.

Typically, the first part of a log entry will indicate the sender.
 
Old 06-21-2008, 03:56 PM   #8
santonel
LQ Newbie
 
Registered: Jun 2008
Distribution: Ubuntu Hardy Heron
Posts: 8

Original Poster
Rep: Reputation: 0
Telnetting into 139 doesnt give me an error but it doesn't show anything either, just hangs at a flashing cursor.

I've never had a problem with the firewall on my router before. I was under the impression it had no effect on LAN traffic but only on WAN traffic. The only thing I can more i can do is put the linux box in the DMZ which I don't think is too secure. But perhaps there is something to it since the 2 systems can ping each other but not by hostname.

Bash doesn't seem to recognize the service commands but they seemed to be running. At least they show up when i enter:

ps ax | grep smbd
ps ax | grep nmbd


There are no errors in /var/log/samba/log.smbd. /var/log/secure is empty. I have no idea how to interpret /var/log/messages. Is there anything I should be looking out for? I can post the tail of the log if necessary.

Firestarter doesn't show any blocked traffic for my ip (192.168.0.100). I added into the incoming policy to accept all connections from it and rules to allow all the ports samba uses.

In the meantime I tried to vnc my linux box and the connection was refused there also even though I opened the ports in firestarter.

I'm truly frazzled on this one and im thinking I should have used a different distro. I love ubuntu and the install was painless and I had no issues connecting to the internet or with ssh but this all ports closed thing is really a pain.

I do thank you for your help , I know i'm asking a lot of questions.
 
Old 06-21-2008, 04:34 PM   #9
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 678Reputation: 678Reputation: 678Reputation: 678Reputation: 678Reputation: 678
The firewall that you need to look at is on the Linux box and on the Windows box. Don't open ports 137-139 & 445 on the router!

Since you can telnet into port 139, that tells you that the Linux firewall isn't blocking the port. I think it also tells you that the smbd service is running. You shouldn't be able to do more with telnet, you just wanted to see if the connection would be refused.
Also check port 445. You could try opening 137 and 138 as well. Different ports are used for different things. For example, browsing, authentication and transferring files. Different versions of Windows used different technologies as well.

Edit your hosts file on both computers and add entries for the other computer. /etc/hosts on linux and c:\WINDOWS\system32\drivers\etc on windows. Then you should be able to ping using the hostname. On Linux you could try pinging using "<windows hostname>.local" if the avahi service (zero-config) is installed and running. This is IMHO a bit clumsy and may need editing other files like /etc/nsswitch.conf before it will work.

You might also want to look at ports 137-139 and 445 on the Windows box by either running "nmap" or using telnet from the Linux box. Windows XP SP2 also has a firewall. Also verify on Windows that filesharing is enabled.

There are some other things to look at such as /etc/hosts.allow and /etc/hosts.deny that could deny access to services. If you can connect to the ports however, I don't think this would be the case.

First let's get the ports you might need open on both sides. If that doesn't work then it's time to look at something else like the /etc/samba/smb.conf file itself.

---

note 1: On some distro's sudo is configured so that you need to include the full path to the command, as in "sudo /sbin/service smbd status". I'm assuming also that on Ubuntu that the service is called "smbd" and not "smb". The "d" is for "daemon". However using "ps" like you did told you that smbd and nmbd are running.

note 2: Which ever Linux distro, or even Windows version you use, become familiar with the administration utilities provided for you. I use openSUSE. Installing samba through YaST would open the ports I need. I'm sure that Ubuntu is similar in this respect. Yes the ports may be closed just after installation, but installing Samba and configuring it through the tools should also install any packages you also need and open the ports that need to be opened.

note 3: This is more like an observation that doesn't deal with your particular problem. Ubuntu and more generally Gnome have a philosophy of hiding details from the user to appear simpler and make life easier. The irony is that in order to make things easy, the system becomes more complex. Take auto-mounting for example (which exists on SuSE as well.) To free the user from determining the device used, and issuing their own mount command, Linux now uses HAL/udev/helper scripts to do this automatically. Understanding all of these parts is a lot more complicated then how things used to be. Linus Torvald's has written that he doesn't care for the Gnome desktop because they go too far to hide things from the user.

I'm not trying to get you to drop Ubuntu or Gnome. I just had to rant a bit to clear my head.

Good Luck!

Last edited by jschiwal; 06-21-2008 at 05:26 PM.
 
Old 06-21-2008, 06:38 PM   #10
santonel
LQ Newbie
 
Registered: Jun 2008
Distribution: Ubuntu Hardy Heron
Posts: 8

Original Poster
Rep: Reputation: 0
I didn't change any settings on my router. As for the ports:

On the linux box I can telnet ports 139 and 445 from my windows box. 137 and 138 do not connect. Doing an nmap localhost returns:

22/tcp open ssh
80/tcp open http
139/tcp open netbios-ssn
445/tcp open microsoft-ds
631/tcp open ipp
5900/tcp open vnc
6000/tcp open X11

Even after letting 137 and 138 through the firewall they still don't show up. Likewise my when I telnet the windows machine from the linux box 137,138 refuse the connection even though I made exceptions for them in the firewall. 139 and 445 connect. I've added the hostnames to the host files on both pcs. I can nmap my xp machine from the linux box but it says the host is down when i try it by ip address. By host name this is what it returns:

23/tcp open telnet
53/tcp open domain
80/tcp open http


/etc/hosts.allow and deny are empty.

Also there is no services file under my /sbin/ directory

Last edited by santonel; 06-21-2008 at 06:40 PM.
 
Old 06-21-2008, 09:23 PM   #11
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 678Reputation: 678Reputation: 678Reputation: 678Reputation: 678Reputation: 678
Run nmap from linux against the windows machine and post the results.

Keep in mind that running nmap on localhost will tell you which services are running, but won't tell you if the firewall is blocking those ports coming in on the interface. The telnet tests from windows did indicate that 139 and 445 are open.

From linux, can you browse your local Linux shares. In konqueror I would enter
smb://<hostname>
where hostname is the same host. If you don't have konqueror, then browse like you normally do but select your local machine instead of the windows machine.

Also, I think it's time to post your /etc/samba/smb.conf file. Unless the Windows firewall is interfering, it looks like you don't have a firewall problem.

Last edited by jschiwal; 06-21-2008 at 09:28 PM.
 
Old 06-21-2008, 09:49 PM   #12
santonel
LQ Newbie
 
Registered: Jun 2008
Distribution: Ubuntu Hardy Heron
Posts: 8

Original Poster
Rep: Reputation: 0
Well it appears that I can't see any of my computers on the workgroup from my linux box now. I was never able to access my linux shares from my linux box.

Here is the conf file:

Code:
#
# Sample configuration file for the Samba suite for Debian GNU/Linux.
#
#
# This is the main Samba configuration file. You should read the
# smb.conf(5) manual page in order to understand the options listed
# here. Samba has a huge number of configurable options most of which 
# are not shown in this example
#
# Any line which starts with a ; (semi-colon) or a # (hash) 
# is a comment and is ignored. In this example we will use a #
# for commentary and a ; for parts of the config file that you
# may wish to enable
#
# NOTE: Whenever you modify this file you should run the command
# "testparm" to check that you have not made any basic syntactic 
# errors. 
#

#======================= Global Settings =======================

[global]

## Browsing/Identification ###

# Change this to the workgroup/NT-domain name your Samba server will part of
   workgroup = WORKGROUP

# server string is the equivalent of the NT Description field
   server string = %h server (Samba, Ubuntu)

# Windows Internet Name Serving Support Section:
# WINS Support - Tells the NMBD component of Samba to enable its WINS Server
;   wins support = no

# WINS Server - Tells the NMBD components of Samba to be a WINS Client
# Note: Samba can be either a WINS Server, or a WINS Client, but NOT both
;   wins server = w.x.y.z

# This will prevent nmbd to search for NetBIOS names through DNS.
   dns proxy = no

# What naming service and in what order should we use to resolve host names
# to IP addresses
;   name resolve order = lmhosts host wins bcast

#### Networking ####

# The specific set of interfaces / networks to bind to
# This can be either the interface name or an IP address/netmask;
# interface names are normally preferred
;   interfaces = 127.0.0.0/8 eth0

# Only bind to the named interfaces and/or networks; you must use the
# 'interfaces' option above to use this.
# It is recommended that you enable this feature if your Samba machine is
# not protected by a firewall or is a firewall itself.  However, this
# option cannot handle dynamic or non-broadcast interfaces correctly.
;   bind interfaces only = true



#### Debugging/Accounting ####

# This tells Samba to use a separate log file for each machine
# that connects
   log file = /var/log/samba/log.%m

# Cap the size of the individual log files (in KiB).
   max log size = 1000

# If you want Samba to only log through syslog then set the following
# parameter to 'yes'.
;   syslog only = no

# We want Samba to log a minimum amount of information to syslog. Everything
# should go to /var/log/samba/log.{smbd,nmbd} instead. If you want to log
# through syslog you should set the following parameter to something higher.
   syslog = 0

# Do something sensible when Samba crashes: mail the admin a backtrace
   panic action = /usr/share/samba/panic-action %d


####### Authentication #######

# "security = user" is always a good idea. This will require a Unix account
# in this server for every user accessing the server. See
# /usr/share/doc/samba-doc/htmldocs/Samba3-HOWTO/ServerType.html
# in the samba-doc package for details.
;   security = user

# You may wish to use password encryption.  See the section on
# 'encrypt passwords' in the smb.conf(5) manpage before enabling.
   encrypt passwords = true

# If you are using encrypted passwords, Samba will need to know what
# password database type you are using.  
   passdb backend = tdbsam

   obey pam restrictions = yes

;   guest account = nobody
   invalid users = root

# This boolean parameter controls whether Samba attempts to sync the Unix
# password with the SMB password when the encrypted SMB password in the
# passdb is changed.
   unix password sync = yes

# For Unix password sync to work on a Debian GNU/Linux system, the following
# parameters must be set (thanks to Ian Kahan <<kahan@informatik.tu-muenchen.de> for
# sending the correct chat script for the passwd program in Debian Sarge).
   passwd program = /usr/bin/passwd %u
   passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .

# This boolean controls whether PAM will be used for password changes
# when requested by an SMB client instead of the program listed in
# 'passwd program'. The default is 'no'.
   pam password change = yes

# This option controls how nsuccessful authentication attempts are mapped 
# to anonymous connections
map to guest = bad user

########## Domains ###########

# Is this machine able to authenticate users. Both PDC and BDC
# must have this setting enabled. If you are the BDC you must
# change the 'domain master' setting to no
#
;   domain logons = yes
#
# The following setting only takes effect if 'domain logons' is set
# It specifies the location of the user's profile directory
# from the client point of view)
# The following required a [profiles] share to be setup on the
# samba server (see below)
;   logon path = \\%N\profiles\%U
# Another common choice is storing the profile in the user's home directory
;   logon path = \\%N\%U\profile

# The following setting only takes effect if 'domain logons' is set
# It specifies the location of a user's home directory (from the client
# point of view)
;   logon drive = H:
;   logon home = \\%N\%U

# The following setting only takes effect if 'domain logons' is set
# It specifies the script to run during logon. The script must be stored
# in the [netlogon] share
# NOTE: Must be store in 'DOS' file format convention
;   logon script = logon.cmd

# This allows Unix users to be created on the domain controller via the SAMR
# RPC pipe.  The example command creates a user account with a disabled Unix
# password; please adapt to your needs
; add user script = /usr/sbin/adduser --quiet --disabled-password --gecos "" %u

########## Printing ##########

# If you want to automatically load your printer list rather
# than setting them up individually then you'll need this
;   load printers = yes

# lpr(ng) printing. You may wish to override the location of the
# printcap file
;   printing = bsd
;   printcap name = /etc/printcap

# CUPS printing.  See also the cupsaddsmb(8) manpage in the
# cupsys-client package.
;   printing = cups
;   printcap name = cups

############ Misc ############

# Using the following line enables you to customise your configuration
# on a per machine basis. The %m gets replaced with the netbios name
# of the machine that is connecting
;   include = /home/samba/etc/smb.conf.%m

# Most people will find that this option gives better performance.
# See smb.conf(5) and /usr/share/doc/samba-doc/htmldocs/Samba3-HOWTO/speed.html
# for details
# You may want to add the following on a Linux system:
#         SO_RCVBUF=8192 SO_SNDBUF=8192
   socket options = TCP_NODELAY

# The following parameter is useful only if you have the linpopup package
# installed. The samba maintainer and the linpopup maintainer are
# working to ease installation and configuration of linpopup and samba.
;   message command = /bin/sh -c '/usr/bin/linpopup "%f" "%m" %s; rm %s' &

# Domain Master specifies Samba to be the Domain Master Browser. If this
# machine will be configured as a BDC (a secondary logon server), you
# must set this to 'no'; otherwise, the default behavior is recommended.
;   domain master = auto

# Some defaults for winbind (make sure you're not using the ranges
# for something else.)
;   idmap uid = 10000-20000
;   idmap gid = 10000-20000
;   template shell = /bin/bash

# The following was the default behaviour in sarge,
# but samba upstream reverted the default because it might induce
# performance issues in large organizations.
# See Debian bug #368251 for some of the consequences of *not*
# having this setting and smb.conf(5) for details.
;   winbind enum groups = yes
;   winbind enum users = yes

# Setup usershare options to enable non-root users to share folders
# with the net usershare command.

# Maximum number of usershare. 0 (default) means that usershare is disabled.
;   usershare max shares = 100

# Allow users who've been granted usershare privileges to create
# public shares, not just authenticated ones
   usershare allow guests = yes

#======================= Share Definitions =======================

# Un-comment the following (and tweak the other settings below to suit)
# to enable the default home directory shares.  This will share each
# user's home directory as \\server\username
;[homes]
;   comment = Home Directories
;   browseable = no

# By default, the home directories are exported read-only. Change the
# next parameter to 'no' if you want to be able to write to them.
;   read only = yes

# File creation mask is set to 0700 for security reasons. If you want to
# create files with group=rw permissions, set next parameter to 0775.
;   create mask = 0700

# Directory creation mask is set to 0700 for security reasons. If you want to
# create dirs. with group=rw permissions, set next parameter to 0775.
;   directory mask = 0700

# By default, \\server\username shares can be connected to by anyone
# with access to the samba server.  Un-comment the following parameter
# to make sure that only "username" can connect to \\server\username
# This might need tweaking when using external authentication schemes
;   valid users = %S

# Un-comment the following and create the netlogon directory for Domain Logons
# (you need to configure Samba to act as a domain controller too.)
;[netlogon]
;   comment = Network Logon Service
;   path = /home/samba/netlogon
;   guest ok = yes
;   read only = yes
;   share modes = no

# Un-comment the following and create the profiles directory to store
# users profiles (see the "logon path" option above)
# (you need to configure Samba to act as a domain controller too.)
# The path below should be writable by all users so that their
# profile directory may be created the first time they log on
;[profiles]
;   comment = Users profiles
;   path = /home/samba/profiles
;   guest ok = no
;   browseable = no
;   create mask = 0600
;   directory mask = 0700

[printers]
   comment = All Printers
   browseable = no
   path = /var/spool/samba
   printable = yes
   guest ok = no
   read only = yes
   create mask = 0700

# Windows clients look for this share name as a source of downloadable
# printer drivers
[print$]
   comment = Printer Drivers
   path = /var/lib/samba/printers
   browseable = yes
   read only = yes
   guest ok = no
# Uncomment to allow remote administration of Windows print drivers.
# Replace 'ntadmin' with the name of the group your admin users are
# members of.
;   write list = root, @ntadmin

# A sample share for sharing your CD-ROM with others.
;[cdrom]
;   comment = Samba server's CD-ROM
;   read only = yes
;   locking = no
;   path = /cdrom
;   guest ok = yes

# The next two parameters show how to auto-mount a CD-ROM when the
#	cdrom share is accesed. For this to work /etc/fstab must contain
#	an entry like this:
#
#       /dev/scd0   /cdrom  iso9660 defaults,noauto,ro,user   0 0
#
# The CD-ROM gets unmounted automatically after the connection to the
#
# If you don't want to use auto-mounting/unmounting make sure the CD
#	is mounted on /cdrom
#
;   preexec = /bin/mount /cdrom
;   postexec = /bin/umount /cdrom
I doubt if its the windows firewall but I turned it off just in case and it's still the same situation. Perhaps I installed samba wrong? All i did was an apt-get and then set the workgroup in the conf file. When I installed ssh server it opened the port and worked fine so perhaps I installed samba wrong?

Last edited by santonel; 06-21-2008 at 09:59 PM.
 
Old 06-22-2008, 02:39 AM   #13
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 678Reputation: 678Reputation: 678Reputation: 678Reputation: 678Reputation: 678
"invalid users = root"
I'm wondering if this might cause problems. I'm not sure. I'm thinking that if the Windows net admin account isn't allowed to connect, that might effect browsing or printing. You could place this line inside each share section to offer the same protection.

You don't have any shares defined. You might want to try this [profiles] share:
Code:
[profiles]
        comment = Network Profiles Service
        path = %H
        read only = No
        store dos attributes = Yes
        create mask = 0600
        directory mask = 0700
I use "security = user" as well. Clicking on the Profiles share (the first time) brings up a username/password request. Then the users home directory is opened. This way you can have many users without having each users home directory cluttering the browser.

From the Linux machine could you enter
smbclient -L <Linux hostname>

Last edited by jschiwal; 06-22-2008 at 05:33 AM.
 
Old 06-23-2008, 02:07 PM   #14
santonel
LQ Newbie
 
Registered: Jun 2008
Distribution: Ubuntu Hardy Heron
Posts: 8

Original Poster
Rep: Reputation: 0
I've partially fixed the problem by completely rewriting the conf file to use only the necessary information. I can now access my linux box from my windows box but none of my windows boxes show up on my linux box nor can I access them directly (smb://ipaddress).

I'm not at the linux box right now but I can post the .conf file later.
 
Old 07-02-2008, 05:41 PM   #15
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 678Reputation: 678Reputation: 678Reputation: 678Reputation: 678Reputation: 678
Accessing Windows computers from the Linux box doesn't use the Samba server. So the smb.conf won't matter in that case unless you depend on wins for name resolution. That uses the winbind daemon, which may access the smb.conf file, I'm not sure ( the server is the smbd daemon, while the client uses nmbd to track connections ) Anyway, I don't think the solution is in the smb.conf file.

Try "smbclient -L <ipaddress>" or "smbclient -L <hostname>". It should list information about the Windows machine and the shares it offers.

Look at the running processes. smbd should be running. nmbd should be running if you have a connection.

Concentrate on one windows host. Look at the ports it has open with the nmap program. Does another windows machine show the shares? Is file sharing enabled on the windows machine? Does the firewall on the windows machine block access?

Different Windows versions use different ports for network browsing. If the windows machine is running vista, you may need to update your version of samba.

If you have konqueror installed, try using that using the "smb:/" protocol in the address bar. The client you are using may depend on a service similar to Lisa for browsing. If this client is configured to use an older technology such as broadcasts, this may cause problems.

Also check your Linux configuration ( i.e. GUI config modules ) and see if there is a configuration for samba client. It may have a place for entering the domain or workgroup.

There is one oddball potential problem. If one of the windows clients has an unused protocol installed such as for netware, it will always win the browser election, even though it may not be the best suited host to be the master browser.

However, since you entered the IP address and not a name, it seems to be either a port problem or an authentication problem. Also check whether the Window's host has the shares defined with a trailing "$" in the name which will make them hidden. This is equivalent to samba's "browsable = no".
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Adding Linux to a Windows XP box... kadafi Linux - Software 1 06-14-2006 02:08 PM
adding linux box to simplest network rank_n00b Linux - Newbie 5 07-25-2004 11:26 PM
Adding linux box (wireless) to existing home network drwatts Linux - Wireless Networking 4 12-21-2003 03:31 PM
Newbie adding Linux box to W2k Domain. Help. jstamp Linux - Networking 2 09-10-2003 02:55 PM
adding new hard drive to existing linux box jaysan Linux - Newbie 2 08-09-2001 06:27 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 08:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration