-   Linux - Networking (
-   -   Accessing internet from win98 through a linux box (

Usalabs 02-08-2004 04:42 PM

Accessing internet from win98 through a linux box
I would like to point out, that a windows machine networked to a linux box, can not and WILL NOT access the internet, file sharing ok, but as for internet access? FORGET IT!

benjithegreat98 02-08-2004 06:34 PM

I do it all the time. I have a pc router loaded with slackware 9.1. eth0 goes to the internet and eth1 goes into my hub. Windows and linux can get on after that. Works beautifully for me. Was this just a statement or would you like some help on this?

rhibs01 02-08-2004 06:53 PM

Win98, Win9x can use internet from Linux
We have a network of PCs running Windows 98, and ME that connect to a samba Server and also all access the internet. Works smoothly with squid.

vectordrake 02-08-2004 08:28 PM

Most distros will ask you flat out if you want it to be your internet gateway, as do the *BSDs as well. They share much better than Windows 98 ever will (2000 and XP will do ok out of the box for light duty, though). Why don't you try again. You'll be glad you did.

Usalabs 02-08-2004 09:54 PM

no way, I've installed, re-installed, and installed RH9 again and again, everytime I try something that someone suggested, it mucks up the system.

Just as an explanation of my setup, I use RH9 with Kde, the linux box uses and internal modem, and a 100Mb/s etherlink card, the 98 machine also has the same card, I can access the internet using the linux box (after a clean reinstall), and I have successfully setup DHCP and the win98 machine can see the shared files on the linux box using samba, but no matter how much I try and play about with the linux box settings, the win98 machine can not access the internet, even with iptables and the firewall disabled on the linux box, which takes me back to the home networking wizard, make it simple and people can do it, make it impossible and no-one can do it.

vectordrake 02-09-2004 07:25 AM

Its up to you if you don't want to use that configuration, but you may want to check a couple of little things just in case you're almost there.

Have you tried to ping a site from the outside world? If so, how? Did you ping a domain name? Or an IP address? If you pinged a domain name, try pinging the site's IP. I usually use They have a fast site and they don't have discovery blocked. If you can ping an IP but not a site name, you need to enter a nameserver into your TCP/IP settings for the '98 box. Have you tried any other apps besides your browser to access the net with the '98 machine?

Dumb question, but is TCP/IP installed?

In your TCP/IP settings on the '98 machine, do you have the IP of the RH box entered as a gateway?

Of course, there are other distros......I got my first Mandrake 9.1 cds from a guy in Western Canada, calling himself CHGuy, for $5/cd - enough to cover the shipping and burning - when I had dialup and no burner. They can be had...

Good luck if you try. Post if you keep having problems.

tangle 02-09-2004 10:25 AM

Go to and download arno-iptables. It is a simple to set iptables script that will let you setup a firewall and allow routing. I have it install on a Slackware 9.0 PC that I use as a router. If you need help setting it up let me know and I'll send you a config file that will work.

Usalabs 02-09-2004 10:36 PM

Everything is working between the win98 machine and the linux box, all except internet access, the linux box connects to the internet with no problem, the win98 machine connects to the linux box and can share files and folders using samba, with no problem, that means that TCP/IP is configured properly, but it seems to be impossible that the win98 machine can not, and will not use the linux box to connect to the internet.

I looked for the script called 'arno-iptables' it don't exist on that website, so I downloaded a few GUI aided iptable scripts and neither of them work, they can not be compiled or, they just don't work with my version of Linux RH9.

I've spent nearly 2 weeks searching the net for a wizrd type software, much similar to the windows home networking wizard, that can automatically setup the network to give the win98 machine access to the internet, but there is nothing out there.

So, it seems that I'll have to keep switching to winxp so that the win98 machine can successfully access the internet.

benjithegreat98 02-09-2004 10:47 PM

Have you checked your DNS settings in Win98? You say you can't access the internet. You can try and ping from your win98 machine. This is If you successfully ping that IP address then that means you are getting to the internet, but your DNS settings are improperly set somewhere and hostnames cannot be resolved. Let us know what happens.

AfterBurn 02-10-2004 09:00 AM

dude, linux is one of the best OS's out there for hosting things. as u can see by my profile i also use RH9 and i have been able to route connections through it from win98. if all else fails, just load a proxy and u have to use software w/ proxy support.

Usalabs 02-10-2004 09:37 AM

The only ping I can get a result from is:-

on both machines and no-where else on the win98 machine.

I could paste the contents of the dhcpd.conf and the iptables file(s) here, but my wife wants to play bingo online, and the only way she can do that on the other computer is through windowsxp, I'll paste it as a reply later in the day, when I can get to use the linux side.

charon79m 02-10-2004 09:39 AM

First off, it's not an issue between Win and Linux... The issues you are dealing with are networking issues and are NOT OS related.

You're issue is probably that you are not setting up your network correctly or that you have not set up your Linux box to route traffic for your network.

If you are looking for a happy little GUI from which you will manage everything, I highly recomend Webmin. It is a very versitle utility with happy little GUIs for about anything you would want to do, including setting up your routing and firewalling. It can be downloaded from and is a free utility released under the GPL. It has some good documentation and even has a single click update feature for itself.

Please do not think that it is a Linux issue as the majority of us here are doing exactly what you are claiming can't be done. I for one have 2 internet gateways for my network and each of them are a routing Linux box. Internally I'm running everything from Win95 - XP and several versions of *nix. I can say without a doubt that my Linux "routers" are far more robust and secure than any Win machine using ICS.

If you honestly want help are are not just posting to vent, I'm sure that we can help you get thing working properly. Given your previous posts you have a tendancy of trolling, so if your purpose is simply to vent, don't bother with a reply.



jazernorth 02-10-2004 09:43 AM

Do a search on for iptables masquerading. Find documentation regarding NAT, which is the next generation of masquerading. It will then enable you to set the Linux server up as a router.

I have mutliple computers using my Linux server as a router/gateway. Windows, Linux, and an AudioTron.



Usalabs 02-10-2004 11:25 AM

Here's the output from dhcpd -d -f :-

Internet Software Consortium DHCP Server V3.0pl1
Copyright 1995-2001 Internet Software Consortium.
All rights reserved.
For info, please visit
Wrote 2 leases to leases file.
Listening on LPF/eth0/00:20:18:d5:80:a7/
Sending on LPF/eth0/00:20:18:d5:80:a7/
Sending on Socket/fallback/fallback-net
DHCPDISCOVER from 00:e0:7d:aa:63:e0 (Bedroom) via eth0
DHCPOFFER on to 00:e0:7d:aa:63:e0 (Bedroom) via eth0
if IN A rrset doesn't exist add 3600 IN A timed out.
DHCPREQUEST for ( from 00:e0:7d:aa:63:e0 (Bedroom) via eth0
DHCPACK on to 00:e0:7d:aa:63:e0 (Bedroom) via eth0
DHCPINFORM from via eth0
DHCPINFORM from via eth0
DHCPINFORM from via eth0
DHCPRELEASE of from 00:e0:7d:aa:63:e0 (Bedroom) via eth0 (found)

Here's the /etc/sysconfig/iptables file:-

# Generated by iptables-save v1.2.7a on Tue Feb 10 10:15:56 2004
:OUTPUT ACCEPT [28:1680]
[0:0] -A PREROUTING -i eth0 -j ACCEPT
[0:0] -A PREROUTING -i eth0 -j ACCEPT
[0:0] -A POSTROUTING -s -o eth0 -j MASQUERADE
# Completed on Tue Feb 10 10:15:56 2004
# Generated by iptables-save v1.2.7a on Tue Feb 10 10:15:56 2004
:INPUT ACCEPT [532:36330]
:OUTPUT ACCEPT [570:38925]
[1846:125847] -A INPUT -j ACCEPT
[1770:120657] -A OUTPUT -j ACCEPT
# Completed on Tue Feb 10 10:15:56 2004

This is the dhcpd.conf file:-

ddns-update-style ad-hoc;
default-lease-time 36000;
max-lease-time 7200;
option subnet-mask;
option broadcast-address;
option routers;
option domain-name "";
option netbios-node-type 8;

subnet netmask {

If anyone has an iptable and dhcp.conf file that works using a win98 machine to access the internet via the linux machine that uses dial up on /dev/modem and a NIC on eth0, could you email them to me?.

vectordrake 02-10-2004 05:37 PM


Originally posted by Usalabs
The only ping I can get a result from is:-

on both machines and no-where else on the win98 machine.

Thus, your DHCP server is not working as advertized. Both machines cannot have the same IP. Log into the RH machine under WinXP and copy down everything you see under the TCP/IP tab of your network card's properties. Whatever IP address you are using for it, you must also have for the RH machine (or, vica versa). DO YOU HAVE A NAMESERVER????? Write down the IP, if so. Most of the time, its a good idea to use the 2 or more that your ISP provides for DNS resolution.

On your Win98 box, check that you are actually polling for an IP. Be sure that the TCP/IP tab is set to "Obtain an IP address automatically". Or, manually set it to something in the same range of private IPs that your RH/XP machine is using. Ex: or They cannot have the same IP address. Its their 'name' on the TCP/IP highway. On the DNS tab, be sure that there is something entered for a nameserver. Use the gateway's IP or the one(s) from your ISP. Be sure that there is a gateway listed! The IP of your redhat/XP machine must be entered here. Without that, there is no internet for your client machine.

From your log, it looks like your DHCP server on the RH machine is offering, but the 98 machine is not accepting the offer. Maybe it doesn't realize that it has a gateway. CHECK that first.

All times are GMT -5. The time now is 02:00 AM.