-   Linux - Networking (
-   -   3G modem unstable after upgrade to wheezy (

jothan sans cheer 04-23-2011 04:36 AM

3G modem unstable after upgrade to wheezy
Hello there!

I recently upgraded from Debian Lenny to wheezy (testing). I use a popular 3G modem, the Huawei E220. In Lenny everything worked fine. I use wvdial to connect and the script from lenny, which worked just fine.

Unstable behaviour goes like this:
I connect, pppd starts, then, either immediately or after a few seconds, the modem hangs up (pppd errorcode 16). Upon retry a SIM Error is being thrown or the /dev/ttyUSB0 node vanishes. Un/Re-plugging the modem and dialing again results in a working connection (mostly).

Has anyone experienced similar behaviour and found a solution or specific problem? Is there any possibility finding out why the modem hangs up (because a web research revealed that there are a million possibilities for this behaviour)?


jamescondron 04-24-2011 12:57 PM

Hi there,

You might be better off asking this in mail list and reporting back- this can only be a kernel issue if it worked before and didn't after the upgrade

All times are GMT -5. The time now is 06:49 PM.