-   Linux - Networking (
-   -   2Wire Troubles (

Rayoftheday 05-07-2009 04:24 PM

2Wire Troubles
I... have a problem. I can't connect to the interweb on Ubuntu, but I can on the Vista part so I know it's working. I've read that connecting is hell on Ubuntu, and now I believe it. I've tried everything and it doesn't work. The 2Wire router was broken a few years ago, so I have to hardcode the IP of my laptop and old XP. My swanky new Vista machine connected automagically, so I figured it had been fixed. Maybe not... Does anyone have any help? I'm out of ideas. If you need more info let me know.

Poetics 05-07-2009 06:07 PM

When you say you've tried "everything," can you give us a brief rundown of what you have tried (DHCP, static settings, et cetera)?

What does `sudo ifconfig -a` yield?

Rayoftheday 05-07-2009 06:26 PM

Mine's wireless, so I don't think ifconfig works. Iwconfig yields something like "Operation not supported". That's the closest I've come, I think, but I don't know how to get around it. I've figured out I have an Atheros card, so should I use Madwifi? I'm not exactly sure how to do that...

Poetics 05-08-2009 08:14 AM

`iwconfig` will control your computer's wireless connectivity, but `ifconfig` will control your computer's IP traffic (the ability to send meaningful data) -- the two work hand-in-hand for wireless devices.

A quick Google search for 'Ubuntu Atheros' returns quite a few results, detailing many people's configurations on many versions of Ubuntu on many different devices. What make/model of laptop (I assume) do you have?

`sudo ifconfig -a` will return a list of your on-board networking devices, which will help make any followup more specific to your case (some systems have wlan0, ath0, or even eth1 for the wireless card).

All times are GMT -5. The time now is 10:59 PM.