LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   2 routers? (https://www.linuxquestions.org/questions/linux-networking-3/2-routers-217194/)

Buckyjunior 08-13-2004 12:22 PM

2 routers?
 
I should be able to do this.

I recently bought a wireless router to replace/suppliment my non-wireless router. I thought I might be able to use the older router as a switchbox in my home lan. Naturally, I needed to change the router's IP address to something different than the newer one.

The older router shows up as "connected" but I cannot connect through the older router. Is this possible? Originally, I "cloned" the MAC address to the old router and did the same with the new. Do I have a conflict there? If I were to alter the MAC address on the old router, what options to I have?

Am I headed in the right direction? Is having multiple routers of any advantage? (Other than the fact that it is already paid for?)

Thanks a Gig,
Bucky

bastard23 08-13-2004 02:20 PM

What's the path to the internet? Through the wireless router? What do you expect/want it to be?

If that's the case, you should just turn off all the "routing" functions of the grounded router. Plug it's uplink into the wireless router and then use it as a cheap (as in you already own it) switch/hub.

Another thing you could do is create two home networks. One for your "insecure" boxen and one for your "secure" boxen. But thats more work :)

Anyways, on to your problem. Each device should have it's own, unique MAC address (Unless you are doing something special, like failover). I think you'll need to be a little more specific about your setup. Perhaps some ascii art

Code:

internet
  |
  |
Wireless router (192.168.1.1)
  |                      |
  |                      |
  |                      |
Redhat box (192.168.1.2)    \
                            Grounded router (used as a hub)
                                          192.168.1.3
                                          /          \
                                          /            \
                              192.168.1.4          192.168.1.5
                                  OS X                      Winders

Or something like that.

Good Luck,
chris

edit: fonts seem to have a different idea of how big a space is. Oh well, I've already played with fonts this week, so I aint goin' fix it.
edit2: cut and paste from fixed font terminial window

Buckyjunior 08-13-2004 03:17 PM

Chris (bastard23),
Yep, that's exactly what I want to do.

internet
|
wireless+ -192.168.1.1 -->Linux box with outside view
|
non-wireless -192.168.1.2 (Reset to default MAC*)
|
other boxes with assorted numbers

*I may have cloned the MAC address in my attempts. (Thinking it would make it transparent in the network.) I'll work on it later this afternoon/evening and let you know how it goes.

Thanks for your time and effort--expecially with the ascii art. I fear that ascii art is nearly a lost craft. Us old timers get it though.

Best wishes,
Bucky

Buckyjunior 08-13-2004 10:40 PM

2 routers in process
 
I guess I still don't have it. Wireless router works fine, recognizes grounded router (giving it's IP address), but I can't ping it, a computer attached to the grounded router can ping it, but can't get through.

Here are some settings. Perhaps another point of view can see where I'm failing to see.

Wireless:
Dynamic IP from ISP
unit has IP address of 192.168.0.1
DHCP server enabled
DHCP client list: 192.168.0.140=grounded router, other IPs assigned in allowed range
----
Virtual server is the Linux box
No filters for LAN users
Firewall:
Allow anything to/from grounded router
Allow Virtual server open on port 80
Allow Ping WAN port
----
Default gateway (ISP assigned) e.g., 10.10.10.5
++++++++++++++++++++
The grounded router is plugged into the wireless router as a client.
Static IP set as 192.168.0.140
DHCP server enabled
DHCP Client list: self as 192.168.0.140, computer=192.168.0.120 set with static IP address so as not to conflict with assignments made by Wireless
----
Virtual server turned off
No filters for LAN users
Firewall:
Allow anything
----
Default gateway set to wireless router 192.168.0.1 [also tried ISP assigned default gateway]

I've rebooted the routers after changes, rebooted the computers after changes. I seem to be stuck. See anything I've missed?

Bucky

bastard23 08-15-2004 12:46 PM

Bucky,

What is the make/model of the routers? It may be that it won't do "ethernet bridging" on all of it's ports. You may have to partition the network between the two routers (grounded would have 192.168.1.0/24). There are several options here. Do you mind the grounded router doing NAT? (I usually try to avoid it, when I can). Do you mind having two subnets Do you have a crossover cable?

You can only have one dhcp server on a network. Turn it off on the grounded router. (This won't fix anything)

namin 08-15-2004 04:34 PM

I had this problem a few months back where the second router couldn't connect outside. I fixed it by simply making the first router DMZ the second. In your case, wireless router puts grounded router on DMZ. This fixed it for me. :)


All times are GMT -5. The time now is 09:52 AM.