LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 11-06-2011, 05:33 PM   #1
Siljrath
Bedrock Linux Advocate
 
Registered: Nov 2004
Location: the internet
Distribution: server:Gentoo | workstation:Bedrock (hijacked:void, fetched:Gentoo,Devuan,Artix)
Posts: 218

Rep: Reputation: 65
[SOLVED]first time znc ~ cant connect with pidgin, or at all...


setting up znc for the first time.

ideally i'll want to connect to it using pidgin ( ~ no idea how to do that yet... thought it might b a simple case of adding an account that points to the server address ... but seems i'm not even that far yet ~)

i cant even get it to connect with irssi just now though, using the suggested
Code:
 /server 192.168.1.7 +6667 nick
it just spits back at me,
Code:
 00:02 -!- Irssi: Looking up 192.168.1.7
00:02 -!- Irssi: Connecting to 192.168.1.7 [192.168.1.7] port 6667
00:02 -!- Irssi: Connection to 192.168.1.7 established
00:02 -!- Irssi: Connection lost to 192.168.1.7
then it continues periodically with... 
00:07 -!- Irssi: Removed reconnection to server 192.168.1.7 port 6667
00:07 -!- Irssi: Looking up 192.168.1.7
00:07 -!- Irssi: Reconnecting to 192.168.1.7 [192.168.1.7] port 6667 - use /RMRECONNS to abort
00:07 -!- Irssi: Connection to 192.168.1.7 established
00:07 -!- Irssi: Connection lost to 192.168.1.7
00:12 -!- Irssi: Removed reconnection to server 192.168.1.7 port 6667
00:12 -!- Irssi: Looking up 192.168.1.7
00:12 -!- Irssi: Reconnecting to 192.168.1.7 [192.168.1.7] port 6667 - use /RMRECONNS to abort
00:12 -!- Irssi: Connection to 192.168.1.7 established
00:12 -!- Irssi: Connection lost to 192.168.1.7
etc etc

so... is there something wwrong with my znc configuration, or something else in my system needed doing first?

the server is running parabola
trying to connect using toorox
(hehe, nice obscure distros i know. lol. just think of it as arch and gentoo respectively)

here's my config near enough as is:
Code:
// WARNING
//
// Do NOT edit this file while ZNC is running!
// Use webadmin or *admin instead.
//
// Buf if you feel risky, you might want to read help on /znc saveconfig and /znc rehash.
// Also check http://en.znc.in/wiki/Configuration

AnonIPLimit  = 10
MaxBufferSize= 500
SSLCertFile  = /home/digit/.znc/znc.pem
ProtectWebSessions = true
Listener     = +6667
ConnectDelay = 5
ServerThrottle = 30

<User DigitGaia>
        Pass = sha256#37jibberishjibberishjibberishjibberjibberjibberishnessofjiberjabberjibberishnessUC+NKm)-Lq!#
        Nick = DigitGaia
        AltNick = DigitGaia_
        Ident = DigitGaia
        RealName = Digit
        QuitMsg = ZNC - http://znc.in
        StatusPrefix = *
        ChanModes = +stn
        Buffer = 50
        KeepBuffer = false
        MultiClients = true
        DenyLoadMod = false
        Admin = true
        DenySetBindHost = false
        TimestampFormat = [%H:%M:%S]
        AppendTimestamp = false
        PrependTimestamp = true
        TimezoneOffset = 0.00
        JoinTries = 10
        MaxJoins = 5
        IRCConnectEnabled = true

        LoadModule = admin
        LoadModule = chansaver
        LoadModule = keepnick
        LoadModule = kickrejoin
        LoadModule = perform

        Server = irc.freenode.net 6667

        <Chan #parabola>
        </Chan>

        <Chan #wastedartist>
        </Chan>

        <Chan #witchgnu>
        </Chan>

        <Chan #witchlinux>
        </Chan>
</User>
can anyone see an obvious (or not obvious) mistake?

is it ssl, ident, or ipv6 or something causing the problem?

thnx for your time n any suggestions u have.

Last edited by Siljrath; 11-10-2011 at 04:33 AM. Reason: cleaned up typos and closed tags ~ solved
 
Old 11-07-2011, 09:12 PM   #2
Siljrath
Bedrock Linux Advocate
 
Registered: Nov 2004
Location: the internet
Distribution: server:Gentoo | workstation:Bedrock (hijacked:void, fetched:Gentoo,Devuan,Artix)
Posts: 218

Original Poster
Rep: Reputation: 65
re-did the "znc --makeconf" this time with no ssl and no ipv6... and adding a password other than an empty string. seems to work now. ... at least, i can connect with irssi.

still dont know how to get pidgin to connect to it though.

the search continues.


~ some time later ~

ok, looks like you just have to be a bit more careful with the options you say yes or no to.

once that was sorted, getting it to work with pidgin was easy.

... and the username bitconfused me at first too. ... i suppose i should have figured it out once "nick" came up too. silly, silly.

Last edited by Siljrath; 11-10-2011 at 04:35 AM. Reason: update
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to Connect to Yahoo using Pidgin saleem_ak Linux - Software 1 07-15-2009 12:18 AM
pidgin won't connect to MSN! robybo Linux - Software 1 09-04-2008 12:26 AM
Pidgin will not connect to ICQ FlorMarina Linux - Software 5 08-02-2008 04:06 AM
Pidgin error with MSN , can't connect hobz Linux - Software 0 04-04-2008 01:25 AM
Gaim/Pidgin won't connect to MSN ckent Linux - Software 6 08-23-2007 10:04 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 05:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration