LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 08-26-2013, 02:38 AM   #1
user1989
LQ Newbie
 
Registered: Aug 2013
Posts: 2

Rep: Reputation: Disabled
[Errno 14] PYCURL ERROR 7 - "couldn't connect to host" Trying other mirror


Hi,

I'm having trouble in installing packages remotely using yum.

I'm using Oracle virtual box and two RedHat VMs configured with Virtual Box Host only adapter.


I've configured the yum.repos.d/server.repo file on server and able to install the packages locally. However, I'm not able to install the packages to client system from the server remotely. Both VMs are responding to the ping.

Repo file on server
--------------------
'[my_repo]
baseurl=file:///packages/
gpgcheck=0
enabled=1'


Repo file on client:
-------------------
'[client_repo]
baseurl=ftp://x.x.x.x/packages/
enabled=1
gpgcheck=0'

Error:
------
[root@client ~]# yum install vsftpd
Loaded plugins: product-id, subscription-manager
Updating Red Hat repositories.
Repository 'client_repo' is missing name in configuration, using id
ftp://10.1.1.3/packages/Packages/repodata/repomd.xml: [Errno 14] PYCURL ERROR 7 - "couldn't connect to host"
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: client_repo. Please verify its path and try again.

Any help would be greatly appreciated.
 
Old 08-26-2013, 02:49 AM   #2
#root
Member
 
Registered: Mar 2013
Location: in my house
Distribution: Ubuntu,Backtrack,Fedora
Posts: 38

Rep: Reputation: 5
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

Last edited by #root; 08-26-2013 at 03:33 AM.
 
Old 08-26-2013, 03:01 AM   #3
SAbhi
Member
 
Registered: Aug 2009
Location: Bangaluru, India
Distribution: CentOS 6.5, SuSE SLED/ SLES 10.2 SP2 /11.2, Fedora 11/16
Posts: 665

Rep: Reputation: Disabled
Quote:
I'm using Oracle virtual box and two RedHat VMs configured with Virtual Box Host only adapter.
baseurl=file:///packages/

I preassume you must have shared the the remote dir from your host machine to Oracle Vbox though shared folder utility in settings. if this is correct :

speify the full path after the
Code:
file:///mnt/[mountpoint or dirname]/packages ####something like this.
yum clean all
Quote:

baseurl=ftp://x.x.x.x/packages/
so is your FTP working... try logging into FTP and download something.

Last edited by SAbhi; 08-26-2013 at 03:04 AM.
 
1 members found this post helpful.
Old 08-26-2013, 10:31 AM   #4
user1989
LQ Newbie
 
Registered: Aug 2013
Posts: 2

Original Poster
Rep: Reputation: Disabled
Thank you Sabhi. The issue has been resolved.

I installed the lftpd package on client and it started working.
 
Old 10-27-2015, 04:28 PM   #5
kherrscher
LQ Newbie
 
Registered: Feb 2015
Location: Yorba Linda
Distribution: RHEL 7
Posts: 4

Rep: Reputation: Disabled
I am getting the same error as above, while trying to connect to a remote server.

When I attempt a "yum install itcm*" to access a yum repo on a remote linux host, I get this error:

Could not open/read file://172.19.0.110//root/.itc-deployment/repodata/repomd.xm

I have also installed httpd on the remote host and tried changing the /etc/yum.repos.d/repo.repo file to read:

[ITCM_REPO]
name=itcm_repo Repo
baseurl=http://172.19.0.xx//root/.itc-deployment/
enabled=1
gpgcheck=0

And that did not work.

Can someone please help?

Last edited by kherrscher; 10-27-2015 at 04:49 PM.
 
Old 01-21-2016, 10:17 AM   #6
SAbhi
Member
 
Registered: Aug 2009
Location: Bangaluru, India
Distribution: CentOS 6.5, SuSE SLED/ SLES 10.2 SP2 /11.2, Fedora 11/16
Posts: 665

Rep: Reputation: Disabled
perhaps teh file name should be "repomd.xml". post anew thread as this is solved if this does not answer your question
 
Old 01-21-2016, 10:31 AM   #7
kherrscher
LQ Newbie
 
Registered: Feb 2015
Location: Yorba Linda
Distribution: RHEL 7
Posts: 4

Rep: Reputation: Disabled
Please forgive my typo. The file is named repomod.xml.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
PYCURL ERROR 6 - "Couldn't resolve host 'mirrorlist.centos.org'" adumith Linux - Newbie 5 01-19-2014 10:22 PM
Fedora 16 Yum [Errno 14] curl#5 - "Couldn't resolve proxy" manqox Fedora 4 04-26-2012 10:37 AM
[SOLVED] YUM not working on the client - [Errno 14] PYCURL ERROR 7 - "" infinite_scale Red Hat 3 04-25-2012 09:13 AM
fluxbox not starting "Error: couldn't connect to XServer" apemax Slackware 3 09-09-2010 05:38 AM
Couldn't display "SMB:///" , No host "(Null)" could been Found?????? munkey Linux - Newbie 3 05-03-2004 04:30 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 04:12 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration