LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   [b]Problems sharing files between linux computers (https://www.linuxquestions.org/questions/linux-networking-3/%5Bb%5Dproblems-sharing-files-between-linux-computers-36563/)

blaze 11-26-2002 09:12 PM

[b]Problems sharing files between linux computers
 
I am trying to share files between two redhat 7.2 boxes, on the box im trying to connect from (homer.simpson), the the /etc/exports file has

/misc/share marge.simpson(rw)

on marge.simpson, when i type
mount -t nfs homer.simpson:/misc/share /mnt/nfs

i get an error saying
mount: cant get address for homer.simpson

when i type
mount -t nfs 192.168.2.100:/misc/share /mnt/nfs

i get
mount: RPC: Unable to receive; errno = Connection refused

both computers have the same files set up the same way, naturally i get the same error if im trying to connect marge to homer or homer to marge

does anyone have any idea what im missing or what the problem is, i chmod 0777 /misc/share on both computers, dont know if that even makes a difference

any help is greatly appreciated
thanks

acid_kewpie 11-27-2002 04:53 AM

are these domain names listed in your /etc/hosts file? typicaly you wouldn't add the domain to it, so host.domain would be resolved as a different machine to just host by itself. if this isn't set up then it will be failing from both sides. simply having the right hostname set isn't sufficient as it'd be far to east to lie to a server, so the address has to be fully resolvable from the server.

blaze 11-27-2002 08:50 AM

I wasnt 100% sure about the hosts file so i put:
192.168.2.100 homer.simpson
192.168.2.102 marge.simpson

in the file for both computers, but i still get a message saying:
mount: RPC: Unable to receive; errno = Connection refused

thanks for the help so far, it seems like there might be something preventing my computers from receiving information from each other, the files i mentioned here are the only ones ive made any changes to, is there anything anyone can think of that im forgetting? these computers both boot in windows, and can see each other with no problems in windows, but just not when i boot in linux, is there any kind of default firewall that might be preventing transfer?

Thanks

acid_kewpie 11-27-2002 10:39 AM

firewall is unlikely, there might be one in place, whcih you should be able to remove in some gui or other... try mounting the share and then seeing if dmesg gives you any useful info. also... the nfs server is up and running on the server machine i take it?

jetfreggel 11-27-2002 12:45 PM

check if the user has permission to read or write in that dir
or make a group for that dir with that user

blaze 11-27-2002 07:48 PM

i dont have a server, just two computers that im trying to share files on, nfs is running on both, and after i make changes and restart nfs i dont get any errors, when i try to mount the share (from the other computer) is when i get the error message...what is dmesg? the share is world rwx

thanks


All times are GMT -5. The time now is 07:54 PM.