-   Linux - Mobile (
-   -   need help installing linux on my mk802 3rd generation. (

BlackHawk 10-24-2012 12:57 PM

need help installing linux on my mk802 3rd generation.
hey everyone,

so i just bought a mk802 which is a mini pc which runs natively with the android 4.0 operating system. Okay so for the past couple of days i have been trying with no success to install linux onto my mk802. In order to have linux run on my mk802 you have to burn a linux image which has been formatted for the mk802 onto a micro sdcard.

Okay so here is the steps i took and the linux image i used all which i got from this website:

step 1: download the linux image

step 2. extract the linux image with p7zip

step 3. next i copied the linux image to my sdcard with dd using this command:

dd of=/dev/sdb1

step 4. after dd finally finished it completed with no errors and i put my sdcard into my mk802 mini pc.

afterwards i booted my mk802 mini pc and waited for linux to load, however all i saw was a blank black screen and after 10 minutes of waiting and only seeing a black screen on my hd tv i gave up.

Now i have followed all of the instructions from the website but i don't get why linux is not loading, if anyone has any tips or suggestions i would really appreciate your assistance because i am lost about how to solve this problem.

I have tried posting this on the rikomagic forum website however i haven't gotten any responses and since this one of the best forum's on the internet today, i thought i would give my post a try here and hope that someone could help me out.

I want to thank you all for your help, and especially your time.

Thanks again, and if anyone needs any more information on my part let me know and i will be happy to provide whatever info you may need on my part.

JaseP 10-24-2012 03:12 PM

Try writing the image as;
dd of=/dev/sdb1 bs=1M

BlackHawk 10-24-2012 05:34 PM

hey JaseP thank you so much for your reply,

on one of the linux images i actually tried adding "bs=1M" to the end of my dd command line and while dd finished with no errors when i put it into my mk802 mini pc linux would not load.

Please if anyone has any input on this subject i would greatly appreciate it.

What makes me really frustrated is that rikomagic advertises that linux runs on the mk802 mini pc but nothing i do works?

Also what made me very frustrated with the mk802 is that in order to power the mk802 you need to plug it into a usb slot, which means i needed a mini usb to a regular usb cable WHICH RIKOMAGIC DID NOT SUPPLY. WHY?

so it was really fun having to go buy a cable so that i could use the mk802...

Part of me is really regretting purchasing this mk802, but i think once i get linux working i will enjoy it a lot more.

If anyone has come across this same issue please let me know...

Thanks again everyone

BlackHawk 10-25-2012 01:20 AM

well the only other thing that i can think of what i am doing wrong is that maybe my sdcard (which is not a name brand) is maybe the problem and that my mk802 mini pc is not loading my non name brand micro sd card.

So when i look at the miniand website which sells the mk802 mini pc they also sell sdcard which are the SanDisk class 10 micro sd cards so i am thinking of buying one of those specific sd cards...

what do you guys/gals think? should i go ahead and buy one, do you think it would really make a difference?

any input on this would really help, i am running out of ideas...

JaseP 10-25-2012 11:37 AM

There can be issues with the bootloader not being able to access the card properly, due to the way the card is formatted (Fat32 vs Fat16,... Block size, etc. ). Try to use the tools they recommend to format or otherwise prepare the card. Some brands of cards can be trouble, as well. An the card's rating can matter, as well...

BlackHawk 10-25-2012 04:49 PM

okay well when i purchased my mk802 from ebay i was told that i was buying the 3rd generation model, and i thought this was a good model but now someone has told me that linux will not run on the mk802 3rd generation because of a different chipset.

*Can anyone please verify if this is true, that linux will not work on mk802 3rd generation models, please please*

However now when i look at the settings of my mk802 i am not sure i have the 3rd generation.

After a graphical boot load up of android and rikomagic images here are what the settings tell me:

Model Number: Rikomagic MK802II

Android Version: 4.0.4

Baseband Version: 1.2

Kernel Version: 3.0.8+

Build Number: RKM-emg4.0.4IMM76D

Okay now i am almost positive that i building the bootable micro sdcard with the linux image for the mk802 mini pc correctly. I thought that i wasn't because when i would check the files on the sdcard in windows it would say that the few files only totaled 16MB's. However, when i plugged my sdcard into my card reader and checked it out in linux it showed 2 different partition numbers for my sdcard (/dev/sdb)

i would see /dev/sdb1 -> which would be about 16MB's

then i would see /dev/sdb2 -> which would total about 3.7GIG's and i would see a bunch of different folders all linux related with linux type filesystems.

So again i am pretty sure that i am building the bootable sdcard correctly, however i am lost as to why my mk802 is not loading linux?

This is getting to be very frustrating...

I hope someone can clarify if it is true that linux will not work for mk802 3rd generation (if i even have a 3rd generation mk802?)

Oh here is a copy of the output from "fdisk -l" after i have written the linux (for mk802) image to my sdcard:


Disk /dev/sdb: 15.9 GB, 15931539456 bytes
64 heads, 32 sectors/track, 15193 cylinders
Units = cylinders of 2048 * 512 = 1048576 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x69e553c5

  Device Boot      Start        End      Blocks  Id  System
/dev/sdb1              2          17      16384  83  Linux
Partition 1 does not end on cylinder boundary.
/dev/sdb2              18        3823    3897344  83  Linux
Partition 2 does not end on cylinder boundary.

jefro 12-26-2012 08:29 AM

Not fully wrong. " rikomagic advertises that linux" Android is linux.

No, you dd an image to a device. of=/dev/sdb1 should be sdx. Be sure you know what x is.

Not sure where you got the image from either. Is it built for this device?

All times are GMT -5. The time now is 01:58 AM.