-   Linux - Mobile (
-   -   How to get access to HTC Heros SD card in linux ? (

exceed1 09-28-2009 03:39 PM

How to get access to HTC Heros SD card in linux ?

I connected the HTC Hero to the computer (running debian 5.0) and it says on the phone that the USB cable is connected.. and i see these lines in dmesg:

[ 4800.392051] usb 5-5: new high speed USB device using ehci_hcd and address 7
[ 4800.537331] usb 5-5: configuration #1 chosen from 1 choice
[ 4800.552718] scsi4 : SCSI emulation for USB Mass Storage devices
[ 4800.559682] usb-storage: device found at 7
[ 4800.559689] usb-storage: waiting for device to settle before scanning
[ 4800.566691] usb 5-5: New USB device found, idVendor=0bb4, idProduct=0c01
[ 4800.566702] usb 5-5: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[ 4800.566707] usb 5-5: Product: Android Phone
[ 4800.566710] usb 5-5: Manufacturer: HTC
[ 4800.566714] usb 5-5: SerialNumber: HT998L902322
[ 4805.557884] usb-storage: device scan complete
[ 4805.559840] scsi 4:0:0:0: Direct-Access    HTC      Android Phone    0100 PQ: 0 ANSI: 2
[ 4805.566908] sd 4:0:0:0: [sdb] Attached SCSI removable disk
[ 4805.566981] sd 4:0:0:0: Attached scsi generic sg2 type 0

It seems like the kernel (2.6.26-1-486) recognizes the phone and i see this in the /dev/disk/by-id:

which points to /dev/sdb, but not actual device. There is no /dev/sdbX device present. When i try to mount the device above it says "mount: No medium found", but that seems to be because it tries to mount /dev/sdb. The device /dev/sdb does not show up in fdisk.

I have unmounted the SD card (from the settings on the phone) to try if that worked but there were no differences. I also tried to install the HTC sync software with wine, the installation went fine but the program didnt start up and the phone didnt act any different / it didnt work any better then.

Does someone know how to get this phone to sync with linux? I thinking that more people got to have this problem.. any help is appericiated.

Trickie 09-30-2009 03:52 AM

Can you read/write to the SD card, without the phone, using a card reader? Which file system do you have on the SD card? You need to establish that the card is working OK first. I've had problems with flakey SD cards in the past.


Trickie 09-30-2009 03:56 AM

...also, is the SD card switch set to read/write rather than read only?


exceed1 09-30-2009 12:22 PM

the phone is brand new so i wouldnt expect any problems with the SD card and the phone has not indicated any problems with it either... i dont have a card reader to i cant read it that way, i cant spend more money on this when i spent about 900 dollars on the phone (norway is expensive)

i cant see any information on the found indicating if it is in read/write mode.

Trickie 09-30-2009 04:21 PM

The ro/rw switch is on top of the card. You can remove the card from the phone and inspect it manually.


exceed1 10-01-2009 03:49 AM

Ok, but my question.. why would i want to remove the card or switch the read/write option when all i want is to attach the phone to the computer to transfer files.. even if it was read only i should have been able to at least mount it.. the kernel recognizes it but it doesnt seem like any block device is created for it.. when searching google i saw that some peope were mounting it like a usb harddrive and using "mount /dev/sdb1 /media/androidPhone", but since i dont have a "sdbX" device, that makes it kind of hard..

Trickie 10-01-2009 05:04 AM

I understand what it is you wish to do but you cannot assume that your SD card is OK just because it is new. I have bought new hardware in the past that has been faulty. The first thing to do, always, in the event of failure, is to prove that the media is working, otherwise you could spend hours trying to load data onto faulty media, which, clearly, is impossible. You won't even be able to mount it.

I know that you don't wish to spend any money on a card reader but they are very cheap (from 3 to 4 in the UK) and very useful. As an alternative, can't you try the card in another device.


Trickie 10-01-2009 05:20 AM

Just a thought: have you checked the output from fdisk -l /dev/sdb


exceed1 10-01-2009 11:54 AM

Thats a good point, but i dont know how to verify if the SD cards is actually working as it should.

Yes i checked fdisk and i couldnt see any sdb device at all eventhough dmesg reported it as sdb.

business_kid 10-01-2009 12:05 PM

I have a htc hero and am an absolute noob with it, but I beat this problem. It takes me 4 steps every time (as root)

1. Plug in to the pc
2. Pull down the notifications thing, select usb connection, and you'll get the option to mount the disk. Do that
3. mount /dev/sdx (where x = your drive), and receive an error. Ignore that.
4 mount /dev/sdx1 -t vfat /mnt/tmp

and it's on. Nothing else worked here.

All times are GMT -5. The time now is 02:22 AM.