-   Linux - Mobile (
-   -   Error: Read-only file system (

linuxseek 11-05-2009 12:22 PM

Error: Read-only file system
Hi Hus' another Newbie....

Firstly allowed me to confess that Linux is alien to me.

Tried to edit some files on my Motorola ZN5 using filezilla and got hese error:

Response: 257 "/usr/data_resource/preloadapps" is the current
working directory.
Status: Directory listing successful
Status: Set permissions of '/usr/data_resource
preloadapps/javaapps/JavaDB' to '773'
Command: CWD /usr/data_resource/preloadapps/javaapps
Response: 250 OK
Command: SITE CHMOD 773 JavaDB
Response: Error: Read-only file system.

How do I go about it to gain excess to change it. I have already deletted some items and its not shown on my phone, but it's shown here and I can't
edit it?

Regards & Thanks

timmeke 11-06-2009 09:06 AM

Why do you use FTP to access the ZN5 phone?
From the website, I gather it comes with sufficient software to view/share/manage pictures.
And how is it connected to your computer (bluetooth, usb, wifi)?

linuxseek 11-06-2009 10:08 AM

ZN5 - Read Only Files

1. I use ftp on the PC cos' I wanna get to the system files of the phone.
True there are couple of software I can view those, but they're built
for Motorola pk5 phones which means I can't edit of upload to the
system area, ZN5 is Linux based. From forum that I read people access
using Filzilla on XP. Tried installed Ubuntu but couldn't get to use
it. Its so confusing for me. I can't even get Ubuntu to ftp my ZN5.

2. Back to the file thing. I managed to remove a few pre installed apps
and made changes to the menu & icons to suit my taste. Phone is
workin' fine after that.
It's jus' that I noticed those few preinstlled apps are still on
the system. So I thought to remove it, sort of clean up the space and
save some ram. Also wanna edit the system directory to include my own
installed apps.

3. With ZN5,presently there's no efficient way to back-up the entire
phone unlike other model where there are lots of software available.
There's one MMBack-up magx, but its hopeless cos' the back-up always
corupt. Menu missing or files system hang etc.....


All times are GMT -5. The time now is 09:00 AM.