-   Linux - Mobile (
-   -   Android Memory Card Issues (

NotAComputerGuy 10-12-2012 09:06 PM

Android Memory Card Issues
Hi all,

I recently tried to convert my (rooted) HTC Desire's 2nd memory card partition from fat32 to ext3 by the following method: Shrink the 2nd partition, create a 3rd partition, copy the data across and delete the second partition.

My phone now won't see my memory card.

If I go into the shell through adb, I can mount /dev/block/mmcblk0p1 and /dev/block/mmcblk0p3 and see all the files. I've tried a factory reset, which didn't work, I've tried mounting these manually to where I think they're ment to be, it didn't work. My memory card is too big for my card reader to work. I originally had it mounted onto my desktop through my phone, but now my phone thinks there's no memory card, so won't allow that.


NotAComputerGuy 10-12-2012 11:18 PM

Luckily I could use a space blank memory card to reinstall clockwork mod, then insert the old card to format the card again and am seeing if photorec can recover anything.

Must learn how to use rsync one day...


All times are GMT -5. The time now is 02:26 PM.