-   Linux Mint (
-   -   What would happen if I was to move apt-get over to Slackware and tried to use it? (

Arcosanti 08-20-2012 10:48 PM

What would happen if I was to move apt-get over to Slackware and tried to use it?
I have an a non working Linux Mint 11 Katya on my second partition and Slackware on my first. I was some what tempted to try and move apt-get over to Slackware and use it just to see what would happen. So what would happen if I was to do it?

Hendronicus 08-20-2012 11:23 PM

It wouldn't work for many, many reasons. Don't bother. There are package managers for Slackware, use them. BTW - Why isn't your Mint 11 working? Maybe you should just fix that.

Arcosanti 08-21-2012 12:12 AM

I am not sure what had happened to my Linux Mint installation. It was nothing that I have ever seen before. I posted about the problem on the Linux Mint forum last year when the problem first stated up. I got no replies and so I just backed up the installation to my second partition while I was still able to use it. It eventually got to the point that it was impossible to log in on any accounts and so I just wiped it out and installed Slackware as I used it before many years ago. The problem first started with a windows mapping program that I had installed in Wine. It was refusing to run and while trying to figure that out, I discovered that the sudo command was no longer working claiming that there was no sudoers file. The sudoers file was indeed there and the permissions were set correctly, but sudo would not work. Then the problem spread to either gnome or Xwindows as I only got a black screen at boot time. When this happened I was able to get over to a text console and login as root to kill all Xindows processes and then logout. Then I would login into my regular account and start up X from the console. Then eventually my regular user account stopped working followed by root. There was no way to login any more. Based on what had happened to sudo, it seems something was blocking read access to certain config files somehow. I didn't have selinux or apparmor installed or any other Linux hardening system. Any ideas what happened? Also as far as I can tell there was no corruption on any files. I have even moved a few apps over from Mint to Slackware and have had no problems.

guyonearth 08-21-2012 04:55 PM

Systems don't just stop working on their own. Files don't disappear or change their permissions. Either you had a failing hard drive or a corrupt file system. Apt is not the native package manager for Slackware, so I doubt you can "move it over".

Arcosanti 08-22-2012 12:23 AM

It definitely isn't the hard drive. It is only two years old and has only been in use for one and a half years. Besides I'm using Slackware on it right now with no problems. Well files were not disappearing and permissions were not changing either. It was just that some files were somehow being blocked from being read in some manner. I have considered that the file system was somehow behind this but there was no corruption of any kind. All of the files were able to be backed up to my second partition with no problem. I did the backup via Midnight Commander and it is very good on informing the user of problems during file copying. I was using ext4 with Linux Mint and with Slackware I am using ext3 just to be on the safe side. The second partition is still ext4 and I haven't had any problems with it under Slackware but I don't have it auto mounted and use it lightly just in case ext4 was the problem. There are only a couple of other possibilities, I did have a problem with aptitude uninstalling a whole bunch of stuff and ended up having to reinstall them with apt-get while consulting the aptitude log file. The only other thing that I can think of was that an update had been applied on the system at about the same time that the problem started and that could have had something to do with it.

My interest in using apt-get under Slackware is to try and get certain items that are hard to get for Slackware any other way and not as a replacement for what Slackware uses.

I still have an old hard drive with Windows XP on it that is in the beginning stages of going bad with some areas marked as bad. Maybe I ought to put Linux on it and see how Linux would handle the problem. It wouldn't be any loss as that hard drive was backed up to a replacement drive fairly quickly when I discovered why XP was freezing and BSODing.

vharishankar 08-22-2012 12:46 AM


guyonearth 08-22-2012 12:51 AM

I would also recommend you move to a Debian or Debian-based system. Apt will not get you anything for Slackware that you don't already have access to, that is determined by repositories, not what package manager you use. After thinking some more, it's likely that what has happened is simply that the permissions on your Mint directory are wrong for a lot of the files when you try to access them from Slackware, which would be the case if they were installed under another system.

Availability of packages and ease of use is why I use Mint/Ubuntu and have for some time, there's just a lot more available.

Arcosanti 08-22-2012 03:00 AM

Slackware didn't have anything to do with what happened to Mint. I didn't install Slackware until about six or seven months after Mint became unusable. Mint was the only OS on the hard drive when it was operational. If Mint hadn't fallen apart the way it did, I'd probably would have never bothered installing Slackware. Slackware was Mint's replacement. As for the perrmissions I can only vouche for the sudoers file and the Windows application that had stopped working in Wine. The sudoers file's permissions were set correctly and I even changed them to see what would happen. I got an error telling me that the permissions were set wrong. So I changed them back to the correct settings only to get the error that the sudoers file was not found. I checked the sudoers file and found nothing wrong with it either. I just could not find any reason for the problem. I could not find any thing wrong with the Windows app either. The few other Windows stuff that I had installed ran just fine though. And there is the issue of this problem spreading over a period of time as if something was spreading invisibly through the system almost like a virus. The problems didn't happen all at once, but over a period of three months. If it doesn't make any sense to anyone, it didn't make any sense to me when I was faced with this problem either.

I'll have to see about looking into Debian. Although I hear it is a rolling release. How good are rolling releases? I am also wanting a light desktop as Gnome was a bit too heavy for this laptop. I'm using XFCE4 in Slackware which isn't bad but not perfect. At least it doesn't drag the system down. I was thinking of putting LXDE on and see how it is.

Some additional info:
I was just looking over my Mint logs and it looks like Appamor was installed and I didn't know it was there. There was sure a lot of mention of it in the logs. Even mentioned the Apparmor filesystem was active. My guess is that an update broke Apparmor and it started blocking things when it should not have done so. This doesn't leave me with a good feeling about using either Apparmor or SeLinux consider what government agency wrote that.

vharishankar 08-23-2012 12:09 PM


mdlinuxwolf 11-18-2012 03:14 PM

It sure sounds like a physical hard drive problem to me. Mint doesn't just start eating itself up for no reason. The slackware partition so far seems not to be affected... yet.

Try running the installation CD to see if you can fix it. If that doesn't work, use bacula to backup everything and reinstall.

All times are GMT -5. The time now is 11:09 AM.