-   Linux Mint (
-   -   using ndiswrapper in LMDE (

pottzie 12-26-2010 07:39 PM

using ndiswrapper in LMDE
I'm trying to install a wireless driver for a Linksys wsub300n in Mint's Debian Edition (32 bit). I tried going to Mint's LMDE forum, but it's down right now, so i thought I'd give LQ ashot.
LMDE comes with ndiswrapper, but I've never been able to use the installed version to install any driver. For some reason, when i try to use it to open the .inf file I have in my directory, it comes back with an error. I've seen threads saying that it needs (perhaps?) a gcc or glbc(?) file. If that's so, seems odd that it's not included, but if that (or something else) is what I need, then where or what do I have to do to get ndiswrapper to "wake up" and function?

pottzie 12-26-2010 10:32 PM

Just dug myself into the hole a little deeper and discovered that the .inf file I was using wasn't the XP driver file. It shows up when I expand the .exe file, but the XP .inf file was in the "drivers" directory. Now when I run ndiswrapper, it hangs when I try to install the correct file, saying ndiswrapper module isn't there. modprobe ndiswrapper confirms that's true. Google came up with a Debian package called Module Assistant, but when I tried to get it to download from the Package Manager, it failed to get the http address to go.

TobiSGD 12-26-2010 10:38 PM

Are you sure you have to use NDIS-wraper for this? Please post the output of

after you plugged in the WLAN-stick. Maybe there is a native driver.

LouRobytes 12-27-2010 05:40 AM

According to, the wusb300n 32-bit drivers work with ndiswrapper. Apparently, the 64-bit drivers do not.

I just compiled ndiswrapper for my Fedora kernel. The install did copy the ndiswrapper executable to /usr/sbin, but failed to place the kernel module (ndiswrapper.ko) in the /lib/modules/<kernel version>/updates directory. I did this myself and then ran depmod -a followed by ndiswrapper -i <driver.inf>. I then ran modprobe ndiswrapper. Everything worked fine.

You must have a kernel module specific to the kernel you're running. In most cases, you can get a pre-compiled binary but if you are running a very new kernel, like mine, you will have to build your own ndiswrapper.

Cheers, Lou

All times are GMT -5. The time now is 02:13 PM.