LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux Mint
User Name
Password
Linux Mint This forum is for the discussion of Linux Mint.

Notices

Reply
 
LinkBack Search this Thread
Old 11-20-2013, 06:22 AM   #1
teboil12
Member
 
Registered: Jan 2011
Location: Finland
Distribution: Mint 16 Cinnamon
Posts: 146
Blog Entries: 2

Rep: Reputation: 9
Unhappy Upgrading from Mint 15 Olivia to Mint 16 Petra


Hi

Is there a way to do it instead of being compelled to make a new install?
When I try to do an upgrade as they tell me to, all I get is this:

ERROR###ERROR###ERROR###ERROR###ERROR###ERROR###ERROR
W:Failed to fetch http://ppa.launchpad.net/gwendal-leb...-i386/Packages 404 Not Found
, E:Some index files failed to download. They have been ignored, or old ones used instead.

Sudo apt-get dist-upgrade don't work, nothing else either. Is there someone out there who can give some advice, and if so, please explain thoroughly as I'm 66 years and not very skilled in this...
 
Old 11-20-2013, 06:33 AM   #2
snowpine
Senior Member
 
Registered: Feb 2009
Posts: 3,871

Rep: Reputation: 1037Reputation: 1037Reputation: 1037Reputation: 1037Reputation: 1037Reputation: 1037Reputation: 1037Reputation: 1037
First of all, I assume you have read this page? http://community.linuxmint.com/tutorial/view/2
If you have not, then stop and give that a thorough read before you do anything else.

Okay, now let's look at your specific error message. It is telling you that http://ppa.launchpad.net/gwendal-leb...-i386/Packages is not a valid URL. This is probably because the maintainer of this PPA has not made a version yet for the unreleased Mint 16. So my recommendation is to remove this PPA from your Software Sources. (To edit your Software Sources and PPA's use MintSources as seen in the screenshots here: http://linuxmint.com/rel_olivia_whatsnew.php )

If you are (by your admission) not very skilled at Linux, then why not wait until Mint 16 is officially released as stable before upgrading?

Last edited by snowpine; 11-20-2013 at 06:35 AM.
 
1 members found this post helpful.
Old 11-20-2013, 06:41 AM   #3
syko4MT@gmx.com
LQ Newbie
 
Registered: Dec 2010
Location: Hamilton MT.
Distribution: Ubuntu11.04, Mint11, Mint12
Posts: 6

Rep: Reputation: Disabled
I run LMDE & LM15, both MATE 64.
Yesterday I had problems with updates. Perhaps part of your problem is that.
It seems that some of the PPA's were not accessible.

This A.M. the LMDE PPA's are all fine. Haven't tried LM's yet.
 
Old 11-20-2013, 08:13 AM   #4
teboil12
Member
 
Registered: Jan 2011
Location: Finland
Distribution: Mint 16 Cinnamon
Posts: 146
Blog Entries: 2

Original Poster
Rep: Reputation: 9
OK Snowpine!

I guess I have to wait, still I understood that Mint 16 is released as stable now, from last friday on...
I have removed this PPA from my Software Sources (many times, in fact) as I get the same result every time I try.

If there are descriptions as how to upgrade, why then don't they work? Guess I have to wait and see more instances of people complaining about this same problem, up to now I've seen only one, as this matter seems to be a very new one.
Maybe the solution will appear sooner or later...
 
Old 11-20-2013, 08:47 AM   #5
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo, Slackware
Posts: 14,896
Blog Entries: 2

Rep: Reputation: 3810Reputation: 3810Reputation: 3810Reputation: 3810Reputation: 3810Reputation: 3810Reputation: 3810Reputation: 3810Reputation: 3810Reputation: 3810Reputation: 3810
Quote:
Originally Posted by teboil12 View Post
I guess I have to wait, still I understood that Mint 16 is released as stable now, from last friday on...
No. They released a RC version, this is still not the final product, but meant for testing, searching and fixing bugs.
Quote:
If there are descriptions as how to upgrade, why then don't they work?
Mint in general recommends to not do upgrades, but to do a fresh reinstall, since they deem the upgrade not be trustworthy. The site snowpine linked to is a community site, so you have to test yourself if it applies to your case.
Quote:
Guess I have to wait and see more instances of people complaining about this same problem, up to now I've seen only one, as this matter seems to be a very new one.
Maybe the solution will appear sooner or later...
The solution will appear once the maintainer of that PPA releases a version of his packages for the new version of Mint. This is not a Mint problem, this problem is caused by an external maintainer.
 
1 members found this post helpful.
Old 11-20-2013, 09:04 AM   #6
snowpine
Senior Member
 
Registered: Feb 2009
Posts: 3,871

Rep: Reputation: 1037Reputation: 1037Reputation: 1037Reputation: 1037Reputation: 1037Reputation: 1037Reputation: 1037Reputation: 1037
It sounds like the MintSources app isn't working correctly for you. I have not ever used MintSources myself so I cannot assist. How comfortable are you editing text files as root (i.e. using 'sudo')?

The link for the gwendal PPA must be in one of two places: either in the file /etc/apt/sources.list or in a separate file within the sub-folder /etc/apt/sources.list.d

As a comment, please understand that the gwendal PPA software is not provided/supported by the makers of Mint in any way. If this software (which you manually installed yourself for some reason) is interfering with your upgrade, in my opinion this should not reflect poorly on the Mint developers.
 
Old 11-22-2013, 02:50 AM   #7
teboil12
Member
 
Registered: Jan 2011
Location: Finland
Distribution: Mint 16 Cinnamon
Posts: 146
Blog Entries: 2

Original Poster
Rep: Reputation: 9
My fault!

I have recently been an Ubuntu user (still have 12.04 LTS on my laptop) and got used to updates every six months the Ubuntu way. I did not remember that the Mint way is different, I suddenly realized that i have to do a fresh install every time and before that save all my valuables and re-install them after the upgrade. Just have to wait for the stable version of Linux Mint 16 Cinnamon Petra.

Sorry guys, trying to be more observant in the future!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Linux Mint 16 “Petra” MATE RC released! LXer Syndicated Linux News 0 11-18-2013 01:41 AM
LXer: Linux Mint 16 Petra Cinnamon Desktop screenshot preview LXer Syndicated Linux News 0 11-16-2013 10:10 PM
LXer: You can pre-order your copies of OpenSuSE 13.1 and Linux Mint 16 Petra LXer Syndicated Linux News 0 10-28-2013 11:23 PM
[SOLVED] Cannot get updates, Linux Mint Olivia teboil12 Linux Mint 2 10-16-2013 11:37 AM


All times are GMT -5. The time now is 08:53 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration