LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux Mint
User Name
Password
Linux Mint This forum is for the discussion of Linux Mint.

Notices


Reply
  Search this Thread
Old 02-17-2017, 05:46 AM   #1
Jayanthan
LQ Newbie
 
Registered: Feb 2017
Posts: 11

Rep: Reputation: Disabled
Unable to update old software or install new softwares


Hi There,

I need help when updating or installing any software these errors throw up

W: Failed to fetch http://packages.domain.com/dists/trusty/InRelease

W: Failed to fetch http://packages.domain.com/dists/trusty/Release.gpg Unable to connect to packages.domain.com:http:

W: Some index files failed to download. They have been ignored, or old ones used instead.

also have error in fontconfig and dpkg where sometimes different error throws up like

E: fontconfig: subprocess installed post-installation script returned error exit status 1

Thanks for taking your time out to help.
 
Old 02-17-2017, 07:51 AM   #2
hydrurga
LQ Guru
 
Registered: Nov 2008
Location: Pictland
Distribution: Linux Mint 20 MATE
Posts: 8,048
Blog Entries: 5

Rep: Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903
Hi, Jayanthan, and welcome to LQ.

Could you please paste the output from the following command, in order to see which repositories you currently have set up:

inxi -r
 
Old 02-17-2017, 08:37 AM   #3
Jayanthan
LQ Newbie
 
Registered: Feb 2017
Posts: 11

Original Poster
Rep: Reputation: Disabled
Hi Hydrurga,

Thanks for your response.

This is the response I get for inxi -r

Repos: Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
deb http://packages.linuxmint.com rosa main upstream import backport
deb http://extra.linuxmint.com rosa main
deb http://mirror.cse.iitk.ac.in/ubuntu trusty main restricted universe multiverse
deb http://mirror.cse.iitk.ac.in/ubuntu trusty-updates main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ trusty-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ trusty partner
Active apt sources in file: /etc/apt/sources.list.d/official-source-repositories.list
deb-src http://packages.linuxmint.com rosa main upstream import backport
deb-src http://extra.linuxmint.com rosa main
deb-src http://mirror.cse.iitk.ac.in/ubuntu trusty main restricted universe multiverse
deb-src http://mirror.cse.iitk.ac.in/ubuntu trusty-updates main restricted universe multiverse
deb-src http://security.ubuntu.com/ubuntu/ trusty-security main restricted universe multiverse
deb-src http://archive.canonical.com/ubuntu/ trusty partner
Active apt sources in file: /etc/apt/sources.list.d/strukturag-libde265-trusty.list
deb http://ppa.launchpad.net/strukturag/libde265/ubuntu trusty main
deb-src http://ppa.launchpad.net/strukturag/libde265/ubuntu trusty main
 
Old 02-17-2017, 09:08 AM   #4
hydrurga
LQ Guru
 
Registered: Nov 2008
Location: Pictland
Distribution: Linux Mint 20 MATE
Posts: 8,048
Blog Entries: 5

Rep: Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903
That's unusual because http://packages.domain.com (which sounds like a placeholder or a template) isn't listed in your active repositories. Your repositories look ok to me at first glance.

How long has this error been going on, and did you make any changes or do anything noteworthy before the problem arose?

What I recommend that you do in the first instance is run:

gksudo software-sources to open Software Sources,

click on "Restore the default settings" at the bottom, close the window, and paste the output from:

sudo apt-get update
 
Old 02-17-2017, 10:04 AM   #5
Jayanthan
LQ Newbie
 
Registered: Feb 2017
Posts: 11

Original Poster
Rep: Reputation: Disabled
I had removed http://packages.domain.com just yesterday but I have been having this error for about 5 months and no I didn't change anything before that.

Here is the result - it says reading packages lists... Done

Get:1 http://security.ubuntu.com trusty-security InRelease [65.9 kB]
Ign http://archive.ubuntu.com trusty InRelease
Ign http://ppa.launchpad.net trusty InRelease
Get:2 http://archive.ubuntu.com trusty-updates InRelease [65.9 kB]
Hit http://ppa.launchpad.net trusty Release.gpg
Ign http://packages.linuxmint.com rosa InRelease
Ign http://extra.linuxmint.com rosa InRelease
Ign http://archive.canonical.com trusty InRelease
Hit http://ppa.launchpad.net trusty Release
Hit http://archive.canonical.com trusty Release.gpg
Get:3 http://security.ubuntu.com trusty-security/main amd64 Packages [580 kB]
Hit http://packages.linuxmint.com rosa Release.gpg
Hit http://extra.linuxmint.com rosa Release.gpg
Hit http://ppa.launchpad.net trusty/main Sources
Hit http://archive.canonical.com trusty Release
Get:4 http://archive.ubuntu.com trusty Release.gpg [933 B]
Hit http://ppa.launchpad.net trusty/main amd64 Packages
Hit http://archive.canonical.com trusty/partner amd64 Packages
Get:5 http://archive.ubuntu.com trusty-updates/main amd64 Packages [948 kB]
Hit http://ppa.launchpad.net trusty/main i386 Packages
Hit http://archive.canonical.com trusty/partner i386 Packages
Hit http://packages.linuxmint.com rosa Release
Hit http://extra.linuxmint.com rosa Release
Hit http://ppa.launchpad.net trusty/main Translation-en
Hit http://archive.canonical.com trusty/partner Translation-en
Get:6 http://security.ubuntu.com trusty-security/restricted amd64 Packages [13.4 kB]
Get:7 http://archive.ubuntu.com trusty-updates/restricted amd64 Packages [16.4 kB]
Get:8 http://security.ubuntu.com trusty-security/universe amd64 Packages [152 kB]
Hit http://extra.linuxmint.com rosa/main amd64 Packages
Hit http://packages.linuxmint.com rosa/main amd64 Packages
Get:9 http://archive.ubuntu.com trusty-updates/universe amd64 Packages [398 kB]
Hit http://extra.linuxmint.com rosa/main i386 Packages
Hit http://packages.linuxmint.com rosa/upstream amd64 Packages
Get:10 http://archive.ubuntu.com trusty-updates/multiverse amd64 Packages [14.0 kB]
Get:11 http://security.ubuntu.com trusty-security/multiverse amd64 Packages [4,139 B]
Get:12 http://archive.ubuntu.com trusty-updates/main i386 Packages [909 kB]
Get:13 http://security.ubuntu.com trusty-security/main i386 Packages [540 kB]
Hit http://packages.linuxmint.com rosa/import amd64 Packages
Get:14 http://archive.ubuntu.com trusty-updates/restricted i386 Packages [16.2 kB]
Hit http://packages.linuxmint.com rosa/main i386 Packages
Get:15 http://security.ubuntu.com trusty-security/restricted i386 Packages [13.1 kB]
Get:16 http://archive.ubuntu.com trusty-updates/universe i386 Packages [400 kB]
Get:17 http://security.ubuntu.com trusty-security/universe i386 Packages [152 kB]
Hit http://packages.linuxmint.com rosa/upstream i386 Packages
Get:18 http://archive.ubuntu.com trusty-updates/multiverse i386 Packages [14.4 kB]
Get:19 http://archive.ubuntu.com trusty-updates/main Translation-en [467 kB]
Hit http://packages.linuxmint.com rosa/import i386 Packages
Get:20 http://security.ubuntu.com trusty-security/multiverse i386 Packages [4,278 B]
Get:21 http://archive.ubuntu.com trusty-updates/multiverse Translation-en [7,340 B]
Get:22 http://security.ubuntu.com trusty-security/main Translation-en [321 kB]
Get:23 http://archive.ubuntu.com trusty-updates/restricted Translation-en [3,847 B]
Get:24 http://archive.ubuntu.com trusty-updates/universe Translation-en [211 kB]
Get:25 http://archive.ubuntu.com trusty Release [58.5 kB]
Ign http://extra.linuxmint.com rosa/main Translation-en_IN
Get:26 http://archive.ubuntu.com trusty/main amd64 Packages [1,350 kB]
Ign http://extra.linuxmint.com rosa/main Translation-en
Get:27 http://security.ubuntu.com trusty-security/multiverse Translation-en [2,201 B]
Get:28 http://security.ubuntu.com trusty-security/restricted Translation-en [3,357 B]
Get:29 http://archive.ubuntu.com trusty/restricted amd64 Packages [13.0 kB]
Get:30 http://security.ubuntu.com trusty-security/universe Translation-en [89.1 kB]
Get:31 http://archive.ubuntu.com trusty/universe amd64 Packages [5,859 kB]
Get:32 http://archive.ubuntu.com trusty/multiverse amd64 Packages [132 kB]
Get:33 http://archive.ubuntu.com trusty/main i386 Packages [1,348 kB]
Get:34 http://archive.ubuntu.com trusty/restricted i386 Packages [13.4 kB]
Get:35 http://archive.ubuntu.com trusty/universe i386 Packages [5,866 kB]
Get:36 http://archive.ubuntu.com trusty/multiverse i386 Packages [134 kB]
Get:37 http://archive.ubuntu.com trusty/main Translation-en [762 kB]
Ign http://packages.linuxmint.com rosa/import Translation-en_IN
Ign http://packages.linuxmint.com rosa/import Translation-en
Ign http://packages.linuxmint.com rosa/main Translation-en_IN
Get:38 http://archive.ubuntu.com trusty/multiverse Translation-en [102 kB]
Ign http://packages.linuxmint.com rosa/main Translation-en
Ign http://packages.linuxmint.com rosa/upstream Translation-en_IN
Ign http://packages.linuxmint.com rosa/upstream Translation-en
Get:39 http://archive.ubuntu.com trusty/restricted Translation-en [3,457 B]
Get:40 http://archive.ubuntu.com trusty/universe Translation-en [4,089 kB]
Ign http://archive.ubuntu.com trusty/main Translation-en_IN
Ign http://archive.ubuntu.com trusty/multiverse Translation-en_IN
Ign http://archive.ubuntu.com trusty/restricted Translation-en_IN
Ign http://archive.ubuntu.com trusty/universe Translation-en_IN
Fetched 25.1 MB in 17s (1,412 kB/s)
Reading package lists... Done
 
Old 02-17-2017, 10:15 AM   #6
hydrurga
LQ Guru
 
Registered: Nov 2008
Location: Pictland
Distribution: Linux Mint 20 MATE
Posts: 8,048
Blog Entries: 5

Rep: Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903
That looks good, thanks.

Now please paste the output from:

sudo apt-get upgrade
 
Old 02-17-2017, 11:03 AM   #7
Jayanthan
LQ Newbie
 
Registered: Feb 2017
Posts: 11

Original Poster
Rep: Reputation: Disabled
here is the result

says
Errors were encountered while processing:
fontconfig
E: Sub-process /usr/bin/dpkg returned an error code (1)

at the last.
Here is the full text.

Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
chromium-browser:i386 chromium-codecs-ffmpeg-extra:i386 clamav
clamav-freshclam linux-kernel-generic mintsystem virtualbox-guest-dkms
virtualbox-guest-utils virtualbox-guest-x11
The following packages will be upgraded:
accountsservice adobe-flash-properties-gtk adobe-flashplugin apt
apt-transport-https apt-utils avahi-autoipd avahi-daemon avahi-utils
base-files bind9-host bsdutils clamav-base dbus dbus-x11 dkms dnsutils eog
ghostscript ghostscript-x gir1.2-accountsservice-1.0 gir1.2-gdkpixbuf-2.0
gir1.2-gstreamer-1.0 grub-common grub-pc grub-pc-bin grub2-common
gstreamer0.10-gconf gstreamer0.10-plugins-bad
gstreamer0.10-plugins-good:i386 gstreamer0.10-plugins-good
gstreamer0.10-pulseaudio gstreamer1.0-plugins-bad
gstreamer1.0-plugins-bad-faad gstreamer1.0-plugins-bad-videoparsers
gstreamer1.0-plugins-good gstreamer1.0-pulseaudio gstreamer1.0-tools
icedtea-7-jre-jamvm imagemagick imagemagick-common init-system-helpers
initramfs-tools initramfs-tools-bin isc-dhcp-client isc-dhcp-common
klibc-utils kpartx kpartx-boot krb5-locales libaccountsservice0 libapparmor1
libapt-inst1.5 libapt-pkg4.12 libavcodec54 libavformat54 libavutil52
libbind9-90 libblkid1 libcurl3:i386 libcurl3-gnutls libdbd-mysql-perl
libdbus-1-3 libdbus-1-3:i386 libdns100 libegl1-mesa libegl1-mesa-drivers
libgbm1 libgc1c2 libgd3 libgd3:i386 libgdk-pixbuf2.0-0
libgdk-pixbuf2.0-0:i386 libgdk-pixbuf2.0-common libgl1-mesa-dri:i386
libgl1-mesa-dri libgl1-mesa-glx libgl1-mesa-glx:i386 libglapi-mesa:i386
libglapi-mesa libgles2-mesa libgme0 libgnutls-openssl27 libgnutls26
libgnutls26:i386 libgs9 libgs9-common libgssapi-krb5-2 libgssapi-krb5-2:i386
libgstreamer-plugins-bad0.10-0 libgstreamer-plugins-bad1.0-0
libgstreamer-plugins-good1.0-0 libgstreamer1.0-0 libgstreamer1.0-0:i386
libgweather-3-6 libgweather-common libhogweed2 libisc95 libisccc90
libisccfg90 libk5crypto3 libk5crypto3:i386 libklibc libkrb5-3 libkrb5-3:i386
libkrb5support0 libkrb5support0:i386 liblwres90 libmagickcore5
libmagickwand5 libmount1 libmysqlclient18 libnettle4 libnl-3-200
libnl-genl-3-200 libnl-route-3-200 libnss3 libnss3:i386 libnss3-1d
libnss3-nssdb libopenvg1-mesa libpcsclite1 libplymouth2 libpython2.7
libpython2.7-minimal libpython2.7-stdlib libpython3.4 libpython3.4-minimal
libpython3.4-stdlib libservlet3.0-java libsmbclient libspectre1
libssl1.0.0:i386 libssl1.0.0 libswscale2 libtomcat7-java libupnp6 libuuid1
libuuid1:i386 libwayland-egl1-mesa libwbclient0 libxatracker2 libxpm4
libxpm4:i386 linux-firmware linux-libc-dev mint-artwork-common mint-mirrors
mount mysql-client mysql-client-5.5 mysql-client-core-5.5 mysql-common
mysql-server mysql-server-5.5 mysql-server-core-5.5 ntpdate openjdk-7-jdk
openjdk-7-jre openjdk-7-jre-headless openjdk-7-jre-lib openssh-client
openssl perlmagick plymouth plymouth-label plymouth-theme-ubuntu-text
python-crypto python-imaging python-imaging-compat python-pil python-samba
python2.7 python2.7-minimal python3-crypto python3-pil python3.4
python3.4-minimal samba samba-common samba-common-bin samba-dsdb-modules
samba-libs smbclient ssh-askpass-gnome sudo tar tzdata tzdata-java
ubuntu-drivers-common util-linux uuid-runtime vim vim-common vim-runtime
vim-tiny x11-common xorg xserver-xorg xserver-xorg-input-all
xserver-xorg-video-all xserver-xorg-video-intel
xserver-xorg-video-openchrome
203 upgraded, 0 newly installed, 0 to remove and 9 not upgraded.
1 not fully installed or removed.
Need to get 161 MB/191 MB of archives.
After this operation, 56.2 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Get:1 http://archive.ubuntu.com/ubuntu/ trusty-updates/main mount amd64 2.20.1-5.1ubuntu20.9 [115 kB]
Get:2 http://packages.linuxmint.com/ rosa/upstream ubuntu-drivers-common amd64 1:0.2.91.12linuxmint1 [62.4 kB]
Get:3 http://archive.ubuntu.com/ubuntu/ trusty-updates/main tar amd64 1.27.1-1ubuntu0.1 [196 kB]
Get:4 http://archive.ubuntu.com/ubuntu/ trusty-updates/main tzdata-java all 2016j-0ubuntu0.14.04 [68.8 kB]
Get:5 http://archive.ubuntu.com/ubuntu/ trusty-updates/main tzdata all 2016j-0ubuntu0.14.04 [166 kB]
Get:6 http://archive.ubuntu.com/ubuntu/ trusty-updates/main util-linux amd64 2.20.1-5.1ubuntu20.9 [458 kB]
Get:7 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libapt-pkg4.12 amd64 1.0.1ubuntu2.17 [639 kB]
Get:8 http://archive.ubuntu.com/ubuntu/ trusty-updates/main apt amd64 1.0.1ubuntu2.17 [953 kB]
Get:9 http://archive.ubuntu.com/ubuntu/ trusty-updates/main bsdutils amd64 1:2.20.1-5.1ubuntu20.9 [33.9 kB]
Get:10 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libapt-inst1.5 amd64 1.0.1ubuntu2.17 [58.8 kB]
Get:11 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libgnutls-openssl27 amd64 2.12.23-12ubuntu2.6 [18.4 kB]
Get:12 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libgnutls26 i386 2.12.23-12ubuntu2.6 [375 kB]
Get:13 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libgnutls26 amd64 2.12.23-12ubuntu2.6 [394 kB]
Get:14 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libssl1.0.0 i386 1.0.1f-1ubuntu2.22 [782 kB]
Get:15 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libssl1.0.0 amd64 1.0.1f-1ubuntu2.22 [828 kB]
Get:16 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libuuid1 i386 2.20.1-5.1ubuntu20.9 [11.4 kB]
Get:17 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libuuid1 amd64 2.20.1-5.1ubuntu20.9 [10.8 kB]
Get:18 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libblkid1 amd64 2.20.1-5.1ubuntu20.9 [62.6 kB]
Get:19 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libdbus-1-3 i386 1.6.18-0ubuntu4.5 [132 kB]
Get:20 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libdbus-1-3 amd64 1.6.18-0ubuntu4.5 [132 kB]
Get:21 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libmount1 amd64 2.20.1-5.1ubuntu20.9 [60.3 kB]
Get:22 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libk5crypto3 amd64 1.12+dfsg-2ubuntu5.3 [79.6 kB]
Get:23 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libk5crypto3 i386 1.12+dfsg-2ubuntu5.3 [77.5 kB]
Get:24 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libkrb5support0 i386 1.12+dfsg-2ubuntu5.3 [31.0 kB]
Get:25 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libkrb5support0 amd64 1.12+dfsg-2ubuntu5.3 [30.7 kB]
Get:26 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libkrb5-3 amd64 1.12+dfsg-2ubuntu5.3 [262 kB]
Get:27 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libkrb5-3 i386 1.12+dfsg-2ubuntu5.3 [260 kB]
Get:28 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libgssapi-krb5-2 i386 1.12+dfsg-2ubuntu5.3 [112 kB]
Get:29 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libgssapi-krb5-2 amd64 1.12+dfsg-2ubuntu5.3 [114 kB]
Get:30 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libcurl3-gnutls amd64 7.35.0-1ubuntu2.10 [166 kB]
Get:31 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libgdk-pixbuf2.0-common all 2.30.7-0ubuntu1.6 [9,066 B]
Get:32 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libgdk-pixbuf2.0-0 i386 2.30.7-0ubuntu1.6 [158 kB]
Get:33 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libgdk-pixbuf2.0-0 amd64 2.30.7-0ubuntu1.6 [160 kB]
Get:34 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libpython2.7 amd64 2.7.6-8ubuntu0.3 [1,039 kB]
Get:35 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libpython2.7-minimal amd64 2.7.6-8ubuntu0.3 [307 kB]
Get:36 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libpython2.7-stdlib amd64 2.7.6-8ubuntu0.3 [1,873 kB]
Get:37 http://archive.ubuntu.com/ubuntu/ trusty-updates/main python2.7-minimal amd64 2.7.6-8ubuntu0.3 [1,187 kB]
Get:38 http://archive.ubuntu.com/ubuntu/ trusty-updates/main python2.7 amd64 2.7.6-8ubuntu0.3 [197 kB]
Get:39 http://archive.ubuntu.com/ubuntu/ trusty-updates/main python3.4 amd64 3.4.3-1ubuntu1~14.04.5 [178 kB]
Get:40 http://archive.ubuntu.com/ubuntu/ trusty-updates/main python3.4-minimal amd64 3.4.3-1ubuntu1~14.04.5 [1,220 kB]
Get:41 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libpython3.4 amd64 3.4.3-1ubuntu1~14.04.5 [1,304 kB]
Get:42 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libpython3.4-stdlib amd64 3.4.3-1ubuntu1~14.04.5 [1,985 kB]
Get:43 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libpython3.4-minimal amd64 3.4.3-1ubuntu1~14.04.5 [462 kB]
Get:44 http://archive.ubuntu.com/ubuntu/ trusty-updates/main ntpdate amd64 1:4.2.6.p5+dfsg-3ubuntu2.14.04.10 [57.7 kB]
Get:45 http://archive.ubuntu.com/ubuntu/ trusty-updates/main klibc-utils amd64 2.0.3-0ubuntu1.14.04.2 [107 kB]
Get:46 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libklibc amd64 2.0.3-0ubuntu1.14.04.2 [40.6 kB]
Get:47 http://archive.ubuntu.com/ubuntu/ trusty-updates/main initramfs-tools all 0.103ubuntu4.6 [44.5 kB]
Get:48 http://archive.ubuntu.com/ubuntu/ trusty-updates/main initramfs-tools-bin amd64 0.103ubuntu4.6 [9,134 B]
Get:49 http://archive.ubuntu.com/ubuntu/ trusty-updates/main gstreamer0.10-gconf amd64 0.10.31-3+nmu1ubuntu5.2 [68.0 kB]
Get:50 http://archive.ubuntu.com/ubuntu/ trusty-updates/main gstreamer0.10-plugins-good i386 0.10.31-3+nmu1ubuntu5.2 [1,340 kB]
Get:51 http://archive.ubuntu.com/ubuntu/ trusty-updates/main gstreamer0.10-plugins-good amd64 0.10.31-3+nmu1ubuntu5.2 [1,363 kB]
Get:52 http://archive.ubuntu.com/ubuntu/ trusty-updates/universe gstreamer0.10-plugins-bad amd64 0.10.23-7.2ubuntu1.3 [1,152 kB]
Get:53 http://archive.ubuntu.com/ubuntu/ trusty-updates/universe libgstreamer-plugins-bad0.10-0 amd64 0.10.23-7.2ubuntu1.3 [136 kB]
Get:54 http://archive.ubuntu.com/ubuntu/ trusty-updates/universe libgme0 amd64 0.5.5-2ubuntu0.14.04.1 [105 kB]
Get:55 http://archive.ubuntu.com/ubuntu/ trusty-updates/main imagemagick-common all 8:6.7.7.10-6ubuntu3.3 [37.8 kB]
Get:56 http://archive.ubuntu.com/ubuntu/ trusty-updates/universe libavutil52 amd64 6:9.20-0ubuntu0.14.04.1 [66.9 kB]
Get:57 http://archive.ubuntu.com/ubuntu/ trusty-updates/universe libavcodec54 amd64 6:9.20-0ubuntu0.14.04.1 [2,350 kB]
Get:58 http://archive.ubuntu.com/ubuntu/ trusty-updates/universe libavformat54 amd64 6:9.20-0ubuntu0.14.04.1 [481 kB]
Get:59 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libcurl3 i386 7.35.0-1ubuntu2.10 [175 kB]
Get:60 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libgc1c2 amd64 1:7.2d-5ubuntu2.1 [74.8 kB]
Get:61 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libxpm4 amd64 1:3.5.10-1ubuntu0.1 [33.2 kB]
Get:62 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libxpm4 i386 1:3.5.10-1ubuntu0.1 [32.3 kB]
Get:63 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libgd3 i386 2.1.0-3ubuntu0.5 [118 kB]
Get:64 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libgd3 amd64 2.1.0-3ubuntu0.5 [122 kB]
Get:65 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libgstreamer1.0-0 i386 1.2.4-0ubuntu1.1 [585 kB]
Get:66 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libgstreamer1.0-0 amd64 1.2.4-0ubuntu1.1 [598 kB]
Get:67 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libnettle4 amd64 2.7.1-1ubuntu0.2 [102 kB]
Get:68 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libhogweed2 amd64 2.7.1-1ubuntu0.2 [124 kB]
Get:69 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libmagickcore5 amd64 8:6.7.7.10-6ubuntu3.3 [1,474 kB]
Get:70 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libmagickwand5 amd64 8:6.7.7.10-6ubuntu3.3 [265 kB]
Get:71 http://archive.ubuntu.com/ubuntu/ trusty-updates/main mysql-common all 5.5.54-0ubuntu0.14.04.1 [13.0 kB]
Get:72 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libmysqlclient18 amd64 5.5.54-0ubuntu0.14.04.1 [597 kB]
Get:73 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libnl-route-3-200 amd64 3.2.21-1ubuntu4 [96.1 kB]
Get:74 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libnl-genl-3-200 amd64 3.2.21-1ubuntu4 [10.2 kB]
Get:75 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libnl-3-200 amd64 3.2.21-1ubuntu4 [45.6 kB]
Get:76 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libnss3-nssdb all 2:3.26.2-0ubuntu0.14.04.3 [10.6 kB]
Get:77 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libnss3-1d amd64 2:3.26.2-0ubuntu0.14.04.3 [9,312 B]
Get:78 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libnss3 i386 2:3.26.2-0ubuntu0.14.04.3 [1,087 kB]
Get:79 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libnss3 amd64 2:3.26.2-0ubuntu0.14.04.3 [1,126 kB]
Get:80 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libpcsclite1 amd64 1.8.10-1ubuntu1.1 [21.1 kB]
Get:81 http://archive.ubuntu.com/ubuntu/ trusty-updates/main ghostscript amd64 9.10~dfsg-0ubuntu10.6 [40.8 kB]
Get:82 http://archive.ubuntu.com/ubuntu/ trusty-updates/main ghostscript-x amd64 9.10~dfsg-0ubuntu10.6 [33.3 kB]
Get:83 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libgs9-common all 9.10~dfsg-0ubuntu10.6 [2,067 kB]
Get:84 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libgs9 amd64 9.10~dfsg-0ubuntu10.6 [1,940 kB]
Get:85 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libspectre1 amd64 0.2.7-2ubuntu1.2 [29.7 kB]
Get:86 http://archive.ubuntu.com/ubuntu/ trusty-updates/universe libswscale2 amd64 6:9.20-0ubuntu0.14.04.1 [81.7 kB]
Get:87 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libwbclient0 amd64 2:4.3.11+dfsg-0ubuntu0.14.04.4 [31.0 kB]
Get:88 http://archive.ubuntu.com/ubuntu/ trusty-updates/main mysql-server all 5.5.54-0ubuntu0.14.04.1 [11.3 kB]
Get:89 http://archive.ubuntu.com/ubuntu/ trusty-updates/main mysql-server-5.5 amd64 5.5.54-0ubuntu0.14.04.1 [1,849 kB]
Get:90 http://archive.ubuntu.com/ubuntu/ trusty-updates/main mysql-client all 5.5.54-0ubuntu0.14.04.1 [11.2 kB]
Get:91 http://archive.ubuntu.com/ubuntu/ trusty-updates/main mysql-client-5.5 amd64 5.5.54-0ubuntu0.14.04.1 [1,603 kB]
Get:92 http://archive.ubuntu.com/ubuntu/ trusty-updates/main mysql-client-core-5.5 amd64 5.5.54-0ubuntu0.14.04.1 [709 kB]
Get:93 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libdbd-mysql-perl amd64 4.025-1ubuntu0.1 [87.6 kB]
Get:94 http://archive.ubuntu.com/ubuntu/ trusty-updates/main mysql-server-core-5.5 amd64 5.5.54-0ubuntu0.14.04.1 [3,763 kB]
Get:95 http://archive.ubuntu.com/ubuntu/ trusty-updates/main openjdk-7-jdk amd64 7u121-2.6.8-1ubuntu0.14.04.3 [16.1 MB]
Get:96 http://archive.ubuntu.com/ubuntu/ trusty-updates/main openjdk-7-jre amd64 7u121-2.6.8-1ubuntu0.14.04.3 [172 kB]
Get:97 http://archive.ubuntu.com/ubuntu/ trusty-updates/universe openjdk-7-jre-lib all 7u121-2.6.8-1ubuntu0.14.04.3 [35.2 kB]
Get:98 http://archive.ubuntu.com/ubuntu/ trusty-updates/main icedtea-7-jre-jamvm amd64 7u121-2.6.8-1ubuntu0.14.04.3 [431 kB]
Get:99 http://archive.ubuntu.com/ubuntu/ trusty-updates/main openjdk-7-jre-headless amd64 7u121-2.6.8-1ubuntu0.14.04.3 [39.3 MB]
Get:100 http://archive.ubuntu.com/ubuntu/ trusty-updates/main python-crypto amd64 2.6.1-4ubuntu0.1 [239 kB]
Get:101 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libsmbclient amd64 2:4.3.11+dfsg-0ubuntu0.14.04.4 [53.0 kB]
Get:102 http://archive.ubuntu.com/ubuntu/ trusty-updates/main smbclient amd64 2:4.3.11+dfsg-0ubuntu0.14.04.4 [313 kB]
Get:103 http://archive.ubuntu.com/ubuntu/ trusty-updates/main samba amd64 2:4.3.11+dfsg-0ubuntu0.14.04.4 [905 kB]
Get:104 http://archive.ubuntu.com/ubuntu/ trusty-updates/main samba-common-bin amd64 2:4.3.11+dfsg-0ubuntu0.14.04.4 [508 kB]
Get:105 http://archive.ubuntu.com/ubuntu/ trusty-updates/main samba-common all 2:4.3.11+dfsg-0ubuntu0.14.04.4 [84.6 kB]
Get:106 http://archive.ubuntu.com/ubuntu/ trusty-updates/main samba-dsdb-modules amd64 2:4.3.11+dfsg-0ubuntu0.14.04.4 [218 kB]
Get:107 http://archive.ubuntu.com/ubuntu/ trusty-updates/main python-samba amd64 2:4.3.11+dfsg-0ubuntu0.14.04.4 [1,066 kB]
Get:108 http://archive.ubuntu.com/ubuntu/ trusty-updates/main samba-libs amd64 2:4.3.11+dfsg-0ubuntu0.14.04.4 [5,138 kB]
Get:109 http://archive.ubuntu.com/ubuntu/ trusty-updates/universe gstreamer1.0-plugins-bad-videoparsers amd64 1.2.4-1~ubuntu1.1 [61.2 kB]
Get:110 http://archive.ubuntu.com/ubuntu/ trusty-updates/universe gstreamer1.0-plugins-bad-faad amd64 1.2.4-1~ubuntu1.1 [21.1 kB]
Get:111 http://archive.ubuntu.com/ubuntu/ trusty-updates/universe gstreamer1.0-plugins-bad amd64 1.2.4-1~ubuntu1.1 [1,025 kB]
Get:112 http://archive.ubuntu.com/ubuntu/ trusty-updates/main gstreamer1.0-plugins-good amd64 1.2.4-1~ubuntu1.3 [1,289 kB]
Get:113 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libgstreamer-plugins-good1.0-0 amd64 1.2.4-1~ubuntu1.3 [32.2 kB]
Get:114 http://archive.ubuntu.com/ubuntu/ trusty-updates/universe libgstreamer-plugins-bad1.0-0 amd64 1.2.4-1~ubuntu1.1 [117 kB]
Get:115 http://archive.ubuntu.com/ubuntu/ trusty-updates/universe libupnp6 amd64 1:1.6.17-1.2+deb7u2build0.14.04.1 [117 kB]
Get:116 http://archive.ubuntu.com/ubuntu/ trusty-updates/main apt-utils amd64 1.0.1ubuntu2.17 [171 kB]
Get:117 http://archive.ubuntu.com/ubuntu/ trusty-updates/main init-system-helpers all 1.14ubuntu1 [10.7 kB]
Get:118 http://archive.ubuntu.com/ubuntu/ trusty-updates/main isc-dhcp-client amd64 4.2.4-7ubuntu12.8 [640 kB]
Get:119 http://archive.ubuntu.com/ubuntu/ trusty-updates/main isc-dhcp-common amd64 4.2.4-7ubuntu12.8 [708 kB]
Get:120 http://archive.ubuntu.com/ubuntu/ trusty-updates/main sudo amd64 1.8.9p5-1ubuntu1.3 [342 kB]
Get:121 http://archive.ubuntu.com/ubuntu/ trusty-updates/main vim amd64 2:7.4.052-1ubuntu3.1 [955 kB]
Get:122 http://archive.ubuntu.com/ubuntu/ trusty-updates/main vim-tiny amd64 2:7.4.052-1ubuntu3.1 [391 kB]
Get:123 http://archive.ubuntu.com/ubuntu/ trusty-updates/main vim-runtime all 2:7.4.052-1ubuntu3.1 [4,882 kB]
Get:124 http://archive.ubuntu.com/ubuntu/ trusty-updates/main vim-common amd64 2:7.4.052-1ubuntu3.1 [95.2 kB]
Get:125 http://archive.ubuntu.com/ubuntu/ trusty-updates/main accountsservice amd64 0.6.35-0ubuntu7.3 [60.6 kB]
Get:126 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libaccountsservice0 amd64 0.6.35-0ubuntu7.3 [69.8 kB]
Get:127 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libapparmor1 amd64 2.10.95-0ubuntu2.5~14.04.1 [33.2 kB]
Get:128 http://archive.ubuntu.com/ubuntu/ trusty-updates/main dbus amd64 1.6.18-0ubuntu4.5 [232 kB]
Get:129 http://archive.ubuntu.com/ubuntu/ trusty-updates/main apt-transport-https amd64 1.0.1ubuntu2.17 [25.0 kB]
Get:130 http://archive.ubuntu.com/ubuntu/ trusty-updates/main bind9-host amd64 1:9.9.5.dfsg-3ubuntu0.13 [46.6 kB]
Get:131 http://archive.ubuntu.com/ubuntu/ trusty-updates/main dnsutils amd64 1:9.9.5.dfsg-3ubuntu0.13 [96.7 kB]
Get:132 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libisc95 amd64 1:9.9.5.dfsg-3ubuntu0.13 [148 kB]
Get:133 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libdns100 amd64 1:9.9.5.dfsg-3ubuntu0.13 [644 kB]
Get:134 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libisccc90 amd64 1:9.9.5.dfsg-3ubuntu0.13 [15.7 kB]
Get:135 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libisccfg90 amd64 1:9.9.5.dfsg-3ubuntu0.13 [35.9 kB]
Get:136 http://archive.ubuntu.com/ubuntu/ trusty-updates/main liblwres90 amd64 1:9.9.5.dfsg-3ubuntu0.13 [32.8 kB]
Get:137 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libbind9-90 amd64 1:9.9.5.dfsg-3ubuntu0.13 [22.0 kB]
Get:138 http://archive.ubuntu.com/ubuntu/ trusty-updates/main krb5-locales all 1.12+dfsg-2ubuntu5.3 [13.5 kB]
Get:139 http://archive.ubuntu.com/ubuntu/ trusty-updates/main openssl amd64 1.0.1f-1ubuntu2.22 [489 kB]
Get:140 http://archive.ubuntu.com/ubuntu/ trusty-updates/main uuid-runtime amd64 2.20.1-5.1ubuntu20.9 [12.2 kB]
Get:141 http://archive.ubuntu.com/ubuntu/ trusty-updates/main clamav-base all 0.99.2+addedllvm-0ubuntu0.14.04.1 [110 kB]
Get:142 http://archive.ubuntu.com/ubuntu/ trusty-updates/main dbus-x11 amd64 1.6.18-0ubuntu4.5 [19.2 kB]
Get:143 http://archive.ubuntu.com/ubuntu/ trusty-updates/main dkms all 2.2.0.3-1.1ubuntu5.14.04.9 [65.7 kB]
Get:144 http://archive.ubuntu.com/ubuntu/ trusty-updates/main gir1.2-accountsservice-1.0 amd64 0.6.35-0ubuntu7.3 [4,678 B]
Get:145 http://archive.ubuntu.com/ubuntu/ trusty-updates/main gir1.2-gdkpixbuf-2.0 amd64 2.30.7-0ubuntu1.6 [7,960 B]
Get:146 http://archive.ubuntu.com/ubuntu/ trusty-updates/main gir1.2-gstreamer-1.0 amd64 1.2.4-0ubuntu1.1 [65.7 kB]
Get:147 http://archive.ubuntu.com/ubuntu/ trusty-updates/main gstreamer0.10-pulseaudio amd64 0.10.31-3+nmu1ubuntu5.2 [99.7 kB]
Get:148 http://archive.ubuntu.com/ubuntu/ trusty-updates/main gstreamer1.0-pulseaudio amd64 1.2.4-1~ubuntu1.3 [49.6 kB]
Get:149 http://archive.ubuntu.com/ubuntu/ trusty-updates/main gstreamer1.0-tools amd64 1.2.4-0ubuntu1.1 [37.1 kB]
Get:150 http://archive.ubuntu.com/ubuntu/ trusty-updates/main imagemagick amd64 8:6.7.7.10-6ubuntu3.3 [189 kB]
Get:151 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libgweather-common all 3.10.2-0ubuntu3 [510 kB]
Get:152 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libgweather-3-6 amd64 3.10.2-0ubuntu3 [58.7 kB]
Get:153 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libservlet3.0-java all 7.0.52-1ubuntu0.9 [296 kB]
Get:154 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libtomcat7-java all 7.0.52-1ubuntu0.9 [3,654 kB]
Get:155 http://archive.ubuntu.com/ubuntu/ trusty-updates/main linux-firmware all 1.127.23 [33.1 MB]
Get:156 http://archive.ubuntu.com/ubuntu/ trusty-updates/main linux-libc-dev amd64 3.13.0-108.155 [772 kB]
Get:157 http://archive.ubuntu.com/ubuntu/ trusty-updates/main perlmagick amd64 8:6.7.7.10-6ubuntu3.3 [139 kB]
Get:158 http://archive.ubuntu.com/ubuntu/ trusty-updates/main python-pil amd64 2.3.0-1ubuntu3.3 [279 kB]
Get:159 http://archive.ubuntu.com/ubuntu/ trusty-updates/main python-imaging all 2.3.0-1ubuntu3.3 [4,666 B]
Get:160 http://archive.ubuntu.com/ubuntu/ trusty-updates/universe python-imaging-compat all 2.3.0-1ubuntu3.3 [1,848 B]
Get:161 http://archive.ubuntu.com/ubuntu/ trusty-updates/main python3-crypto amd64 2.6.1-4ubuntu0.1 [239 kB]
Get:162 http://archive.ubuntu.com/ubuntu/ trusty-updates/main python3-pil amd64 2.3.0-1ubuntu3.3 [281 kB]
Get:163 http://archive.ubuntu.com/ubuntu/ trusty-updates/main xserver-xorg-video-intel amd64 2:2.99.910-0ubuntu1.7 [621 kB]
Get:164 http://archive.ubuntu.com/ubuntu/ trusty-updates/main kpartx-boot all 0.4.9-3ubuntu7.15 [2,130 B]
Get:165 http://archive.ubuntu.com/ubuntu/ trusty-updates/main kpartx amd64 0.4.9-3ubuntu7.15 [22.0 kB]
Fetched 161 MB in 2min 13s (1,208 kB/s)
Extracting templates from packages: 100%
Preconfiguring packages ...
Setting up fontconfig (2.11.0-0ubuntu4.2) ...
Regenerating fonts cache... failed.
See /var/log/fontconfig.log for more information.
dpkg: error processing package fontconfig (--configure):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
fontconfig
E: Sub-process /usr/bin/dpkg returned an error code (1)
 
Old 02-17-2017, 11:10 AM   #8
hydrurga
LQ Guru
 
Registered: Nov 2008
Location: Pictland
Distribution: Linux Mint 20 MATE
Posts: 8,048
Blog Entries: 5

Rep: Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903
Ok, the problem appears to lie with the package fontconfig not having been fully installed. We'll try to rectify that.

First to see the package's status:

dpkg -s fontconfig

Also, as requested by the error message, in order to try to get more info on why installing fontconfig failed:

tail /var/log/fontconfig.log

Last edited by hydrurga; 02-17-2017 at 11:17 AM.
 
Old 02-17-2017, 11:23 AM   #9
Jayanthan
LQ Newbie
 
Registered: Feb 2017
Posts: 11

Original Poster
Rep: Reputation: Disabled
for

dpkg -s fontconfig

I got

Package: fontconfig
Status: install ok half-configured
Priority: optional
Section: fonts
Installed-Size: 553
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Architecture: amd64
Multi-Arch: foreign
Version: 2.11.0-0ubuntu4.2
Config-Version: 2.11.0-0ubuntu4.1
Replaces: fontconfig-config (<< 2.5.93-1)
Depends: fontconfig-config, libc6 (>= 2.3.4), libfontconfig1 (>= 2.9.0), libfreetype6 (>= 2.2.1)
Description: generic font configuration library - support binaries
Fontconfig is a font configuration and customization library, which
does not depend on the X Window System. It is designed to locate
fonts within the system and select them according to requirements
specified by applications.
.
Fontconfig is not a rasterization library, nor does it impose a
particular rasterization library on the application. The X-specific
library 'Xft' uses fontconfig along with freetype to specify and
rasterize fonts.
.
This package contains a program to maintain the fontconfig cache
(fc-cache), a sample program to list installed fonts (fc-list), a program
to test the matching rules (fc-match) and a program to dump the binary
cache files in string form (fc-cat). It no longer makes fonts managed by defoma
available to fontconfig applications.
Original-Maintainer: Keith Packard <keithp@debian.org>

and for

tail /var/log/fontconfig.log

I got

tail /var/log/fontconfig.log
/usr/share/fonts/X11/encodings: caching, new cache contents: 0 fonts, 1 dirs
/usr/share/fonts/X11/encodings/large: caching, new cache contents: 0 fonts, 0 dirs
/usr/share/fonts/X11/misc: caching, new cache contents: 59 fonts, 0 dirs
/usr/share/fonts/X11/util: caching, new cache contents: 0 fonts, 0 dirs
/usr/share/fonts/cmap: caching, new cache contents: 0 fonts, 5 dirs
/usr/share/fonts/cmap/adobe-cns1: caching, new cache contents: 0 fonts, 0 dirs
/usr/share/fonts/cmap/adobe-gb1: caching, new cache contents: 0 fonts, 0 dirs
/usr/share/fonts/cmap/adobe-japan1: caching, new cache contents: 0 fonts, 0 dirs
/usr/share/fonts/cmap/adobe-japan2: caching, new cache contents: 0 fonts, 0 dirs
/usr/share/fonts/cmap/adobe-korea1: Bus error
 
Old 02-17-2017, 11:36 AM   #10
hydrurga
LQ Guru
 
Registered: Nov 2008
Location: Pictland
Distribution: Linux Mint 20 MATE
Posts: 8,048
Blog Entries: 5

Rep: Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903
It's stalling at the Adobe Korean font (hopefully not on any others too but we'll cross that bridge when we come to it).

What we can try to do is remove that font package for the moment and see if that makes a difference. I assume, based in India, that you're not using Korean on your machine.

sudo apt-get purge cmap-adobe-korea1

sudo apt-get install fontconfig

Last edited by hydrurga; 02-17-2017 at 11:39 AM. Reason: Easuer this way
 
Old 02-17-2017, 11:56 AM   #11
Jayanthan
LQ Newbie
 
Registered: Feb 2017
Posts: 11

Original Poster
Rep: Reputation: Disabled
haha nice guess. I am based in India and I don't use Korean on my machine.

same dpkg error in both commands.

for

sudo apt-get purge cmap-adobe-korea1

I got

Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'poppler-data' instead of 'cmap-adobe-korea1'
0 upgraded, 0 newly installed, 0 to remove and 212 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up fontconfig (2.11.0-0ubuntu4.2) ...
Regenerating fonts cache... failed.
See /var/log/fontconfig.log for more information.
dpkg: error processing package fontconfig (--configure):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
fontconfig
E: Sub-process /usr/bin/dpkg returned an error code (1)

and for sudo apt-get install fontconfig

I got

Reading package lists... Done
Building dependency tree
Reading state information... Done
fontconfig is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 212 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Setting up fontconfig (2.11.0-0ubuntu4.2) ...
Regenerating fonts cache... failed.
See /var/log/fontconfig.log for more information.
dpkg: error processing package fontconfig (--configure):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
fontconfig
E: Sub-process /usr/bin/dpkg returned an error code (1)
 
Old 02-17-2017, 12:16 PM   #12
hydrurga
LQ Guru
 
Registered: Nov 2008
Location: Pictland
Distribution: Linux Mint 20 MATE
Posts: 8,048
Blog Entries: 5

Rep: Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903
Ok, next move, courtesy of http://askubuntu.com/questions/59033...untu-reinstall

sudo apt-get install --reinstall --purge fontconfig-config
 
Old 02-17-2017, 12:44 PM   #13
Jayanthan
LQ Newbie
 
Registered: Feb 2017
Posts: 11

Original Poster
Rep: Reputation: Disabled
I am getting the same error.

Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 212 not upgraded.
1 not fully installed or removed.
Need to get 47.4 kB of archives.
After this operation, 0 B of additional disk space will be used.
Get:1 http://archive.ubuntu.com/ubuntu/ trusty-updates/main fontconfig-config all 2.11.0-0ubuntu4.2 [47.4 kB]
Fetched 47.4 kB in 0s (61.3 kB/s)
Setting up fontconfig (2.11.0-0ubuntu4.2) ...
Regenerating fonts cache... failed.
See /var/log/fontconfig.log for more information.
dpkg: error processing package fontconfig (--configure):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
fontconfig
E: Sub-process /usr/bin/dpkg returned an error code (1)

I tried sudo apt-get install fontconfig-config=2.11.0-0ubuntu4

no luck I got

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libgtk2.0-cil : Depends: libcairo2 (>= 1.12.0) but it is not going to be installed
Depends: libgtk2.0-0 (>= 2.24.0) but it is not going to be installed
Depends: libmono-cairo4.0-cil (>= 2.10.1) but it is not going to be installed
Depends: libmono-system-drawing4.0-cil (>= 1.0) but it is not going to be installed
Depends: libpango1.0-0 (>= 1.29.4) but it is not going to be installed
libmono-system-web-services4.0-cil : Depends: libmono-system-web4.0-cil (>= 2.10.3) but it is not going to be installed
monodoc-http : Depends: mono-xsp4 but it is not going to be installed or
mono-apache-server4 but it is not going to be installed or
mono-fastcgi-server4 but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

when I tried sudo apt-get upgrade libfontconfig1

I got

Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
libfontconfig1 is already the newest version.
The following packages have been kept back:
chromium-browser:i386 chromium-codecs-ffmpeg-extra:i386 clamav
clamav-freshclam linux-kernel-generic mintsystem virtualbox-guest-dkms
virtualbox-guest-utils virtualbox-guest-x11
The following packages will be upgraded:
accountsservice adobe-flash-properties-gtk adobe-flashplugin apt
apt-transport-https apt-utils avahi-autoipd avahi-daemon avahi-utils
base-files bind9-host bsdutils clamav-base dbus dbus-x11 dkms dnsutils eog
ghostscript ghostscript-x gir1.2-accountsservice-1.0 gir1.2-gdkpixbuf-2.0
gir1.2-gstreamer-1.0 grub-common grub-pc grub-pc-bin grub2-common
gstreamer0.10-gconf gstreamer0.10-plugins-bad
gstreamer0.10-plugins-good:i386 gstreamer0.10-plugins-good
gstreamer0.10-pulseaudio gstreamer1.0-plugins-bad
gstreamer1.0-plugins-bad-faad gstreamer1.0-plugins-bad-videoparsers
gstreamer1.0-plugins-good gstreamer1.0-pulseaudio gstreamer1.0-tools
icedtea-7-jre-jamvm imagemagick imagemagick-common init-system-helpers
initramfs-tools initramfs-tools-bin isc-dhcp-client isc-dhcp-common
klibc-utils kpartx kpartx-boot krb5-locales libaccountsservice0 libapparmor1
libapt-inst1.5 libapt-pkg4.12 libavcodec54 libavformat54 libavutil52
libbind9-90 libblkid1 libcurl3:i386 libcurl3-gnutls libdbd-mysql-perl
libdbus-1-3 libdbus-1-3:i386 libdns100 libegl1-mesa libegl1-mesa-drivers
libgbm1 libgc1c2 libgd3 libgd3:i386 libgdk-pixbuf2.0-0
libgdk-pixbuf2.0-0:i386 libgdk-pixbuf2.0-common libgl1-mesa-dri:i386
libgl1-mesa-dri libgl1-mesa-glx libgl1-mesa-glx:i386 libglapi-mesa:i386
libglapi-mesa libgles2-mesa libgme0 libgnutls-openssl27 libgnutls26
libgnutls26:i386 libgs9 libgs9-common libgssapi-krb5-2 libgssapi-krb5-2:i386
libgstreamer-plugins-bad0.10-0 libgstreamer-plugins-bad1.0-0
libgstreamer-plugins-good1.0-0 libgstreamer1.0-0 libgstreamer1.0-0:i386
libgweather-3-6 libgweather-common libhogweed2 libisc95 libisccc90
libisccfg90 libk5crypto3 libk5crypto3:i386 libklibc libkrb5-3 libkrb5-3:i386
libkrb5support0 libkrb5support0:i386 liblwres90 libmagickcore5
libmagickwand5 libmount1 libmysqlclient18 libnettle4 libnl-3-200
libnl-genl-3-200 libnl-route-3-200 libnss3 libnss3:i386 libnss3-1d
libnss3-nssdb libopenvg1-mesa libpcsclite1 libplymouth2 libpython2.7
libpython2.7-minimal libpython2.7-stdlib libpython3.4 libpython3.4-minimal
libpython3.4-stdlib libservlet3.0-java libsmbclient libspectre1
libssl1.0.0:i386 libssl1.0.0 libswscale2 libtomcat7-java libupnp6 libuuid1
libuuid1:i386 libwayland-egl1-mesa libwbclient0 libxatracker2 libxpm4
libxpm4:i386 linux-firmware linux-libc-dev mint-artwork-common mint-mirrors
mount mysql-client mysql-client-5.5 mysql-client-core-5.5 mysql-common
mysql-server mysql-server-5.5 mysql-server-core-5.5 ntpdate openjdk-7-jdk
openjdk-7-jre openjdk-7-jre-headless openjdk-7-jre-lib openssh-client
openssl perlmagick plymouth plymouth-label plymouth-theme-ubuntu-text
python-crypto python-imaging python-imaging-compat python-pil python-samba
python2.7 python2.7-minimal python3-crypto python3-pil python3.4
python3.4-minimal samba samba-common samba-common-bin samba-dsdb-modules
samba-libs smbclient ssh-askpass-gnome sudo tar tzdata tzdata-java
ubuntu-drivers-common util-linux uuid-runtime vim vim-common vim-runtime
vim-tiny x11-common xorg xserver-xorg xserver-xorg-input-all
xserver-xorg-video-all xserver-xorg-video-intel
xserver-xorg-video-openchrome
203 upgraded, 0 newly installed, 0 to remove and 9 not upgraded.
1 not fully installed or removed.
Need to get 0 B/191 MB of archives.
After this operation, 56.2 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Extracting templates from packages: 100%
Preconfiguring packages ...
Setting up fontconfig (2.11.0-0ubuntu4.2) ...
Regenerating fonts cache... failed.
See /var/log/fontconfig.log for more information.
dpkg: error processing package fontconfig (--configure):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
fontconfig
E: Sub-process /usr/bin/dpkg returned an error code (1)

and for wget http://launchpadlibrarian.net/177041...u4.1_amd64.deb and
sudo apt-get install libexpat1-dev

--2017-02-18 00:05:39-- http://launchpadlibrarian.net/177041...u4.1_amd64.deb
Resolving launchpadlibrarian.net (launchpadlibrarian.net)... 91.189.89.229, 91.189.89.228
Connecting to launchpadlibrarian.net (launchpadlibrarian.net)|91.189.89.229|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 664086 (649K) [application/x-debian-package]
Saving to: ‘libfontconfig1-dev_2.11.0-0ubuntu4.1_amd64.deb’

100%[================================================>] 6,64,086 240KB/s in 2.7s

2017-02-18 00:05:43 (240 KB/s) - ‘libfontconfig1-dev_2.11.0-0ubuntu4.1_amd64.deb’ saved [664086/664086]

and

Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
libc-dev-bin libc6-dev
Suggested packages:
glibc-doc
The following NEW packages will be installed:
libc-dev-bin libc6-dev libexpat1-dev
0 upgraded, 3 newly installed, 0 to remove and 212 not upgraded.
1 not fully installed or removed.
Need to get 2,094 kB of archives.
After this operation, 13.8 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libc-dev-bin amd64 2.19-0ubuntu6.9 [69.0 kB]
Get:2 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libc6-dev amd64 2.19-0ubuntu6.9 [1,910 kB]
Get:3 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libexpat1-dev amd64 2.1.0-4ubuntu1.3 [115 kB]
Fetched 2,094 kB in 2s (870 kB/s)
Setting up fontconfig (2.11.0-0ubuntu4.2) ...
Regenerating fonts cache... failed.
See /var/log/fontconfig.log for more information.
dpkg: error processing package fontconfig (--configure):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
fontconfig
E: Sub-process /usr/bin/dpkg returned an error code (1)
 
Old 02-17-2017, 12:49 PM   #14
Jayanthan
LQ Newbie
 
Registered: Feb 2017
Posts: 11

Original Poster
Rep: Reputation: Disabled
Thanks for the help hydrurga. Just wanted to know if problem has been identified exactly and I don't have any idea on inner working of linux though I have been using Linux for a few years now.
 
Old 02-17-2017, 01:01 PM   #15
hydrurga
LQ Guru
 
Registered: Nov 2008
Location: Pictland
Distribution: Linux Mint 20 MATE
Posts: 8,048
Blog Entries: 5

Rep: Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903
Well you're scooting on well ahead of me and my suggestions, so I'll bow out. Hopefully someone else will step up to the plate.

It's clear that you need to sort that font problem out before dpkg will work, so you should concentrate on that.

Trying to install new packages like libc-dev-bin libc6-dev and libexpat1-dev is only, in my opinion, going to muddy the waters further.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ubuntu software centre no install button for some softwares !!! geekygeek Linux - Newbie 2 02-19-2012 08:08 AM
Unable to install softwares from Ubuntu Software Centre in Lucid Lynx ayazfarooque Ubuntu 4 05-28-2010 07:12 AM
how to install softwares from other os like windows and also run portable softwares rudramurthy Linux - Newbie 6 10-16-2008 06:33 AM
unable to update or use software updater nitin403 Mandriva 1 05-22-2005 04:06 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux Mint

All times are GMT -5. The time now is 01:30 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration