-   Linux Mint (
-   -   tried to install Broadcom BCM4311 wireless; DESTROYED ethernet instead!! (

Don_Nadie 04-02-2013 02:03 PM

tried to install Broadcom BCM4311 wireless; DESTROYED ethernet instead!!
Linuxmint 14 Cinnamon up to date
Dell Inspiron 6400 laptop
Dell Wireless 1490/Broadcom BCM4311 wifi card

I tried out the Trisquel LiveCD via a USB flash drive and was surprised to see that it successfully brought up my wifi. This is FSF-approved free software, so I thought my Linuxmint should be able to run my wifi card as well.

I used the Linuxmint package manager to install
  • broadcom-sta-common
  • b43-fwcutter
and did a

sudo apt-get install firmware-b43-installer
in a terminal window.

I didn't see my wifi card in Network Connections, so I rebooted.

My ethernet was gone! ifconfig only shows loopback; nothing else. There's no MAC address in my wired Network Connections.

I thought installing the broadcom packages caused my ethernet problem, so I uninstalled them and rebooted again. I still have no ethernet in Linuxmint.

I'm using Window$ to post this from the same machine. Nothing wrong with my ethernet in Window$ and Window$ has always worked with my wifi card. 04-29-2013 02:27 PM

See whether your interface is present in
$ ifconfig -a

If so run
$ ifup <interface>

To wake it up:)

Don_Nadie 05-01-2013 01:08 PM

I had no interest in carrying on without an internet connection so I reinstalled Linuxmint weeks before responded to my post. Of course with a new installation I got my ethernet back but don't have wifi because I don't want to blow away my ethernet again by trying to get my wireless working.

The only advice I have found is don't buy a computer with a Broadcom wireless card if you want to run Linux or buy a wifi USB adapter that's known to work with Linux.

mswope 08-01-2013 11:40 AM

I run into a similar problem every time I reload my Inspiron 1545. It has the same Broadcom wireless card - but it does end up working! Don't give up... And, when you do get it working, remember to document it (in Google Keep or Evernote or something)... I ALWAYS forget to do this and have to search for the solution. I think I've done this 4-5 times now :-/


911InsideJob 08-11-2013 09:06 AM

I finally got my Broadcom wireless working with Broadcom's proprietary linux driver downloaded from their site. In Mint KDE 15 the proprietary installer is in System Setting/Hardware/DriverManager. Luckily my new laptop doesnt require any proriety drivers. I hated the one with Broadcom WiFi... dislike isn't a strong enough word.

All times are GMT -5. The time now is 12:08 AM.