-   Linux Mint (
-   -   Sound works in 12, not 13 (

viking55 08-07-2012 10:45 AM

Sound works in 12, not 13
my name is mick i am new to linux . iam using lm12 at present every thing works fine , want to upgrade to lm 13 . when i install lm 13 no sound can anybody please help

RealiX 08-09-2012 02:50 PM

Please, type


lspci | grep audio


lspci | grep Audio
and paste the output.

shane25119 08-11-2012 11:16 AM

I have a recurring problem with 13 where my audio goofs up periodically. If you pop into sound on the control center you can usually fix it by looking at the output tab.

But still, do the above suggestion too.

viking55 08-25-2012 07:38 AM

Sound card details.

00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller

I have tried to get sound working with many live distrobutions but non of the Debian distributions work with sound.

Every thing else is fine just the sound.

PaulFC5 08-28-2012 12:51 AM

I found that to get sound working in Mint12 &13 on Skype (and other audio apps) I had to remove Pulse Audio - and get "back" to Alsa - the main/"basic" linux sound server.
I think that PulseA is just an overlay over Alsa - and lots of other posts suggest getting rid of it.

Can't remember the exact sudo commands to do this - but googling wil find the post that gives them.
I think it just starts out "sudo remove pulseaudio" - and that may be enough.

In Skype with pulseaudio - it seems to be the "default" and only sound in and out setting :( - there was no way to specify other sound devices - but, when pulseaudio was gotten rid of, the "expected" great big list of the various sound hardware devices to choose from came up!
And sound generally is now fine :).

Paul W

rayfward 09-01-2012 12:20 PM

I know viking55. He lives locally to me and I did the conversion from Windows to Linux. His PC is a Sony VAIO J Series or something along those lines, an all in one type PC. I don't have the model but sound only works on Mint 12 and not 13 Non of the other recent distributions of Debian have sound either and only some of the other Fedora/Slackware have sound some times crackly. Drivers are the same as Mint 12 on 13. The odd thing is the mic input seems to be working. I used the same ISO to upgrade My machine, My partners machine and Viking55's partners machine. Only Viking55's machine has a problem. If it is the pulse audio sound system I get back to you with an update. In the mean time any other suggestions would be much appreciated.

rayfward 09-22-2012 04:40 PM

Well it's been a while. I tried various solutions including the removal of pulse but still cannot get sound to work except on Mint 12.
It's all centred around Ubuntu's current release. I'm hoping that Mint 14 due out in November will be an improvement.

PaulFC5 09-23-2012 06:38 PM

Yes - it does generally seem to be a bit tricky to get audio working OK in linuxes - even after having gotten rid of PulseAudio there seems to be some kind of exclusivity/"shutting other apps out" bizzo going on in my Mint13Mate.
ie: I've been dabbling my toes into Ardour as a recording app (and I'm only getting to use about 1% of it! - it's an enormous learning curve - and an obviously very good and useful app) but when it's running Audacity can't get to "see" the soundcard - ie Audacity's list of input and output devices doesn't include the analogue inputs/outputs of my beautiful Asus Xonar soundcard - Ardour seems to have gotten itself exclusive use of them. But when Ardour gets shut down these inputs/outputs show up in Audacity as one would hope/expect.
I am still using Audacity as well as Ardour because I haven't yet :o figured out how to "normalise" the two stereo channels independently in Ardour - whereas Audacity has a very good/configurable "normalise" function. Even though this involves a few quite slow-ish "Export File" commands - quite tedious in the case of a full Handel opera :D.

It usually seems to come down to interpreting what the sound devices are called in Jack and/or Alsa and selecting them - and seeing that they've got enough "volume"/aren'tmuted - eg my soundcard shows up as "AV200".

A quite useful little app that I've used occasionally that gives a picture/GUI of what's going on audiowise is called Patchage. And the "Gnome ALSA Mixer" can sometimes also be quite helpful/useful.

AAMOI a poster on another thread that I replied to - after delightedly thanking me for the idea of ditching pulseaudio - which solved his problem as it did mine :) - said that he used: "sudo apt-get autoremove pulseaudio" to get rid of it.

All times are GMT -5. The time now is 05:20 AM.