-   Linux Mint (
-   -   Sound Woes. Tried Most things, any suggestions? (

MCMXCIII 05-31-2009 06:22 AM

Sound Woes. Tried Most things, any suggestions?

First I may as well introduce myself. I'm Jack, been using Mint (Felicia 6) for a good few months now, both on my main laptop and Netbook. For some reason I can't get any sound and never have been able to on this laptop (Acer Aspire 6920). I originally had windows vista pre-installed, till I did a Linux install one night whilst very tired and accidentally wrote over it (everything's backed up so it didn't matter), and even when I dual-booted Vista and Mint, I still got no sound. I never have with any distro (I've tried a good 30 by now, from Mandravia to Dreamlinux) and every time I've got nothing... I've re-installed alsa-utils and run the command "alsamixer -c0" turning everything up full and the like and finally figured it must be my sound-card drivers. So I downloaded the brand of audio driver that was originally installed, but for linux, and extracted them. I have NO idea how to go about running them and from what I've read it looks quite a lengthly and complicated process. I was wondering if anyone is able to shed any light. I also have queries about setting XP to run properly in Virtualbox (non-free) but that's for another time and a different thread. Right now I'd like some sound xD

Thanks in advance,


Simon Bridge 05-31-2009 07:01 AM

Have you tried...

supermal 06-01-2009 10:36 AM

I had a similar annoying problem with my HP DV7 Pavilion laptop.

I tried all I could find on the forums, including the thread mentioned above. In that thread there is a bit by Tinyvole ( or something like that) using that as a guide I eventually went deep into HP's website and actually discovered a couple of lines of code that worked perfectly and instantly. I know you have a different manufacture of laptop, but I would strongly recommend digging deep on the ACER site, you never know!!

noxious 06-08-2009 06:20 PM

What kernel are you using? My HP DV6 will only give me sound and wireless with a 2.6.27-7 kernel

supermal 06-09-2009 02:57 PM

assuming its me your asking, hp dv7 is running 2.6.28,11.
the way I got sound working was while I was using linux mint 6. It refused to do the sound thing constantly until I found a bit on hp's site. As a consequence I added these 2 lines to my alsa-base.conf file
options snd-hda-intel model=hp-m4
options snd-hda-intel enable_msi=1, it worked and works with linux mint7 also. Hope this helps.

noxious 06-10-2009 10:38 AM

Well, I just don't get it... I added those two lines and I still get no sound. The computer is a new HP DV6. When I play a sound file, everything says sound is playing - except there's no sound from the speakers. Output VU meters are showing the sound playing, everything is un-muted and full volume. One thing though - Menu-->Sound & Video-->Pulseaudio volume control shows the little speaker symbol having a little red X next to it. The text is bold, so it's trying to put out sound - it's just not getting to the speakers, it looks like.

When I click the little speaker symbol to mute, the red X stays, the text goes gray. Click again to unmute, the text is bold, but the red X remains.


noxious 06-10-2009 09:00 PM

I think that did it supermal! I added those lines into the /etc/modprobe.d/alsa.conf file and after a couple of reboots it started to work!

I activated all the other repositories and moved up to the 2.6.28-13 kernel, so maybe that helped as well.

But, the Menu-->Sound&Video-->Pulseaudio volume Control still has the speaker symbol "x"'d out - but the sound works.


supermal 06-12-2009 08:43 AM

If it works in all apps, you've got it made, party on and ignore crossed out icons, they're boring.

All times are GMT -5. The time now is 02:28 PM.