LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux Mint
User Name
Password
Linux Mint This forum is for the discussion of Linux Mint.

Notices


Reply
  Search this Thread
Old 05-15-2015, 04:17 AM   #1
Mintonite
LQ Newbie
 
Registered: May 2015
Posts: 17

Rep: Reputation: Disabled
Sound from external DAC not detected; can't unmute devices in pavucontrol


Recently I installed Linux Mint 17.1 KDE on a brand new computer. So far, only this problem. Using Audacity, I'm trying to capture audio streams from an external DAC-tuner connected by optical cable to a Xonar D2/PM sound card's S/PDIF input. But there's no sound input detected by Audacity or by headphones plugged into the Xonar's headphone output jack. However, music files played on the computer can be captured by Audacity and are heard through the headphones.

In PulseAudio Volume Control it's not possible to unmute the Xonar card, the onboard audio, or the graphics card clicking on the red X beside the speaker icon associated with each of these devices doesn't remove the X. In KDE Mixer the sound devices can be unmuted/muted, and opening alsamixer in the terminal shows that nothing seems to be muted.

I want to record radio streams from the external DAC-tuner as I had been doing using Audacity and the same Xonar sound card in my previous old computer running Debian XFCE, with only ALSA and no PulseAudio. Then, whenever the sound system was playing and the computer was also on, the sound was always audible through the headphones connected to the Xonar. I've checked and rechecked the optical cable and headphone connections several times and they seem fine. Would greatly appreciate any helpful advice. I would think that sound must be audible from the headphones if it's being processed by the Xonar and before it has any possibility of being captured by Audacity.

Some relevant information:

cat /proc/asound/cards

Code:
0 [D2             ]: AV200 - Xonar D2
                      Asus Virtuoso 200 at 0xd000, irq 16
 1 [HDMI           ]: HDA-Intel - HDA Intel HDMI
                      HDA Intel HDMI at 0xf7930000 irq 49
 2 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xf7080000 irq 17
 3 [SAA7134        ]: SAA7134 - SAA7134
                      saa7133[0] at 0xf7800000 irq 17
inxi -Fxz

Code:
System:    Host: desktop Kernel: 3.13.0-37-generic x86_64 (64 bit, gcc: 4.8.2) 
           Desktop: KDE 4.14.2 (Qt 4.8.6) Distro: Linux Mint 17.1 Rebecca
Machine:   System: Gigabyte product: Z97-D3H
           Mobo: Gigabyte model: Z97-D3H-CF version: x.x Bios: American Megatrends version: F7 date: 06/17/2014
CPU:       Quad core Intel Core i7-4790 CPU (-HT-MCP-) cache: 8192 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 28800.2 
           Clock Speeds: 1: 800.00 MHz 2: 800.00 MHz 3: 800.00 MHz 4: 800.00 MHz 5: 800.00 MHz 6: 800.00 MHz 7: 3601.00 MHz 8: 800.00 MHz
Graphics:  Card-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller bus-ID: 00:02.0 
           Card-2: NVIDIA GF119 [GeForce GT 610] bus-ID: 01:00.0 
           X.Org: 1.15.1 drivers: nvidia,intel (unloaded: fbdev,vesa,nouveau) Resolution: 1280x1024@60.0hz 
           GLX Renderer: GeForce GT 610/PCIe/SSE2 GLX Version: 4.4.0 NVIDIA 331.113 Direct Rendering: Yes
Audio:     Card-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller driver: snd_hda_intel bus-ID: 00:03.0
           Card-2: C-Media CMI8788 [Oxygen HD Audio] driver: snd_virtuoso port: d000 bus-ID: 04:01.0
           Card-3: NVIDIA GF119 HDMI Audio Controller driver: snd_hda_intel bus-ID: 01:00.1
           Sound: Advanced Linux Sound Architecture ver: k3.13.0-37-generic
Network:   Card: Intel Ethernet Connection I217-V driver: e1000e ver: 2.3.2-k port: f080 bus-ID: 00:19.0
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 1000.2GB (0.7% used) 1: id: /dev/sda model: ST1000DX001 size: 1000.2GB 
Partition: ID: / size: 28G used: 6.6G (26%) fs: ext4 ID: /home size: 875G used: 408M (1%) fs: ext4 
           ID: swap-1 size: 16.00GB used: 0.00GB (0%) fs: swap 
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C gpu: 0.0:36C 
           Fan Speeds (in rpm): cpu: N/A 
Info:      Processes: 221 Uptime: 1 min Memory: 895.0/15909.2MB Runlevel: 2 Gcc sys: 4.8.2 Client: Shell inxi: 1.8.4
 
Old 05-16-2015, 10:26 PM   #2
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
TRy creating .asoundrc file & make it default.
I posted my .asoundrc here
http://www.linuxquestions.org/questi...ta-4175541104/
 
Old 05-17-2015, 01:36 AM   #3
Mintonite
LQ Newbie
 
Registered: May 2015
Posts: 17

Original Poster
Rep: Reputation: Disabled
Thanks EDDY1, an .asoundrc file is worth trying. Your example is different from my setup so when I get a chance I'll investigate how to configure that file. In the meantime, here's more relevant information:

Code:
~ > aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: D2 [Xonar D2], device 0: Multichannel [Multichannel]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: D2 [Xonar D2], device 1: Digital [Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

~ > arecord -l
**** List of CAPTURE Hardware Devices ****
card 2: D2 [Xonar D2], device 0: Multichannel [Multichannel]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: D2 [Xonar D2], device 1: Digital [Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 3: SAA7134 [SAA7134], device 0: SAA7134 PCM [SAA7134 PCM]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
 
Old 05-18-2015, 12:40 AM   #4
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
You are trying to add 1 card so you're making it default, you should be able to use the 1 that you were using when you disconnect.
 
Old 05-18-2015, 08:40 AM   #5
Mintonite
LQ Newbie
 
Registered: May 2015
Posts: 17

Original Poster
Rep: Reputation: Disabled
This .asoundrc configuration enables sound from the headphones but Audacity still doesn't record external radio streams.
Code:
pcm.!D2 {
     type hw
     card 0
     device 1
}
 
pcm.!default {
     type plug
     slave {
           pcm "D2"
     }
}
 
Old 05-21-2015, 11:54 PM   #6
Mintonite
LQ Newbie
 
Registered: May 2015
Posts: 17

Original Poster
Rep: Reputation: Disabled
Following a suggestion from an Audacity Forum Staff Member, I removed .asoundrc. The headphones continued outputting audio but Audacity continued not recording it. As no one has come up with a fix to the problem of Audacity not recording from an external DAC-tuner, I tried ocenaudio. Without any set-up, 2 mouse clicks and it started recording the external audio. Ocenaudio has all the capabilities I require, so goodbye Audacity.
 
Old 05-22-2015, 12:39 AM   #7
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Glad to know you got it working.
Canyou mark the thread as solved so as to help others who experience the same problem
 
Old 05-22-2015, 10:01 PM   #8
Mintonite
LQ Newbie
 
Registered: May 2015
Posts: 17

Original Poster
Rep: Reputation: Disabled
Audacity still doesn't record my external audio, so the main problem hasn't been solved; I've simply sidestepped it by switching to one of several alternative applications. Also, pavucontrol unmute still doesn't work, though that doesn't seem to be a problem since it doesn't appear to effect sound. If forum moderators define this as being solved, they should mark it as such.
 
Old 05-22-2015, 11:49 PM   #9
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
If Oceanaudio sees it then there must be a .confi file for it, maybe you can compare the 2 files & edit.
 
Old 05-23-2015, 07:55 AM   #10
Mintonite
LQ Newbie
 
Registered: May 2015
Posts: 17

Original Poster
Rep: Reputation: Disabled
The only file I could find for ocenaudio with a name resembling that is ocenaudio.cfg which defines keyboard shortcuts and isn't what you're referring to.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Can't open pavucontrol in xfce - sound not configured Higgsboson Linux - Newbie 6 01-17-2015 11:04 AM
Have To Keep Pavucontrol Open In Order For Sound To Work Sumguy Linux - Newbie 5 03-29-2014 03:23 PM
duplicating all sound in ALSA to an external DAC hedpe Linux - Hardware 2 10-09-2007 03:58 AM
CD sound silent, cannot unmute noid Linux - Newbie 8 07-24-2005 05:57 AM
How to Unmute sound using OSS?? shazam75 Mandriva 3 10-15-2004 03:59 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux Mint

All times are GMT -5. The time now is 10:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration