LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux Mint
User Name
Password
Linux Mint This forum is for the discussion of Linux Mint.

Notices

Reply
 
LinkBack Search this Thread
Old 01-26-2014, 10:27 PM   #1
Shadowmeph
Member
 
Registered: May 2008
Location: West Coast Canada
Posts: 253

Rep: Reputation: 28
no sound ati video card HDMI


I cannot seem to get the sound to work off of my HDMI cable
 
Old 01-26-2014, 11:06 PM   #2
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Slackware
Posts: 14,865
Blog Entries: 2

Rep: Reputation: 3798Reputation: 3798Reputation: 3798Reputation: 3798Reputation: 3798Reputation: 3798Reputation: 3798Reputation: 3798Reputation: 3798Reputation: 3798Reputation: 3798
Which driver do you use? If it is the free radeon driver, which kernel version is installed on your system?
 
Old 01-26-2014, 11:45 PM   #3
aus9
Guru
 
Registered: Oct 2003
Posts: 5,055

Rep: Reputation: Disabled
Hi

I take a different approach

what distro are you using pls?

2) are you using pulseaudio?
leaping ahead, go to pavucontrol and config tab and change the pulldown
to select your hdmi device

3) if answer is no and using alsa
leaping ahead set up a .asoundrc file in your home folder/yourname
(note the leading do)

with contents using a formula of

pcm.!default {
type hw
card <number>
device <number>
}

change card to card 0 or card 1 etc
change device to device 1 or 3 or something based on this command

Code:
cat /proc/asound/pcm
---post your output if you are unsure pls

its likely your analog is hw0:0
its likely your hdmi is card1 devices vary
you may need to try more than one device number

---log out and log back in after changing file

eg

pcm.!default {
type hw
card 1
device 7
}
 
Old 01-27-2014, 12:00 AM   #4
Shadowmeph
Member
 
Registered: May 2008
Location: West Coast Canada
Posts: 253

Original Poster
Rep: Reputation: 28
ok so I installed the fgrlx drivers rebooted now it is all qworking fine
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Is it possible to play Blu Ray through a video card HDMI output to HDMI TV? SharpyWarpy Linux - Hardware 5 10-28-2012 01:01 AM
[ProLiant MicroServer, ATI R6xx HDMI, Digital Out, HDMI] No HDMI sound at all vnatius Linux - Hardware 15 08-16-2012 01:09 PM
(RHEL 5.6) No sound after installing NVIDIA Video Card with hdmi neoserdes Linux - Hardware 7 05-08-2012 03:10 AM
HD ATI HDMI interfering with default sound card setting CA0106 RichardT Ubuntu 2 01-06-2010 07:21 AM
No sound over HDMI Video Card with GeForce 9500GT jpacooper Linux - Hardware 2 02-03-2009 05:07 PM


All times are GMT -5. The time now is 02:11 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration