-   Linux Mint (
-   -   Mysterious "usb" directories in /media dir - USB devices Don't Mount Like Before (

gentisle 03-23-2011 11:13 AM

Mysterious "usb" directories in /media dir - USB devices Don't Mount Like Before
Here's the output of my /media dir:
/media $ ls -l
total 56
drwx------ 1 owner owner 20480 2011-03-22 11:52 Megadisk
drwxr-xr-x 2 root root 4096 2011-03-20 14:45 isodisk
lrwxrwxrwx 1 root root 4 2011-03-19 13:57 usb -> usb0
drwxr-xr-x 2 root root 4096 2011-03-19 13:57 usb0
drwxr-xr-x 2 root root 4096 2011-03-19 13:57 usb1
drwxr-xr-x 2 root root 4096 2011-03-19 13:57 usb2
drwxr-xr-x 2 root root 4096 2011-03-19 13:57 usb3
drwxr-xr-x 2 root root 4096 2011-03-19 13:57 usb4
drwxr-xr-x 2 root root 4096 2011-03-19 13:57 usb5
drwxr-xr-x 2 root root 4096 2011-03-19 13:57 usb6
drwxr-xr-x 2 root root 4096 2011-03-19 13:57 usb7

1. The Megadisk is the Windows label for that external USB drive. It's correct. So far it has always automatically mounted correctly.
2. The isodisk dir, I created, it is OK.
3. None of the other directories were created by me. Nor did I link the usb to usb0.
4. I have no idea what to even search for since "Mysterious USB directories" didn't yield anything worthwhile.
5. Prior to whatever went wrong, my 4GB flash drive would automatically mount correctly as it's Windows label name (vol name).
Now it always mounts under the linked usb->usb0 dir. Any ideas what I might search on, or what this is called? Thanks.

LinuxMint 10 Gnome amd64, on a Medion laptop, x2 amd, 4GB ram, shared 128MB nVidia 6150 graphics. All updates have been applied through Synaptic. I also had a shutdown issue that was solved by issuing apt-get update; apt-get upgrade at the prompt. I don't recall when that started. Virtualbox 4.0.4.r70112 64-bit is installed. That seems to be working about as well as any other Virtualbox I've installed. Does Virtualbox do something to create those dirs?

$ df -h
Filesystem Size Used Avail Use% Mounted on
/dev/sda5 2.9G 474M 2.3G 18% /
none 1.9G 304K 1.9G 1% /dev
none 1.9G 308K 1.9G 1% /dev/shm
none 1.9G 348K 1.9G 1% /var/run
none 1.9G 0 1.9G 0% /var/lock
/dev/sda6 4.7G 138M 4.4G 4% /tmp
/dev/sda10 164G 42G 114G 27% /home
/dev/sda7 6.6G 942M 5.4G 15% /var
/dev/sda8 15G 4.0G 9.4G 30% /usr
/dev/sdc1 932G 505G 427G 55% /media/Megadisk

exvor 03-23-2011 08:06 PM

This really sounds like there is some issue with the automounting fuction of mint (assumeing thats what distro this is). Something you can check is how many parttions are listed on the device. You can do this by doing a fdisk -l /dev/sdx where as x is the correct device.

gentisle 03-23-2011 10:15 PM

To exvor: Thanks for replying. fdisk -l just shows 1 partition correctly as it always has been.

Something else I've found: I cannot right click the icon and unmount/eject/safely remove. Regardless of which of those options are listed when I right click, it won't allow me to do it. It complains "/media/usb0 is not in fstab and you are not root." Well there's not much in fstab, but here it is:
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc nodev,noexec,nosuid 0 0
/dev/sda5 / ext4 errors=remount-ro 0 1
# /home was on /dev/sda10 during installation
UUID=e...6 /home ext4 defaults 0 2
/dev/sda6 /tmp ext4 defaults 0 2
# /usr was on /dev/sda8 during installation
UUID=0...0 /usr ext4 defaults 0 2
/dev/sda7 /var ext4 defaults 0 2
# swap was on /dev/sda9 during installation
UUID=0...1 none swap sw 0 0

I partitioned the disk at install time with (if I remember correctly)
/ 3gb
/tmp 3gb
/var 5gb
/usr 15gb
swap 4gb
/home remainder

In the folder browsing window (not Konqueor or Dolphin), it lists the correct volume name for my USB flash drive, yet doesn't show that it's mounted. But it does show that the usb0 is mounted. Furthermore, when I right click on the volume name, select "Eject" or "Safely remove", it says, "Unable to eject volname, One or more partitions are busy on /dev/sdb" Strangely enough the "Mount" option is listed on the context menu even though it is mounted at /media/usb0.
Disk Utility in the LM10 menu (is this gnome-disk-utility?) also reports only 1 partition. In the Disk Util, I was able to select "Unmount" and that worked, but selecting "Safely remove" gave the same "unable umount..busy" error. Also, I can umount -f and it will unmount.

First of all, is is OK to create directories in /media? I seem to remember reading on the Solaris forum that you shouldn't do that. Secondly, does this sound like my installation of linux has been into the catnip and is totally stoned? (sorry, I couldn't resist).

gentisle 04-10-2011 11:37 AM

Well, I finally found what the mysterious usb0-9 directories are. Before I had the problem, I was fishing for USB info about my system, and used Synaptics to install other USB utilities. One of which was usbmount. This program created those directories. So I have removed it, and we'll see what happens. I hope everything USB-wise works correctly. I'll try to remember and post again here, but if everything works correctly, I'll probably forget I had the problem.

All times are GMT -5. The time now is 03:38 AM.