LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux Mint
User Name
Password
Linux Mint This forum is for the discussion of Linux Mint.

Notices

Reply
 
Search this Thread
Old 05-30-2012, 12:56 PM   #1
taylorkh
Senior Member
 
Registered: Jul 2006
Location: North Carolina
Distribution: CentOS 6 on my desktop, Ubuntu 12.04 LTS on my server, Ubuntu 12.04 on my netbook and the wife's PC
Posts: 1,186

Rep: Reputation: 95
Mint 13 - wireless configuration problem


The machine in question is a Dell Latitude 2100 netbook. It came from the factory with Ubuntu 9.04 and has been running Ubuntu 10.04 for the past couple of years. Today I decided to install Mint 13 Mate which I have been playing with in VMWare and seems to have a nice simple interface.

The install on the netbook went fine. I installed the "restricted" driver for the Broadcomm wireless card just as I had done previously with Ubuntu. I configured the wireless connection under networking by supplying the SSID (which is not broadcast) and password from my wireless router. I set the connection to WPA2 personal as the router is WPA2. The issues I have noticed are:

1 - the wireless connection does not connect
2 - WPA2 personal reverts to WPA personal

I changed the router to WPA and still no connection.

I backed up the Mint install and am installing Ubuntu 12.04 to see if that will connect. In the interim, can anyone give me any suggestions regarding getting the Mint wireless connection to work? I don't have the Broadcomm model number at the moment. I will post it once the current install completes. However, Mint seemed to find the correct driver in the repository.

TIA,

Ken

Update - I installed Ubuntu 12.04 (from which Mint 13 is derived I think?) and allowed it to install the restricted driver. I configured the network connection to my wireless router and it works fine.

The driver package is bcmwl-kernel-source_5.100.82.38+bdcom-0ubuntu6.1_i386.deb in both cases. The files are identical on Ubuntu and Mint.

I uninstalled and reinstalled the driver but Mint still does not connect. It still reverts WPA2 to WPA.

I noticed that in Ubuntu I had to add a new connection for wireless. Mint seems to know that there is a wireless device and I am only allow to change its properties. I changed Mint to "roaming" mode but that simply cleared the properties and I could not edit anything.

Last edited by taylorkh; 05-30-2012 at 04:47 PM. Reason: update
 
Old 05-30-2012, 07:22 PM   #2
PhoenixAndThor
Member
 
Registered: Sep 2009
Location: Geogia, USA
Distribution: Ubuntu, Debian, Live CDs
Posts: 213

Rep: Reputation: 38
Good to see you found a solution. Broadcom chips are somewhat notorious for causing problems for us *nix users. The last netbook I had (HP Mini) wouldn't work at all. I had to buy a USB Wi-Fi adapter to connect to anything.
 
Old 05-30-2012, 07:57 PM   #3
taylorkh
Senior Member
 
Registered: Jul 2006
Location: North Carolina
Distribution: CentOS 6 on my desktop, Ubuntu 12.04 LTS on my server, Ubuntu 12.04 on my netbook and the wife's PC
Posts: 1,186

Original Poster
Rep: Reputation: 95
I have NOT found a solution. Ubuntu 12.04 works but the objective was to install Mint 13. The wireless adapter does NOT work with Mint 13.

Ken
 
Old 05-31-2012, 02:04 PM   #4
taylorkh
Senior Member
 
Registered: Jul 2006
Location: North Carolina
Distribution: CentOS 6 on my desktop, Ubuntu 12.04 LTS on my server, Ubuntu 12.04 on my netbook and the wife's PC
Posts: 1,186

Original Poster
Rep: Reputation: 95
Well. I have now found a solution. As storage is cheap I will copy my post from over on the Mint forum:

To summarize the issue... I installed Mint 13 Mate and allowed it to download and install the Broadcomm driver. I tried to create the wireless connection using mate-network-admin (Networking app from the Menu; Administration). This created entries in /etc/network/interfaces which caused issues on boot. I confirmed that the identical Broadcomm driver worked OK on Mint 13 Cinnamon and Ubuntu 12.04 (from which Mint 13 is derived). Here step by step is how I managed to get wireless networking working on Mint 13 Mate:

1 - Connected the netbook to my router by an Ethernet cable
2 - Performed a clean install of Mint 13 Mate
3 - Had a look at the network situation as follows
Right click on the network icon in the notification area (which is nm-applet) and observed the following
Enable Networking was checked
Enable Wireless was checked
Connection Information showed me the details of the wired connection
Edit Connections took me to a dialog which showed
Wired tab - Wired connection 1 present
Wireless tab - no entries
4 - From the Menu; Preferences; Additional Drivers I downloaded and installed the Broadcomm driver. For reference the file is bcmwl-kernel-source_5.100.82.38+bdcom-0ubuntu6.1_i386.deb
5 - Rebooted to complete the installation of the driver.
6 - Right clicked on the network icon in the notification area and selected Edit connections.
7 - Selected the Wireless tab and pressed the + Add button. I supplied the following data
Connection name" Wireless connection 1" (the default which was shown)
SSID: Luca$Electric (the name of my router - British car fans will understand this ) This is not broadcast by the router
Mode: Infrastructure
I moved to the Wireless Security tab and set:
Security: WPA and WPA2 Personal
Password: (the appropriate password for my router/network)
Finally I saved the connection and closed the dialogs. I still did not have a connection. So...
8 - I again Right Clicked on the network icon in the notification area and this time I clicked Connect to hidden wireless network.

Behold - I was connected!!!

9 - Disconnected the Ethernet cable and rebooted. I was again and automagically connected to my wireless network.

n.b. The option to "Connect to hidden wireless network" is no longer present when I right click on the network icon in the notification area.

If you are having trouble connecting a Broadcomm or any other wireless card in Mint 13 Mate consider trying these steps. Do NOT use the Menu; Administration; Network program. It doesn't work and thinking back it does not work in Ubuntu either going back at least to 9.04.

Hope this helps someone.

Ken
 
1 members found this post helpful.
Old 04-27-2013, 08:51 PM   #5
ledledled
LQ Newbie
 
Registered: Apr 2013
Location: Texas
Distribution: Mint 14.1 Cinnamon
Posts: 3

Rep: Reputation: Disabled
Arrow Easy solution here

As of the date of this post, this solution worked on a Dell Inspiron 1501, with Mint 14.1 Nadia Cinnamon 64 installed and updated:
1. Make sure the package is removed:
sudo apt-get remove bcmwl-kernel-source
2. Install the firmware:
sudo apt-get install firmware-b43-installer
3. Reboot.

Source: http://blog.tech4him.com/broadcom-wi...-04-and-11-10/
Not sure you are having the same problem as I was, but a google search led me to this forum page. If you have the 43xx broadcom series card in your laptop, then this is worth reading:
http://ubuntuforums.org/showthread.p...5#post11283995

Last edited by ledledled; 04-27-2013 at 10:16 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wireless problem when switching from Mint to Windows kvv Linux - Newbie 1 02-06-2011 05:16 AM
Fedora wireless configuration problem.. yesglass Fedora 2 08-13-2009 01:27 AM
Problem with wireless configuration vade Ubuntu 5 06-24-2009 07:51 AM
Problem in configuring a wireless connection with Mint jimspence Linux - Newbie 3 12-26-2008 12:23 PM
Problem wireless card configuration pierre44 Linux - Wireless Networking 1 08-08-2005 03:08 PM


All times are GMT -5. The time now is 10:48 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration