-   Linux Mint (
-   -   Mint 13/Cinnamon Java mouse pointer problem (

Chris.Bristol 06-19-2012 02:53 PM

Mint 13/Cinnamon Java mouse pointer problem
I'm using Mint 13 with Cinammon.

When I run a Java program the mouse pointer is in the wrong place - it is in a different place to where its action happens, and it doesn't work on pull-down menus, possibly for the same reason.

If I select Gnome3 at login it works perfectly.

fluxell 09-05-2012 02:49 PM

Possibly same issue
I'm currently running Cinnamon on Mint 13 and have a very similar problem. When using SQLDeveloper, which runs on java, the menu items don't stay open with a click, I have to hold down the mouse button. In addition, at least one of the tear-off menus I can't click on at all. In part, this seems to be due the multiple monitor setup. If I place the SQLDeveloper window on my main scree instead of my secondary screen, the menus behave slightly better and the tear off menu works as expected. I'm currently not using the NVidia drivers because of another issue that I've had since upgrading to Mint 13 (from Ubuntu 10.04).

fluxell 12-28-2012 10:50 AM

Temp Solution
While this isn't a permanent solution, I did run across the following which basically says to push the window to the top left before maximizing the window. Seems to work, but still would like to see a better solution.

Chris.Bristol 01-11-2013 09:56 AM

This is fixed in Mint 14.

Chris.Bristol 05-14-2013 08:39 AM


This is fixed in Mint 14
I was wrong, it's not! I had done quite a lot of different things to my system, one of which might have fixed it. I have just re-installed Mint 14 to sort out some other problems and the mouse pointer problem is back. I have tried the jre1.7.0_21 and java-7-openjdk-i386 versions of Java and that doesn't make any difference. I don't think it can be caused by the Java program I am using (DIYLC) as a Mint site user has the same problem with SPSS.

Fluxell's workaround in post 3 works.

There are bug reports here and here

So the problem is well understood, but it hasn't been fixed.

Chris.Bristol 07-17-2013 05:04 PM

This seems to have been fixed.

All times are GMT -5. The time now is 02:10 PM.