-   Linux Mint (
-   -   Menus (

Chris.Bristol 01-11-2013 06:55 AM

This computer has had various distributions on, Xubuntu, Ubuntu 12.10 with a program to get rid of Unity and replace it with something similar to the Gnome2 panels and menu (gnome-session-fallback/gnome-panel?) and now Cinnamon. Probably because of its history Cinnamon doesn't work properly so I've had to use gnome-session-fallback/gnome-panel to get the classic Gnome2 panels. (I've put a separate post about this.) I think the various distributions have been using the Applications/Places menu lists, but slightly differently.

The Alacarte menu editor does not reflect what is actually on the menu. I think the menu program attempts to merge different menu lists into one. I reckon I'd be best to delete all or most of them and start again, how should I identify these files, and where should I look for them?

Update: I've just found this page Gnome which is well written and understandable even by a novice like me - perhaps a useful site. It suggests that they are to be found here /usr/share/applications and here ~/.local/share/applications.

I went through ~/.local/share/applications deleting duplicates and anything that didn't have a proper icon as I found that those applications weren't installed. There were about 400 files which I have reduced to 4. The menu was always very slow, now I know why, it's much faster now!

Chris.Bristol 01-11-2013 07:49 AM

I think I know what part of the problem is, I had been using Alacarte because Cinnamon Menu Editor doesn't work from the menu*. If I use Cinnamon Menu Editor it nearly matches what it is showing on the menu, so I conclude that Alacarte works on different files and shouldn't be used. The System sub-menu contains Administration and Preferences which don't show in Cinnamon Menu Editor.

Update: I've now found /etc/xdg/menus/ which seems to create those sub-menus and organise certain types of application into them so that's alright.

*Cinnamon Menu Editor
When attempting to run it from the menu the error message is

Failed to execute child process "/usr/share/applications/cinnamon-menu-editor.desktop" (Permission denied)
The permissions look the same as "Cinnamon Settings" which works. If I run it by clicking on the .desktop file or by typing cinnamon-menu-editor in a terminal it works - very strange.
This is the only remaining problem.

Update: I haven't worked why this was happening, but I have reinstalled Cinnamon with a different username so it is no longer a problem.

All times are GMT -5. The time now is 08:41 AM.