-   Linux Mint (
-   -   maya mate edition dialup and wireless problems (

jludeman 07-09-2012 07:07 PM

maya mate edition dialup and wireless problems
I'm an old hand at getting dial up and wireless working on ubuntu from feisty to lucid. Due to hardware issues I felt the need to upgrade from lucid. Precise did not work for me for many reasons. I discovered Mint Maya Mate edition and installed it to Virtualbox in Lucid. After a couple of days of tweaking I was really happy with Mint.

In virtualbox mint was sharing a working internet connection with the Lucid box. When I installed mint to the actual hard drive and tried to connect to my dialup isp everything was okay except that the dns did not work. The dial up connected and assigned a remote address and dns server. Everything I tried from ping to Firefox reported no route to the internet.

I tried sudo route delete default without good results. I edited /etc/ppp/options and added the line replacedefaultroute also with no results.

Because I'm a glutton for punishment I installed mint on the test partition on my laptop and drove the 18 miles one way to a public high speed connection.

I did the following at the command line:

sudo iwlist wlan0 scan
sudo iwconfig wlan0 essid "public123"
sudo dhclient wlan0

Everything worked up to dhclient. I got "dhcpdiscover on wlan0 to port 67" (various intervals). This went on until I got tired of looking at it without ever connecting.

On every version of ubuntu up until now the command line sequence above worked great.

I don't know what has changed in network management to cause all of the above. Extensive google search is not helping me. Part of the problem is that anyone who has any choice does not use dialup any more.

I have no choice other than satellite. If you read the terms and conditions for satellite service you get a certain amount of high speed bandwith per month. Then you are throttled down to nothing. So you must pay a minimum $50 a month for about a weeks service. I can't justify that on my tight budget.

Also even if I had satellite given my experience with public wifi access I'm not sure mint would even connect.

Thanks for any help in advance.

jludeman 07-12-2012 11:56 AM

The problem is worse than I expected. I can't get the laptop to connect to the desktop using a simple crossover cable and sshfs. Networking does not get any simpler.

One thing I discovered while trying to get ppp and wireless working is that some program or service is changing things to suit some preset pattern.

I had various network configuration files up to look at and the editor kept reporting that the file had changed on disk.

Anyway I'm marking this solved simply because I'm giving up on mint, ubuntu and debian altogether.

jludeman 07-23-2012 05:12 PM

I will just go stand in that corner and shut up now.
I will just go stand in that corner and shut up soon.

After using Linux exclusively for over half a decade I recently had to install windows xp for a money making project. I will be far more tolerant of the shortcomings of Linux in the future.

I also investigated alternatives to debian, ubuntu and mint in the Linux arena. Outside of Arch or LSF/BLFS I just don't see any that will work for me. I really don't have time for either one right now.

Mint 13 was by far the easiest Linux upgrade I've done so far. Aside from all the dialup and network problems I liked it very much. So after I pouted for a while I installed Mint on my main drive.

Of course dialup still did not work. I finally typed sudo mate-network-manager in a terminal. On the DNS tab I added the google public name servers and My browser finally connected to the internet.

I had already edited /etc/ppp/resolv.conf to have the google servers but that had not worked. Anyway my network problems seem to be at least partially resolved.

Namebench is in the repositories. Try it and see if you can find a faster name server.

I will just go stand in that corner and shut up now.

jk07 07-24-2012 02:16 PM

I'm in the same boat as you so I can empathize. I have dial-up working on Ubuntu 12.04. Why don't you like Ubuntu 12.04? If you don't like Unity, there is always X/K/L/ubuntu.

All times are GMT -5. The time now is 05:50 PM.