-   Linux Mint (
-   -   Installed Evolution, requires me to enter password for keyring (

trafikpolisen 12-26-2012 12:29 PM

Installed Evolution, requires me to enter password for keyring
I've installed Evolution on Linux Mint 13 Mate. When entering the mail password for the first time i was required to set a keyring password, which i now have to enter when checking for new emails. I'm guessing there's a default keyring connected to the login password, as i don't have to enter anything when connecting to the wlan or when using included Thunderbird. How do i make Evolution use the same keyring as the rest of the system? It is rather annoying to have to enter a password for checking mails.

xenopeek 12-26-2012 03:18 PM

From this issue it seems to have been solved in mate-keyring 1.3.1: You can check your mate-keyring version with:

dpkg -l mate-keyring
Linux Mint 13 has on a clean install mate-keyring 1.3.0. Updating may provide a newer version, or you could enable the backports repository in the Software Sources program to upgrade to the newer MATE release (as also available on Linux Mint 14). Now, a fair disclaimer: I haven't tested Evolution on MATE so I'm not sure if this will actually fix it.

Another solution I found for an older Linux Mint version, which may still work fine:

You'd normally set the keyring password identical to your login password, or leave it blank (I can't recall which one works, or if they both do) and then you shouldn't be queried on the password each boot. Assuming the above fix. On GNOME you used to be able to edit your keyring password with Seahorse: If you go for the second approach, using the solution for an older Linux Mint version, for sure you can install and use Seahorse then.

All this stems from Evolution being a GNOME 3 project, and though MATE is based on GNOME 2 it renamed all the libraries and programs so as to not conflict with GNOME 3 (so you can install GNOME 3 and MATE side-by-side, which was not possible with GNOME 3 and 2). But, that causes these kind of problems :(

trafikpolisen 12-26-2012 04:49 PM

I've noticed that not only Evolution prompts me for a keyring password, it also happens when connecting to a pptp vpn with network manager. I have version 1.3.0. I have selected backports in the Mint Update, version 1.4.0 now shows up. I will update only mate-keyring and see if that fixes the problem and then deselect backports in software sources again.

xenopeek 12-27-2012 01:47 AM

You probably also need to upgrade libmatekeyring. Hope it works!

trafikpolisen 12-27-2012 06:50 AM

Updating mate-keyring didn't work. I even tried to install Nadia in VMware, same problem there.
Finally stumbled upon a solution at
Just created two symlinks:
cd /usr/bin
sudo ln -s mate-keyring gnome-keyring
sudo ln -s mate-keyring-daemon gnome-keyring-daemon

No need to backup anything as the gnome variants doesn't exist.
Delete the files in ~/.config/mate/keyrings (not necessary if you create the symlinks on a fresh install before using for example Evolution).
Now Evolution will ask for the e-mail password once, but without any dialog to create a new keyring.

All times are GMT -5. The time now is 03:37 PM.