LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux Mint
User Name
Password
Linux Mint This forum is for the discussion of Linux Mint.

Notices

Reply
 
LinkBack Search this Thread
Old 12-10-2013, 08:29 AM   #1
starkadder
Member
 
Registered: Jun 2007
Posts: 75

Rep: Reputation: 15
how2 disable 30 sec shutdown delay Mint 15 xfce 64bit


Hello,
I'm astonished that I can't find an existing answer to this minor irritation. Perhaps I'm using the wrong search terms or the answer is so simple that I'm too stupid to see it.
When I request shutdown there is a 30 second delay which I don't want. I've searched the googlenet and found suggested fixes for Gnome and Cinnamon but nothing for Xfce. There must be an init, config or similar file containing the delay instructions somewhere but I can't find it.
Would some kind soul point an old man in the right direction please?
 
Old 12-10-2013, 01:40 PM   #2
ondoho
Member
 
Registered: Dec 2013
Distribution: arch linux / crunchbang
Posts: 185

Rep: Reputation: 26
i don't think they deliberately put a delay in there.
much more likely there's actually something happening under the hood while you wait, most probably waiting for an app to shut down, then killing it after 30s.
for troubleshooting, there surely is a logfile somewhere for shutdown. probably one of the /var/log/X.*.log files, but i don't know which.
one solution you can try: to shutdown, open a terminal and type
Code:
sudo shutdown -h now
and hope you can see some relevant information in the terminal window.
 
Old 12-10-2013, 02:13 PM   #3
starkadder
Member
 
Registered: Jun 2007
Posts: 75

Original Poster
Rep: Reputation: 15
Thanks ondoho.
"They" most definitely do deliberately put the delay in there. There is a dialogue window showing a countdown and asking if I'm sure I wanted to shut down, with the option of cancelling or hitting a shutdown now button.
There should be a way of adjusting the delay but I've yet to find it.
It may be that I've been using Puppy for a long time now and I'm acustomed to everything I ask for happening immediately. I'm only just getting used to typing sudo in front of every command and my password after.
The line you suggested does shutdown immediately without any information in the terminal window. Displaying the shutdown --help information gives some clues, I'll have to work on them.
I can live with the inbuilt delay, I always hit the immediate shutdown button, I just have an aversion to a machine apparently assuming that I don't know what I want and my having to confirm the command.
Thanks for your input.
 
Old 12-10-2013, 02:44 PM   #4
ondoho
Member
 
Registered: Dec 2013
Distribution: arch linux / crunchbang
Posts: 185

Rep: Reputation: 26
ok, i'm sorry i'd never have imagined something like that.

since the shutdown dialog is most probably some small utility (like mintmenu), it has a log of installed files and maybe even a rudimentary man page or at least a "-h" option. and if that doesn't yield results, there's always other small shutdown utilities you can use instead.

i just queried forums.linuxmint.com/search.php for "shutdown delay" and there's a few relevant results.
 
Old 12-11-2013, 04:52 AM   #5
starkadder
Member
 
Registered: Jun 2007
Posts: 75

Original Poster
Rep: Reputation: 15
At the moment I can't access the Mint forum because of some kind of login glitch (I'm told that my user name and password are incorrect and when I try to reset the password I'm told that my email address(es) are not known. When I then try to register a new username I'm told that my emails are already in use. Hey ho.) I'll do the same as you did if I ever manage to get a reply from Mint admin, until then I'll probably go back to Puppy. I'm sure that there is a simple fix, I can't imagine the Mint developers putting in such an irritating feature without providing for a way out but I'm obviously being thick in not being able to find it.
Thanks for your interest.
 
Old 12-11-2013, 12:30 PM   #6
ondoho
Member
 
Registered: Dec 2013
Distribution: arch linux / crunchbang
Posts: 185

Rep: Reputation: 26
you don't need to login to search mint forums.
i would have given you a direct link to the search results, but they're using a system that doesn't allow that :-(
 
Old 12-17-2013, 01:15 AM   #7
starkadder
Member
 
Registered: Jun 2007
Posts: 75

Original Poster
Rep: Reputation: 15
Thank you ondoho,
Please accept my apologies if I appear to be a Help Vampire, I'd hate to think that I'd leave anyone exhausted, bitter and dispirited!
The "problem" I originally posted turns out to be with the newer xfce rather than Mint. I tried the latest Open Suze and that also has the delay built in. Adjusting the delay in Suze may be simpler than in Mint but I've yet to find time to investigate.
I'll poke about with the Mint installation when I can, if I can't get round it, I'll live with it.
Thanks again.
 
Old 12-17-2013, 02:26 PM   #8
ondoho
Member
 
Registered: Dec 2013
Distribution: arch linux / crunchbang
Posts: 185

Rep: Reputation: 26
Quote:
Originally Posted by starkadder View Post
Please accept my apologies if I appear to be a Help Vampire, I'd hate to think that I'd leave anyone exhausted, bitter and dispirited!
??? that is my signature, it is under every post i make, so it isn't necessarily targeted at you. and if you read the article, you could find that you are indeed not.

ps:
re-reading your posts:
if you have to type "sudo" in front of every command, then you're doing something wrong.
please be aware that puppy is very different from normal linux in this respect - the whole root/user thing.
in normal linux you're supposed to act as a user, except where you modify the system (as opposed to userspace).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel Panic with 0 sec delay... jchambers Linux - Newbie 2 01-08-2008 09:55 PM
Cups printing delay of 30 sec. btwn documents tra4d Linux - General 2 12-12-2007 07:47 AM
How2 disable access to windows shares. holeg Linux - Newbie 2 07-13-2006 01:23 AM
20+ sec delay establishing a connection. matt_d Linux - Networking 3 05-28-2006 02:47 PM
RedHat AS 3, system time delay 3 sec everyday jingle_mj Linux - General 5 11-01-2005 11:48 PM


All times are GMT -5. The time now is 07:17 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration