-   Linux Mint (
-   -   How to Disable Plymouth in Mint/Ubuntu (

dixiedancer 08-20-2010 05:59 AM

How to Disable Plymouth in Mint/Ubuntu
Plymouth can't be removed from Ubuntu or Mint without taking half the system with it. It's got tentacles all over the whole OS!

But surely it can be disabled with some file edit or command line. Does anyone know how?

Thanks in advance,

linus72 08-20-2010 06:07 AM

you can disable the splash by editing out the word "splash" on the grub2 menu boot line
just remove the word splash and it wont show
insert the word "text" and it will boot to command line, no gdm,etc

dixiedancer 08-20-2010 09:03 AM


Originally Posted by linus72 (Post 4072248)
you can disable the splash by editing out the word "splash" on the grub2 menu boot line
just remove the word splash and it wont show
insert the word "text" and it will boot to command line, no gdm,etc

Where might I find the grub 2 menu boot line?

Like please tell me /usr/share or whatever. I don't know how to edit a line in Grub if I can't find it, lol.


syg00 08-20-2010 09:20 AM

It is almost always better to describe the problem you think you have than demand an answer you have already fixated on.

For grub2, have a look at this. If you just want to see the boot messages Plymouth insists on hiding try the <Esc> key.

linus72 08-20-2010 09:24 AM

oh, sorry

you can edit /boot/grub/grub.conf
here mine

menuentry 'Ubuntu, with Linux 2.6.32-24-generic' --class ubuntu --class gnu-linux --class gnu --class os {
        insmod ext2
        set root='(hd0,3)'
        search --no-floppy --fs-uuid --set 24ab71de-24cf-4f92-8360-0c7a577a02b3
        linux        /boot/vmlinuz-2.6.32-24-generic root=UUID=24ab71de-24cf-4f92-8360-0c7a577a02b3 ro  quiet text
        initrd        /boot/initrd.img-2.6.32-24-generic

as you can see in blue, I removed "splash" and inserted "text"
if you still wish to boot to GDM/login manager then just remove the word splash
you must edit it as root

to make it permanent edit /etc/default/grub


# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`

# Uncomment to disable graphical terminal (grub-pc only)

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux

# Uncomment to disable generation of recovery mode menu entries

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

then do "update-grub" in terminal as root

I hope that helps...
I suggest you also remove the "quiet" parameter too

CJ Chitwood 08-29-2010 10:37 PM

I see this isn't a too-ancient thread...

I have a similar problem, only I already have removed the "splash" comments to no avail: I *still* get a Mint splash.

My system worked fine at home, then when I took it to work, it quit. I had to reinstall when I brought it back home, and it worked fine again. I took it to work, it continued to work fine. I brought it home, it worked fine, back to work, worked fine. Brought it back home and now it's a totally new not-working state.

It acts like a hardware problem except that the liveCD works fine and the hard drive is not corrupt and I can fully read and write whatever I need. The hardware, therefore, I can only assume is fine. After all, if there were a problem, it should fail on both the installed system and the liveCD. I'd check logs, except for whatever reason Mint shows no logs after the point where the problem started -- it mounts the drive, so why can't it log to it? I'll post a new thread when I have time to do so (so as not to hijack this one), but right now, I just want to be able to troubleshoot the system without interference from a Windows-like splash virus.

I'd like to remove Plymouth, but as OP stated, it latches on to many, many necessary parts of the system (seemingly needlessly, all for the sake of dependencies). Maybe I can remove it without checking for dependencies, or maybe just remove the binary....

macaddict01 10-03-2010 01:25 AM

I'm somewhat new to Mint and Ubuntu but I find it fascinating they included Plymouth in the distros. For me it causes a huge headache during boot cycles. More times than not it seems to not do a clean handover to the GDM and I'm stuck with a black screen until I do a ctl-alt-delete. Removing the 'splash' variable from all my grub entries did seem to help. Also, I used Synaptic to uninstall the Plymouth themes except for the text them.

widget 10-14-2010 03:46 PM


sudo gedit /etc/default/grub
remover "splash" from the instruction string.


sudo update-grub
This will get rid of the graphic part of Plymouth. You will have to live with the rest of Plymouth (libplymouth2). This will help get rid of most of the problem but probably make the slow shut down more obvious. Shutdown will not be slower, could be faster but the error messages are all there, sometimes spread diagonally across the screen.

Plymouth is not real impressive.

All times are GMT -5. The time now is 07:18 AM.