Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Distributions > Linux Mint
User Name
Linux Mint This forum is for the discussion of Linux Mint.


  Search this Thread
Old 06-15-2009, 04:04 AM   #1
LQ Newbie
Registered: Jul 2006
Posts: 5

Rep: Reputation: 0
Cool Graphics card problem on Mint 7 (Linux newbie)


I have made the switch from the awful Windows to Linux Mint 7 and loving it. My problem is this: I have an ATI Radeon 2400HD video card running on the propriety driver recommended by the Mint hardware driver program. Everything installs fine and it can run all the nice desktop effects too. My problems starts when I reboot after the first initial reboot following installation of the driver, the screen resolution expands itself beyond the boundaries of the monitor, which is an Acer X223W 22inch. Thus meaning I cannot see the task bar at the bottom of the screen or anything that sits in the lower third of the screen layout. I can overcome this by selecting a safe vga mode at boot time but this is not an ideal situation.
Can anyone offer a solution to this problem please?
Many thanks.
Old 06-15-2009, 09:01 PM   #2
LQ Guru
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
I can't get into specifics of either Mint or your laptop model, as I have used neither, but these sorts of problems generally require a look at your xorg.conf file, which is the file that configures your screen display.
It's usually located in /etc/X11/ on the system. If you could copy/paste that into a post here, it may provide us some clues.. Also, what is the native resolution & vertical refresh rate of your monitor? For example, 1680x1050 @ 59.95 ? You can usually find this data in the manual for the monitor, or online.


Old 06-16-2009, 02:26 PM   #3
LQ Newbie
Registered: Jul 2006
Posts: 5

Original Poster
Rep: Reputation: 0
This is the contents of the xorg.conf file on my system:

Section "Monitor"
Identifier "Configured Monitor"

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24

Section "Module"
Load "dri"
Load "GLcore"
Load "glx"

Section "Device"
Identifier "Configured Video Device"
Driver "fglrx"

Section "ServerFlags"
Option "DontZap" "False"

Monitor specs are as follows:

* *Max Resolution* 1680 x 1050 / 60 Hz
* *Color Support* 24-bit (16.7 million colors)
* *Max Sync Rate (V x H)* 75 Hz x 80 KH

Just to add this is a desktop machine, not a laptop.

Many thanks,
Old 06-16-2009, 04:23 PM   #4
LQ Guru
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
Section "Screen"
    Identifier     "Screen1"
    Device         "VideocardB(lowerVGA)"
    Monitor        "KDS0"
    DefaultDepth    16
    Option         "NoLogo" "False"
    Option         "RenderAccel" "On"
    Option         "HWcursor" "On"
    Option         "DamageEvents" "True"
    Option         "TwinView" "0"
    Option         "metamodes" "DFP-0: 1680x1050 +0+0"
      SubSection   "Display"
      Depth         16
First, it would be good if you would add the 'metamodes' line as I have in the above 'Screen' section. In your case, with only one monitor, changing 'metamodes' to 'modes' will probably do.

Disregard the other stuff in there, I just copied & pasted

PS - Dunno what made me think that was a laptop but thanks for the clarification.

Note too, checking your xorg.0.log file can lead to clues as to what's wrong, but for now, try it with a MODES line as I indicated, and see if it changes anything.

For reference, always remember the driver docs that come with your driver, and the man page for the driver too, for exact syntax of stuff.

Good luck! I'll check later and see what's up with your situation.

Old 10-03-2009, 06:54 PM   #5
LQ Newbie
Registered: Oct 2009
Posts: 8

Rep: Reputation: 0
me too.....

i am as well a newbie to linux as a "bill hater". i have both ubuntu and mint and have the same problems on both shells... the resolution. i have tried to alter the screen comand on both but they are "read only" files and i cannot save any alteration... can anyone help with this issue?


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Newbie with Mint/ Linux needs to install Clam AV in Mint after 4 Wdws Trogan attack BAKEAPPLEFARM Linux Mint 6 03-24-2010 09:38 PM
Newbie simple installation problem with Mint everyonedoesit Linux - Newbie 2 06-02-2009 05:46 PM
Newbie with Mint/ Linux would like to iinstall WINE on Mint so found no help for this BAKEAPPLEFARM Linux Mint 4 05-08-2009 09:33 AM
Geforce 6600 graphics card will only allow me to install PCLinux os...not Mint or Ubu g4yjsbarrie Linux - Distributions 2 06-16-2008 02:25 PM
Problem loading graphics driver on Mint 4.0 Pandemic187 Linux - Hardware 2 12-06-2007 11:52 AM > Forums > Linux Forums > Linux - Distributions > Linux Mint

All times are GMT -5. The time now is 12:48 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration