Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Distributions > Linux Mint
User Name
Linux Mint This forum is for the discussion of Linux Mint.


  Search this Thread
Old 01-12-2014, 06:31 PM   #1
LQ Newbie
Registered: Jan 2014
Posts: 2

Rep: Reputation: Disabled
Question Encrypted LVM process loops "already mapped or mounted", Mint 16 Cinnamon x64

I've been trying to set up a LVM boot with an encrypted partition for Mint and an encrypted partition shared as /home and swap space between Mint and my other Linux system. On every startup, cryptsetup asks me to supply the passphrase to my Mint LVM (under its physical name) AFTER it maps same LVM to cryptroot. The result is, as you might expect, me always being asked to supply the passphrase to a drive that will not mount. I can be to, and input, the passphrase seven times before I get to press "S" or "M" for recovery options.

georgia UUID=... none luks, cipher=serpent-xts-essiv:sha256, retry=2,lvm=atlanta-root

shared UUID=... none luks cipher=serpent-xts-essiv:sha256,retry=2,lvm=data-home
CRYPTOPTS=TARGET=georgia source=/dev/disk/by-uuid/...,lvm=atlanta-root
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash rootfstype=ext4"
GRUB_CMDLINE_LINUX="cryptdevice=/dev/disk/by-uuid/... georgia"
The boot process complains and quits, or worse yet drops me to initramfs without a word, if any of these entries are absent. I've looked over and tried everything I can to get it to even this point, didn't want to come here without making at least a bit of effort. There's got to be something I'm missing. A little help here, please?
Old 01-22-2014, 07:30 AM   #2
LQ Newbie
Registered: Jan 2014
Posts: 2

Original Poster
Rep: Reputation: Disabled
Never mind, just had to go into /usr/share/initramfs-tools/scripts/local-top/cryptroot and change crypttarget from "cryptroot" to "", then update the initramfs. It works fine now.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux People need to build a new "old-lady Mint-OS".. "Mint Julep"... Cosmicb Linux - Newbie 21 08-29-2016 05:14 PM
LXer: Review: Linux Mint 16 "Petra" Cinnamon + MATE LXer Syndicated Linux News 0 12-19-2013 07:12 PM
When I try to use mint 15 cinnamon, I have "freezing" problems, but Mate is fine. katrada Linux - Newbie 10 10-23-2013 03:47 AM
LXer: Review: Linux Mint 15 "Olivia" Cinnamon + MATE LXer Syndicated Linux News 0 06-13-2013 01:46 AM
LXer: Review: Linux Mint 14.1 "Nadia" MATE + GNOME 3/Cinnamon LXer Syndicated Linux News 0 12-10-2012 05:30 PM

All times are GMT -5. The time now is 12:46 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration