-   Linux Mint (
-   -   Cannot view data on external storage (

CollieJim 12-02-2012 04:11 PM

Cannot view data on external storage
As usual, I do not find Mint Linux particularly reliable when first installed.

When I plug in an external storage device, I automatically get, for each partition on the device, an error message:

Could not display "/media/jim/..."
The location is not a folder.

How do I stop this nonsense? It is a folder, and it appears that permissions are not set properly.
How do I stop automounting? I do not always want all partitions mounted.


frankbell 12-03-2012 09:03 PM

I looked around the web and did not find anything on disabling automount on Mint, not that I looked very hard, since Google is available to all.

Some more information would likely be useful, such as what version of Mint, what is the output of fdisk -l from a terminal (may need to be run as root), and what are the permissions on the partitions? Does this happen with every external storage device you connect, or just with one?

CollieJim 12-05-2012 06:43 AM

The automount process creates a directory for the user under /media:

drwxr-x---+  3 root root 4096 Dec  5 20:34 jim
As jim I cannot even look in it.

If there is an entry if /etc/fstab it is used, but otherwise the device is put under /media and is not visible.
I guess the solution is to have an entry for every possible partition with noauto set. Rather messy.

frankbell 12-06-2012 08:26 PM

It looks as if root is the owner in the automount. Have you tried unmounting the partition as root, then remounting it as user? That might give you a hint as to what is going on.

CollieJim 12-07-2012 01:37 AM

I've change the owner to jim. I can access the device, but now automount has stopped working...
I'm quite happy to mount manually.

frankbell 12-07-2012 08:22 PM

Just for fun, I connected my Podplayer (Iriver 150) to my Mint 13 system. It automounted just fine and allowed me to manipulate the files on it, including copying and deleting a file. The directory structure looked just the same as on my other systems.

I am not sure the behavior you've experienced is necessarily typical of Mint. There may be something else going on. I have no idea what it may be, though.

CollieJim 12-07-2012 10:14 PM

Things change from one release to the next and are not always known or intended.
This is the first distro that creates a subdirectory under /media for the user. In the past, the new devices all got lumped together in /media unless /etc/fstab has a relevant entry.

frankbell 12-08-2012 06:33 PM

Which version of Mint?

CollieJim 12-08-2012 10:31 PM

Mint 14

frankbell 12-09-2012 07:39 PM

I haven't upgraded yet, so I haven't encountered any changes they may have made. It will probably be a couple of weeks before I do. If I run into anything funky, I'll remember this thread.

All times are GMT -5. The time now is 01:52 AM.