LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux Mint (https://www.linuxquestions.org/questions/linux-mint-84/)
-   -   Cannot log in to Mint 16 - cinnamon desktop gone (https://www.linuxquestions.org/questions/linux-mint-84/cannot-log-in-to-mint-16-cinnamon-desktop-gone-4175494776/)

Thane 02-13-2014 09:50 AM

Cannot log in to Mint 16 - cinnamon desktop gone
 
Sorry to the moderators for this new thread. While trying to fix a sound delay problem (for which I have another post going), I followed a solution elsewhere in these pages and removed pulseaudio (to supposedly drop into alsa thereafter). I've now got a more serious problem. Anyway removing pulse audio using s--- apt-get remove pulseaudio, the following programs were also removed: cinnamon-bluetooth, cinnamon-control-center, cinnamon-screensaver, libcanberra-pulse, mint-meta-cinnamon, pulseaudio, pulseaudio-module-bluetooth, pulseaudio-module-x11.

The upshot is now I cannot log in at the mint petra login screen. If I could get to the terminal screen, I could reinstall the missing programs and I think I could get everything working again. Cannot seem to get the terminal though. The error message when I try to log in is, "failed to find session "cinnamon".

fuorviato 02-13-2014 11:53 AM

First of all - Why you'd need to remove pulseaudio? It's a core component for Mint and Ubuntu-based distros.
Coming to the login screen. Have you tried hiting ctrl+alt+f1 on your keyboard to get to the main shell? If you're plugged to the ethernet, you should be able to reinstall cinnamon from there.
Also. You may be able to invoke another rescue session from your login screen drop-down menu. Check if there's any.
If all the above fails, rebooting your machine, going to GRUB menu to fire up a recovery session may also be a chance.

Thane 02-13-2014 01:12 PM

Many thanks fuorviato for the ctl+alt+f1. That was what I was missing. I've reinstalled the removed programs and I'm back to the cinnamon desktop now. Still left with my original problem though which is as follows. I installed skype, which has always worked fine in past mint editions using apt-get install skype. With my mint 16 64 bit installation however, none of the available sound options for skype will play properly. The only ones I have cause about a 10 second delay in sound -- unuseable. Looking around here I found a thread which said (for a previous version of mint) that removing pulseaudio would cause mint to drop back into alsa, which should fix the problem. The suggested code was apt-get remove pulseaudio. With the removal of cinnamon I thought I'd be restarting into the gnome shell by default and I'd be able to reinstall anything necessary. But I couldn't figure out how to get back to the command prompt. So thank you for that info. Still left with my original problem though. I'll mark this as solved and continue with my other thread (a few spots below this one in the thread list).


All times are GMT -5. The time now is 06:03 PM.