Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Distributions > Linux Mint
User Name
Linux Mint This forum is for the discussion of Linux Mint.


  Search this Thread
Old 07-19-2016, 10:31 PM   #1
Registered: Jan 2005
Posts: 221

Rep: Reputation: 33
Can I get my scrollbar back please?

Similar to this question but on Mint 18 and not exactly the same.

I can't find a way to get normal scroll bars on Mint 18. This problem started years ago when the GTK3 people decided to make scrollbars mobile-friendly, and unfortunately made them desktop-useless.

I'm talking about scrollbars dissapearing constantly, and the scrollbar arrows missing.

Is it possible to get rid of that behaviour? I can probably live without the arrows (though I'm having a very hard time missing them) but I cannot live with the idiotic you-don't-need-to-know-where-you-are-in-a-long-anything concept.

It's terrible in Xreader (where I can't see the scrollbar unless I mouse over it), in Thunar where I need to mouse over a pane to figure out whether there are more files/folders, and pretty much any other app that has a scrollbar.

I have a 24" 1920x1080 monitor, and I don't need to save 20 pixels (one percent of my screen width!!!) on a scrollbar. Really!

Anyway, sorry for the rant, the question (if anyone knows the answer) is how do I get a normal scrollbar back? Is it still possible?

I tried putting export GTK_OVERLAY_SCROLLING=0 in my .bashrc or .profile but unexplicably it works for some apps and not others. I can run


and the scrollbars start to work, but not if I start xreader via some graphical means.
Old 07-19-2016, 11:45 PM   #2
Registered: Feb 2004
Location: Austin Texas
Distribution: Mandrake 9.2
Posts: 702

Rep: Reputation: 231Reputation: 231Reputation: 231
You can turn off the scrollbar effect in System Settings > Effects

The arrows are a bit more complicated...
Edit the gtk-2.0/gtkrc file for the theme you are using.

ADD THIS LINE: GtkScrollbar::stepper-size = 18

GtkScrollbar::has-backward-stepper = 1
GtkScrollbar::has-forward-stepper = 1
GtkScrollbar::stepper-size = 18
GtkScrollbar::slider-width = 18
GtkScrollbar::trough-border = 1
GtkScrollbar::activate-slider = 1
GtkScrollbar::min-slider-length = 24

Change these lines to 1, not 0
GtkScrollbar::has-backward-stepper = 1
GtkScrollbar::has-forward-stepper = 1

That is for the gtk2 programs. For gtk3 programs, edit the gtk-3.0/gtk-widgets.css file, at about line 1656

.scrollbar {
background-clip: padding-box;
-GtkRange-trough-border: 2;
-GtkScrollbar-has-backward-stepper: 1;
-GtkScrollbar-has-forward-stepper: 1;
-GtkRange-slider-width: 10;
-GtkScrollbar-min-slider-length: 30;
-GtkRange-stepper-spacing: 0;
-GtkRange-trough-under-steppers: 1;

Last edited by TxLonghorn; 07-19-2016 at 11:59 PM.
Old 07-20-2016, 08:23 AM   #3
Registered: Jan 2005
Posts: 221

Original Poster
Rep: Reputation: 33
Thank you TxLonghorn! Cinnamon was already so nice, but now I feel even happier with it!

I already had "Fade effect on Cinnamon scrollboxes" off, but I guess that does something different. What fixed it for the scrollbar was "Overlay scroll bars".

And the arrows came back with the text file changes you mentioned. I don't know why they didn't work when I followed the instructions in the other thread.

Too bad the arrows look unstyled in gtk2, but whatever, I'm keeping them anyway!


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Scrollbar on TV soe Linux - Software 0 05-26-2006 03:25 AM
Custom scrollbar jilljack Programming 1 11-01-2005 09:34 AM
Scrollbar in Gtk+ 2.0 hpcpg Programming 0 03-29-2004 06:46 AM
No back/forward buttons or scrollbar in firefox Lul2x Linux - Software 7 03-28-2004 05:41 PM
No themed scrollbar in mozzila bolinux Linux - Software 8 10-17-2003 03:35 PM > Forums > Linux Forums > Linux - Distributions > Linux Mint

All times are GMT -5. The time now is 02:23 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration