LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux Mint (https://www.linuxquestions.org/questions/linux-mint-84/)
-   -   Boot to guest, no root, sudo dead, fresh drive - single install, tried everything - fight me lol - Cinnamon 3.6.6 - 4.10.0-38-generic (https://www.linuxquestions.org/questions/linux-mint-84/boot-to-guest-no-root-sudo-dead-fresh-drive-single-install-tried-everything-fight-me-lol-cinnamon-3-6-6-4-10-0-38-generic-4175649680/)

philwhite 03-06-2019 10:14 PM

Boot to guest, no root, sudo dead, fresh drive - single install, tried everything - fight me lol - Cinnamon 3.6.6 - 4.10.0-38-generic
 
Hey'all,
Old WinXP drive - uninstalled, installed Linux, worked fine, turned it off often, booted up to my pswd, logged-in w/ full privileges to my desktop, one day it changed - booted straight to different splash screen with guest login only. I had one hard drive in the machine.
I installed Linux on a new drive, re-did my desktop and settings and slaved my other HD.
Same thing just happened again. I hadn't turned off my computer for over a month.
These two episodes happened across two years of everything working fine.
Now I'm locked out, can't use my bookmarks or access any of my old settings.
"The permissions of "HDD" could not be determined." {ascertained would have been a better word}
The new drive reads: Reboot and Select proper Boot device... and press a key_
The old drive gives me a guest account login.
I'm working off of a USB stick now.
'sudo' commands return: unable to change to root gid... unable to initialize pdig plugin...
There is no legacy boot option in my BIOS.
I changed the battery.
I don't know what else to say except that any help would be greatly appreciated.
advTHANKSance

hazel 03-07-2019 06:21 AM

It would help a lot if you told us what Linux distribution you are using. You have a cinnamon desktop, so I'll make a guess at Mint. In which case, you don't have a root login, only sudo. But we need to know one way or the other.

Have you tried getting a text console? Press ctrl+alt+F1. This should give you a simple login prompt at which you can log in with any valid identity.

yancek 03-07-2019 06:51 AM

If you previously had windows xp on this machine, it would be useful to know exactly how old it is and could you post some info on the hardware. In addition to which Linux system you are using, which release is it? Logging in generallhy doesn't give one 'full privileges' and some Linux systems will not allow that in a GUI. Can you be more specific on what you mean here? Also, what is the "it" that changed? You were no longer able to log in? You were not able to get 'full privileges"?

Quote:

There is no legacy boot option in my BIOS
Are you saying this is an EFI machine? That would be surprising if you had xp on it previously as xp can't use UEFI. Does the machine your are referring to have any operating system on it now?

When you installed again to the new drive, did you install the bootloader to the MBR of that drive and set it to first boot priority in the BIOS?

It would really be useful to post info on the hardware and age of the computer to clarify if it is EFI or Legacy/CSM.

philwhite 03-07-2019 07:30 AM

Quote:

Originally Posted by hazel (Post 5971164)
It would help a lot if you told us what Linux distribution you are using. You have a cinnamon desktop, so I'll make a guess at Mint. In which case, you don't have a root login, only sudo. But we need to know one way or the other.

Have you tried getting a text console? Press ctrl+alt+F1. This should give you a simple login prompt at which you can log in with any valid identity.

Mint - Sylvia
It seems that my experience with Linux is very different.
I've been logging into the GUI for a couple of years now. Everytime my screensaver comes on I have to put in my password.
ctrl+alt+F1 sends me to a fullscreen black opaque terminal.

philwhite 03-07-2019 07:47 AM

Quote:

Originally Posted by yancek (Post 5971174)
If you previously had windows xp on this machine, it would be useful to know exactly how old it is and could you post some info on the hardware. In addition to which Linux system you are using, which release is it? Logging in generallhy doesn't give one 'full privileges' and some Linux systems will not allow that in a GUI. Can you be more specific on what you mean here? Also, what is the "it" that changed? You were no longer able to log in? You were not able to get 'full privileges"?

Are you saying this is an EFI machine? That would be surprising if you had xp on it previously as xp can't use UEFI. Does the machine your are referring to have any operating system on it now?

When you installed again to the new drive, did you install the bootloader to the MBR of that drive and set it to first boot priority in the BIOS?

It would really be useful to post info on the hardware and age of the computer to clarify if it is EFI or Legacy/CSM.

The entire way the computer booted changed. I'm not sure how to express it other than in my above comment.
I've been logging in like it was Windows.
The new drive is a Seagate Barracuda 1Tb and is two years old.
The other drive is a WD Caviar Green 1Tb
AMD FX 6300 Six core x3
16 Gib
NVIDIA GM107 GeForce GTX 750 Ti
Biostar TA970
It's a BIOS but there is no legacy option in the BOOT menu.
The boot priorities are set correctly, but I am getting two Ubuntu drives plus my two drives showing up when I F9 to select boot device.
All I have is Linux Mint on each drive, both have the same password, denied root with each but root is accessible when working off of the USB key.
"did you install the bootloader to the MBR of that drive"
Not sure what you mean here.
Noob here, btw, as if you couldn't tell.

onebuck 03-07-2019 08:22 AM

Moderator Response
 
Moved: This thread is more suitable in <Linux Mint> and has been moved accordingly to help your thread/question get the exposure it deserves.

hazel 03-07-2019 10:35 AM

Quote:

Originally Posted by philwhite (Post 5971205)
It's a BIOS but there is no legacy option in the BOOT menu.

That's not surprising. If it's a real BIOS, there is no need of that.
Quote:

The boot priorities are set correctly, but I am getting two Ubuntu drives plus my two drives showing up when I F9 to select boot device.
That doesn't surprise me either. Mint often gets misidentified as Ubuntu.
Quote:

"did you install the bootloader to the MBR of that drive"
Not sure what you mean here.
Noob here, btw, as if you couldn't tell.
The bootloader is the program that is first loaded by the BIOS or UEFI. For Mint (and most other modern Linux distros) this will be GRUB. The bootloader then loads the Linux kernel. But where the bootloader goes depends on your firmware:
* If you use a BIOS or a UEFI in legacy mode, GRUB (or a bit of it) goes into the master boot record or MBR, which is the first sector of the drive. The rest of GRUB goes into the first partition (BIOS boot partition) if you have a GPT disk or into the space following the MBR if you have a DOS disk.
* If you use a UEFI in native mode, GRUB goes into the EFI system partition.

Your installation dialogue will have asked you where to put GRUB. How did you answer? If you have a real BIOS, you should have elected to install it into the drive (sda) and not in the Linux partition on the drive (sda1 or similar).

philwhite 03-07-2019 10:43 AM

Quote:

Originally Posted by hazel (Post 5971263)
That's not surprising. If it's a real BIOS, there is no need of that.

That doesn't surprise me either. Mint often gets misidentified as Ubuntu.

The bootloader is the program that is first loaded by the BIOS or UEFI. For Mint (and most other modern Linux distros) this will be GRUB. The bootloader then loads the Linux kernel. But where the bootloader goes depends on your firmware:
* If you use a BIOS or a UEFI in legacy mode, GRUB (or a bit of it) goes into the master boot record or MBR, which is the first sector of the drive. The rest of GRUB goes into the first partition (BIOS boot partition) if you have a GPT disk or into the space following the MBR if you have a DOS disk.
* If you use a UEFI in native mode, GRUB goes into the EFI system partition.

Your installation dialogue will have asked you where to put GRUB. How did you answer? If you have a real BIOS, you should have elected to install it into the drive (sda) and not in the Linux partition on the drive (sda1 or similar).

I made four partitions while installing, It was installed into one of those partitions.

yancek 03-07-2019 11:47 AM

If you have a Legacy/MBR install (NOT UEFI) then you would have needed to install Grub to the MBR as explained above. Check the link below which has instructions for installing Mint. If you scroll down the page to the Installation Type screens, the second one shows at the bottom of the main window "Device for bootloader installation" and the default is /dev/sda which you should have left as default. Which of the options did you select? If you want control of the install, use the manual method which is referred to as Something Else in Mint. Since you don't indicate that you have any other OS or more than one drive, the simplest method would have been Erase Disk and install Mint overwriting everything on the drive.

https://www.linuxbuzz.com/linux-mint...e-screenshots/

philwhite 03-07-2019 03:58 PM

Quote:

Originally Posted by yancek (Post 5971300)
If you have a Legacy/MBR install (NOT UEFI) then you would have needed to install Grub to the MBR as explained above. Check the link below which has instructions for installing Mint. If you scroll down the page to the Installation Type screens, the second one shows at the bottom of the main window "Device for bootloader installation" and the default is /dev/sda which you should have left as default. Which of the options did you select? If you want control of the install, use the manual method which is referred to as Something Else in Mint. Since you don't indicate that you have any other OS or more than one drive, the simplest method would have been Erase Disk and install Mint overwriting everything on the drive.

https://www.linuxbuzz.com/linux-mint...e-screenshots/

Despite my answer above, I doubt I would have changed the default place to install it, and the new drive was a fresh install, nothing having ever been on it before. I used Gpart before the install to create four (4) partitions. I did have two drives, though, the second time.
I'm not overwriting anything for the moment. I simply can't believe that I'm the only person on the internet to use Linux this way, or to have had these problems.
Could it be a glitch in the software? I got it directly from the Mint site. Maybe Mint is crap.
For now I've lost all the internet bookmarks, Google Earth places... over the last year. It's as if I have to replace my machine every year. Haven't been able to find ANYTHING remotely close to my situation online.

yancek 03-07-2019 06:29 PM

Quote:

denied root with each but root is accessible when working off of the USB key.
Not sure what that comment means. How are you 'denied root'? Do you mean you can use sudo on the Live Mint but were unable to do so with the installed Mint?

It seems from your posts that you have apparently been using Mint for some time and this is a new problem, is that correct?

If you installed Mint to a second drive, did you install Grub to the MBR of the first drive? Was the first, non-working drive attached at the time? If you installed Grub to the MBR of the new drive did you then change the boot priority in the BIOS so that drive was first?

Quote:

Everytime my screensaver comes on I have to put in my password.
If you ever get this thing booted, that is a simple change in the Setting or Control Center. You should have a Lock screen option where you can disable this.

If there were dramatic changes and you did not make any changes to your hardware/software, it might be a hardware problem. Not enough info to say.

Quote:

The boot priorities are set correctly, but I am getting two Ubuntu drives plus my two drives showing up when I F9 to select boot device.
If you see an option for ubuntu but are using Mint, that is standard on an EFI install as Mint uses ubuntu for the directory containing EFI files.

Quote:

Maybe Mint is crap.
I don't use it myself but there are tens of millions of people worldwide who do use it and doubtless would disagree with that assessment.

Since the problem is your inability to boot it and you can still use the Mint usb, I think the best next step to try to resolve this problem is to go to the site below while booted into Mint on the usb. Download and run the boot repair software. Read the instructions thoroughly first. Do NOT try to make any repairs but select the option to Create BootInfo Summary. THere are 2 options, the best one to use is the 2nd option explained on the page using the ppa as it is more updated.

https://help.ubuntu.com/community/Boot-Repair

philwhite 03-07-2019 07:32 PM

Quote:

Originally Posted by yancek (Post 5971463)
Not sure what that comment means. How are you 'denied root'? Do you mean you can use sudo on the Live Mint but were unable to do so with the installed Mint?

It seems from your posts that you have apparently been using Mint for some time and this is a new problem, is that correct?

If you installed Mint to a second drive, did you install Grub to the MBR of the first drive? Was the first, non-working drive attached at the time? If you installed Grub to the MBR of the new drive did you then change the boot priority in the BIOS so that drive was first?

If you ever get this thing booted, that is a simple change in the Setting or Control Center. You should have a Lock screen option where you can disable this.

If there were dramatic changes and you did not make any changes to your hardware/software, it might be a hardware problem. Not enough info to say.

If you see an option for ubuntu but are using Mint, that is standard on an EFI install as Mint uses ubuntu for the directory containing EFI files.

I don't use it myself but there are tens of millions of people worldwide who do use it and doubtless would disagree with that assessment.

Since the problem is your inability to boot it and you can still use the Mint usb, I think the best next step to try to resolve this problem is to go to the site below while booted into Mint on the usb. Download and run the boot repair software. Read the instructions thoroughly first. Do NOT try to make any repairs but select the option to Create BootInfo Summary. THere are 2 options, the best one to use is the 2nd option explained on the page using the ppa as it is more updated.

https://help.ubuntu.com/community/Boot-Repair

-Can't use sudo commands. It's a symptom of the larger problem.
-This is the second time it has happened in two years. I'm comfortable with computers but don't know the Linux vocabulary very well.
-I installed Mint on a drive after having deleted WinXP. Everything was fine for a year, then one day, on boot, I lost access to my desktop, my user login disappeared, I was stuck in a guest account with no privileges.
-I couldn't solve the problem, so I installed Mint on a fresh drive and just slaved the old one.
-I can't say for sure where the GRUB was installed, either time, but I probably did the same thing both times.
-I always check the boot sequence, it was fine for a year until it wasn't.
-I set my lockscreen like that. All my settings are gone, is what I meant.
-My hardware seems fine.
-"If you see an option for ubuntu but are using Mint, that is standard on an EFI install as Mint uses ubuntu for the directory containing EFI files." So should I select the drive or the Ubuntu line?
-I said maybe. But this is not acceptable behaviour from any software.
-Thanks for the link, I'll have a look at that.

philwhite 03-07-2019 07:37 PM

The last time it happened, I had the Linux drive and the Linux slave, now the main drive can't be booted but it is seen. It's booting to the slave no matter what the boot priorities are because it isn't reading the main drive as a boot device any more. Since I had this problem with my old drive, I am stuck in a guest account unless I use the USB.

hazel 03-08-2019 05:58 AM

Just a little rant ;)
This is a classic case of what happens when a distro tries too hard to be "user-friendly". It makes all kinds of assumptions and when, for some reason, they are not met, chaos results. For example, the OP can't log in with his normal user account (which has full sudo access) because the display manager presents him with only a guest account. So he can't fix his system because that requires the use of sudo.:banghead:

It isn't the job of a login program to assume any particular login identity. It should allow users to log in with whatever identity they currently want to use. All the login program needs to do is check that the user name is a known one and that a matching password is given.

Mint is certainly not "crap" but it tries too hard to be Windows. Result: all goes well for months and the user doesn't learn anything about how his system works because he doesn't have to. Then something goes wrong and it can't be fixed from the inside because of the stupid assumptions the system has made.

philwhite 03-08-2019 06:35 AM

Quote:

Originally Posted by hazel (Post 5971605)
Just a little rant ;)
This is a classic case of what happens when a distro tries too hard to be "user-friendly". It makes all kinds of assumptions and when, for some reason, they are not met, chaos results. For example, the OP can't log in with his normal user account (which has full sudo access) because the display manager presents him with only a guest account. So he can't fix his system because that requires the use of sudo.:banghead:

It isn't the job of a login program to assume any particular login identity. It should allow users to log in with whatever identity they currently want to use. All the login program needs to do is check that the user name is a known one and that a matching password is given.

Mint is certainly not "crap" but it tries too hard to be Windows. Result: all goes well for months and the user doesn't learn anything about how his system works because he doesn't have to. Then something goes wrong and it can't be fixed from the inside because of the stupid assumptions the system has made.

I don't know how much clearer I can be, but I do not have access to sudo. I listed the errors recieved when I try sudo commands in the terminal.


All times are GMT -5. The time now is 07:43 AM.