LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices


Reply
  Search this Thread
Old 08-16-2010, 12:22 PM   #1
XG5A
LQ Newbie
 
Registered: Aug 2010
Posts: 12

Rep: Reputation: 0
Xubuntu Installation no GUI


Hi,
I'm attempting to install Xubuntu on an IBM Thinkpad i series 1300 (1171) for a friend. The computer has a 700Mhz Pentium 3 processor, and 192mb of ram. I'm not sure what kind of video card. The normal Cd hangs up before installation begins, so I used the alternate CD. I executed the normal installation, but what I ended up with is command-line. I tried

sudo aptitude install xubuntu-desktop

but it was already installed.

I think the error has to do with the monitor. I checked for xorg.conf, which is non-existent. I used the xorg.conf file from here, more specifically here, but when I run startx, I get errors saying that the screen resolution is too big and there isn't enough memory.


I could be totally wrong here, too. Are there any other diagnostics I could do. I'm newer to linux, but seem to be catching on. I may be chasing my tail. I've looked all over the internet, but I think I need help.
Thanks for the help!

Last edited by XG5A; 08-16-2010 at 12:24 PM.
 
Old 08-16-2010, 12:29 PM   #2
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 399Reputation: 399Reputation: 399Reputation: 399
We would need to see the /var/log/Xorg.0.log file that is generated by 'startx' to see what the problem is. You can either attach the file to a post here, or use a service like sprunge. You can install curl and then run:

Code:
cat /var/log/Xorg.0.log | curl -F 'sprunge=<-' http://sprunge.us
Then give us the URL that you get back.

Adam
 
Old 08-16-2010, 01:20 PM   #3
XG5A
LQ Newbie
 
Registered: Aug 2010
Posts: 12

Original Poster
Rep: Reputation: 0
i should mention that startx gives the same errors without the xorg.conf file (it disappears every time I reboot), so this is with no xorg.conf file.

http://sprunge.us/BIWP
 
Old 08-16-2010, 01:37 PM   #4
gasdim
Member
 
Registered: Jun 2010
Location: Volos GREECE
Distribution: ubuntu derivative
Posts: 157

Rep: Reputation: 28
So here is your problem "(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found"

That means that there is no videomode available for your configuration! Now edit your x.org configuration. In the console give "xorgconfig" without quotes. This will configure xorg from the begin. This is very simple so if it doesn;t work try to edit xorg.conf with a text editor. with nano give "nano /etc/X11/xorg.conf" without quotes as root. Try to modify hortizonal sync or refresh rate or colour depth or monitor width!
 
Old 08-16-2010, 02:09 PM   #5
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 399Reputation: 399Reputation: 399Reputation: 399
I would actually recommend creating the xorg.conf file with 'Xorg -configure'. It will autodetect everything it can. You can try running Xorg at 1024x768, but you will need to drop your color depth to at least 16bpp. If you want to run at 24bpp, you'll have to adjust your resolution to something like 800x600. Either way, if you're not sure what to do, post the xorg.conf file that is created with 'Xorg -configure' and we'll see what we can do.

Adam
 
Old 08-16-2010, 04:28 PM   #6
XG5A
LQ Newbie
 
Registered: Aug 2010
Posts: 12

Original Poster
Rep: Reputation: 0
Thanks for the help. I really like the idea of autodetecting.... I'm not around the computer right this moment, but I'll try this out as soon as I can and report back. Thanks again for the help!
 
Old 08-17-2010, 11:34 AM   #7
XG5A
LQ Newbie
 
Registered: Aug 2010
Posts: 12

Original Poster
Rep: Reputation: 0
So I ran 'Xorg -configure', and it created xorg.conf.new in my home/user directory, which looks like:
http://sprunge.us/giRG

it then told me to run 'X -config /home/dave/xorg.conf.new' to test the server, which I did, and got the same error as before. it made a log, which looks like:
http://sprunge.us/FSLM


so, is this where I play around with "horizontal sync or refresh rate", and color depth and resolution? how would I do this in the xorg.conf.new file? I don't see where screen resolution is specified. also, do i need to move this xorg.conf.new file to /etc/X11 and rename it "xorg.conf" to get it to always take effect, if I do get it to work?

also, when i run 'xorgconfig' i get "command not found"

Last edited by XG5A; 08-17-2010 at 11:45 AM.
 
Old 08-17-2010, 11:58 AM   #8
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 399Reputation: 399Reputation: 399Reputation: 399
Quote:
Originally Posted by XG5A View Post
So I ran 'Xorg -configure', and it created xorg.conf.new in my home/user directory, which looks like:
http://sprunge.us/giRG

it then told me to run 'X -config /home/dave/xorg.conf.new' to test the server, which I did, and got the same error as before. it made a log, which looks like:
http://sprunge.us/FSLM


so, is this where I play around with "horizontal sync or refresh rate", and color depth and resolution? how would I do this in the xorg.conf.new file? I don't see where screen resolution is specified.
It's not specified, but we might have to. First, try this as /etc/X11/xorg.conf:

http://sprunge.us/KjaX

The only difference between this xorg.conf and the xorg.conf.new file you posted is a single line that defines the DefaultDepth as 16.
Quote:

also, when i run 'xorgconfig' i get "command not found"
Yeah, that was bad advise from the other poster.

Adam
 
Old 08-17-2010, 12:14 PM   #9
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida panhandle
Distribution: slackware64-current, arch, ubuntu, others
Posts: 3,433

Rep: Reputation: 547Reputation: 547Reputation: 547Reputation: 547Reputation: 547Reputation: 547
In the driver section of your xorg.conf file change
Quote:
driver "siliconmotion"
to
Quote:
driver "vesa"
and see if that helps
 
Old 08-17-2010, 12:44 PM   #10
XG5A
LQ Newbie
 
Registered: Aug 2010
Posts: 12

Original Poster
Rep: Reputation: 0
driver "vesa" was not successful (returned the same error), but DefaultDepth 16 worked beautifully!! So, the computer now boots to the xubuntu gui
1 minor hitch, however, is that the keyboard doesn't work. I think it is configured wrong. The first time, when I was in the comand prompt with the correct xorg.conf file, and did 'startx', I booted to an xfce session, and it worked, but then when I booted to xubuntu, it doesn't work. I did notice an error message about the keyboard in X -config when I tried driver "vesa". maybe the keyboard is also configured wrong? Ideas?
Thanks, again, for the help, too!
 
Old 08-17-2010, 12:49 PM   #11
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 399Reputation: 399Reputation: 399Reputation: 399
Hmmm... Try adding this one line to the ServerLayout section:

Option "AutoAddDevices" "False"

If your keyboard isn't working, it likely isn't getting detected by hal (or hal just isn't running). That option should force X to use the InputDevice sections in your xorg.conf file.

Adam
 
Old 08-17-2010, 04:47 PM   #12
XG5A
LQ Newbie
 
Registered: Aug 2010
Posts: 12

Original Poster
Rep: Reputation: 0
server layout section of xorg.conf?
 
Old 08-17-2010, 06:40 PM   #13
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 399Reputation: 399Reputation: 399Reputation: 399
Correct.

Adam
 
1 members found this post helpful.
Old 08-18-2010, 09:37 PM   #14
XG5A
LQ Newbie
 
Registered: Aug 2010
Posts: 12

Original Poster
Rep: Reputation: 0
So, I went to boot up to try this, and the keyboard works. So, besides a few minor tweaks, everything is working great! Who knew an old computer could work so well. I'm really beginning to like this linux thing...
 
Old 09-01-2010, 01:49 PM   #15
XG5A
LQ Newbie
 
Registered: Aug 2010
Posts: 12

Original Poster
Rep: Reputation: 0
So as a follow up question:
The computer is functional now, and xfce loads on startup. However, the cpu is always at 100%, even with simple jobs like web browsing and word processing. Running "top" in the command line shows that the xorg process is using 20-30% of the cpu time, all the time. So, i'm wondering if the xorg.conf file is still configured wrong, somehow. I have a feeling I need that processor time to make the computer useable, since it only has a 700Mhz processor.
Any ideas?

As a footnote, the computer only has 192Mb of ram, so i'm wondering what I can do to keep that free, too.

Last edited by XG5A; 09-01-2010 at 01:51 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
xubuntu - Gui tool for sharing a folder? cyent Ubuntu 2 07-20-2012 04:31 AM
xubuntu doens’t launch GUI ??? cosinus2000 Ubuntu 5 05-07-2009 12:32 PM
Xubuntu GUI not running on old Toshiba laptop mrtumnus Linux - Laptop and Netbook 3 09-04-2008 08:36 AM
xubuntu installation without CD iqbal Ubuntu 9 07-02-2008 03:46 PM
Xubuntu Installation Help! Pranthan Ubuntu 1 02-04-2007 04:32 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook

All times are GMT -5. The time now is 11:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration