LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   xserver fails after system updates - 9.04 Jaunty Ubuntu (https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/xserver-fails-after-system-updates-9-04-jaunty-ubuntu-725234/)

jasma12 05-11-2009 12:19 PM

xserver fails after system updates - 9.04 Jaunty Ubuntu
 
Hey all.
My newly built 9.04 Jaunty Ubuntu on a Wind U120 was working swimmingly for the past month until system updates this past weekend.
Now I can get boot up and past Post, up the the beginning of the desktop window, and the icon on the screen is the white ball spinning around.... and around.... and around... but no login box. It just won't turn that corner and give me the login box. Sometimes it will crash and restart a few times, other times it will sit with the spinning white ball for hours. I cannot get the login window.
I've tried sudo vi /etc/X11/xorg.conf, but there is no resolution settings in this file. It just shows under:
Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
EndSection


This is the syntax verbatim. Where else can I look to find my current resolution and what is the command to edit/fix it (back to 1024x600)?

If I am technically getting X to start, being almost at the login box with the white ball spinning around, is this really the issue?

I would like to see on my screen and verify what resolution it is attempting to start at.

Any assistance please??????

Thanks,
jasma12

repo 05-11-2009 12:23 PM

try
Code:

sudo dpkg-reconfigure xserver-xorg

jasma12 05-11-2009 12:38 PM

Thanks for the reply.

I have tried that one and the one that ends in 'freex86' or something similar.

No luck though and I'm just not figuring out where my actual resolution is stored, and in what file it is stored?

At the spinning white boot up where it sits and spins, I hit CTRL+ALT+F1, login, su, login....
This is where I tried to reconfigure xserver-xorg and the other commands I have so far tried.
When running the sudo dpgk-reconfigure xserver-xorg I go through the prompts. I've done it twice now, once picking NO to all the questions and rebooting and now once picking YES to all the questions and rebooting. When I type startx I get:
X: warning: process set to priority -1 instead of priority 0

Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.XO-lock and start again.

ddxSigGiveUp: Closing log
Invalid MIG-MAGIC-COOKIE-1 keygiving up.
xinit: Resource temporarily unavailable (errno 11): unable to connect to X server
xinit: No such process (errno 3): Server error.


Thanks for any help.
And what file can I find specifically what resolution X is trying to boot to? xorg.conf does not have any resolutions in it.

Thanks,
jasma12

jasma12 05-11-2009 02:24 PM

This is the xserver warning I get sometimes, not on every boot, but maybe half of them:

""the display server has been shut down about 6 times in the last 90 seconds. it is likely that something bad is going on. waiting for 2 minutes before trying again on display :0.""



I've also tried mv gdm.conf to try to force it to rebuild but nothing has made this thing budge at all.

anyone got any advice?

farslayer 05-11-2009 02:24 PM

You realize you don't need to reboot every time right ? This is Linux not Windows..

CTRL+ALT+BACKSPACE
- Kills Xserver
startx - will start the X server


My advice would be to get the specs for your monitor determine the resolution and refresh you want and use a Modeline to configure it on your system..

jasma12 05-11-2009 02:30 PM

somewhat correct, but yes farslayer, and I think that I do realize this is not Windows. however, ctrl+alt+backspace does nothing on the u120 with ubuntu 9.04.
I know my resolution is 1024x600 and on default graphics on the wind.

never heard of modeline, but I may give it a shot.

jasma12

jasma12 05-11-2009 02:45 PM

Also I have tried, among other things:



sudo dpkg-reconfigure gdm
sudo dpkg-reconfigure gnome-desktop-data
sudo dpkg-reconfigure gnome-control-center
sudo dpkg-reconfigure gnome-menus
sudo dpkg-reconfigure gnome-system-tools
sudo dpkg-reconfigure gnome-applets
sudo dpkg-reconfigure gnome-session

farslayer 05-11-2009 03:49 PM

Xserver configuration is done automatically these days, manually trying to reconfigure those packages is not going to accomplish anything productive for you..

Modeline


CTRL+ALT+BKSPC does kill the X-server, but if you are already sitting at a console, it won't do anything, because there is nothing to kill...


How to see what Graphics module X detected and is using, I believe it should be intel for most of the netbooks..
cat /var/log/Xorg.0.log | grep autoconfigured



If everything was working and an update caused this issue, it could be a bug in one of the updated packages...

tommcd 05-14-2009 01:37 AM

Quote:

Originally Posted by farslayer (Post 3537454)
CTRL+ALT+BKSPC does kill the X-server

Not in Ubuntu with 9.04. For whatever reason ctrl + alt + back_space has been disabled in Ubuntu 9.04. You can get it back by installing dontzap and running:
Code:

dontzap --disable
See "Ctrl-Alt-Backspace disabled by default in Xorg" in the 9.04 release notes:
http://www.ubuntu.com/getubuntu/releasenotes/904
EDIT: This has been apparently been disabled to avoid "accidentally triggering the key combination". Well, when was the last time any of you accidentally triggered that key combination? Is this supposed to be helpful? To me it seems like a hinderance.

farslayer 05-14-2009 07:32 AM

Quote:

Originally Posted by tommcd (Post 3540194)
Not in Ubuntu with 9.04. For whatever reason ctrl + alt + back_space has been disabled in Ubuntu 9.04. You can get it back by installing dontzap and running:
Code:

dontzap --disable
See "Ctrl-Alt-Backspace disabled by default in Xorg" in the 9.04 release notes:
http://www.ubuntu.com/getubuntu/releasenotes/904
EDIT: This has been apparently been disabled to avoid "accidentally triggering the key combination". Well, when was the last time any of you accidentally triggered that key combination? Is this supposed to be helpful? To me it seems like a hinderance.

Interesting.. now why in the hell would they do that ? I agree that seems like a stupid move. You start your system X fails you get a black screen and have no quick easy way to kill X by default ? The most common time you would use that key combination is at initial install time.. GENIUS !! I can't say I have EVER accidentally triggered it.. in the beginning I couldn't even remember what it was and tried numerous combinations trying to hit it and failed..

Thanks for the info.. all I can do is shake my head and wonder what they are thinking.


I stand corrected.


All times are GMT -5. The time now is 11:08 AM.